Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The joy of Windows Update: Gremlins in udfs.sys causing BSOD?

06 Jan 2015   #1

Windows 7 professional 64-bit
The joy of Windows Update: Gremlins in udfs.sys causing BSOD?

Long version:
So, I started 2015 with this idea of having a nice fresh, newly updated windows computer on my desktop. After all, it had been nagging me for a while with that little annoying "Updates installed, need to reboot" box. You know the one you always press "later" on...

So, I decided to actually reboot the system. That, I should not have done!

The system slowly grind to a halt and locked up about half way through the reboot process. After waiting for an hour or so, and concluding that the system was locked up (no response to num lock) I rebooted the old fashioned way

Aaaaand the system slowly started. Only to reboot halfway through the boot process. Boot into recovery. It says that recovery can not help me. Clearly I am on my own here. Boot into rescue. The system hangs about halfway (CLASSPNP.sys). Somewhere in the back of my mind I remembered that this driver was related to AHIC, so I swapped over to IDE and got the system to boot into rescue. It cleaned up some stuff related to the update on boot, and another reboot (with AHIC) gave me access to all hard disks in rescue, as well as networking.

Another try to boot normally gave me a BSOD again, with a very non-descriptive error (0x000007e). Booting with logging enabled showed the last driver to be loaded to be udfs.sys. And at this point I am stuck. As far as I can tell this driver was not changed in the update. Anybody have any idea how to sort out this mess?

Short version:
* System hang on reboot after AU
* No help from boot recovery or system restore (only lists one restore point)
* BSOD in CLASSPNP.sys on rescue, solved by swapping to IDE and then back to AHIC
* Keeps giving a BSOD on normal boot.
* Last loaded driver according to boot log is udfs.sys
Help? Pretty please?

My System SpecsSystem Spec
06 Jan 2015   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

There is no crash dump. Most probably because of this fact ....
  Log Name: System
  Source: volmgr
  Date: 2015-01-06T13:30:06.201
  Event ID: 45
  Task: N/A
  Level: Error
  Opcode: N/A
  Keyword: Classic
  User: N/A
  User Name: N/A
  Computer: overlord
The system could not sucessfully load the crash dump driver.
There may be many a reasons behind it; but one very possible reason is that yorr SSD is running out of free space.
Drive C:
Size 74,43 GB (79 919 312 896 bytes)
Free Space 2,75 GB (2 950 840 320 bytes)
If you can free up some space (at least 10%, that is 8 GB more or less), then probably the situation will be some better, at least we will get a crash dump to analyze for the reason behind the BSOD.
My System SpecsSystem Spec
06 Jan 2015   #3

Windows 7 professional 64-bit

Okay, I spent some quality time cleaning up space on the disk. I also tried to figure out why the minidumps where not written. Turned out that if the swap file is on another partition no minidump is written. So I moved the swap to the boot disk, and triggered the BSOD again. It claims to have written a dump, but I can't seem to find any minidump file. It's neither in the windows/Minidump dir, nor is it created in another folder when I changed the path in the system settings.

Any idea? I am attaching a new dump of the logs also.
My System SpecsSystem Spec

07 Jan 2015   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Do these two things as two must to follow precautions ....
Daemon Tools, Alcohol 120% and Power Archiver Pro uses SCSI Pass Through Direct (SPTD), which is a well known BSOD causer. Uninstall the program at first. Then download SPTD standalone installer from, and execute the downloaded file as guided below :
  • Double click to open it.
  • Click this button only:
  • If it is grayed out, as in the picture, there is no more SPTD in your system, and you just close the window.
Free up the startup. Windows does not need any other program to auto start with it, but the auto start programs often conflicts and causes various problems including BSODs.
  1. Click on the Start button
  2. Type “msconfig (without quotes), click the resulting link. It will open the System Configuration window.
  3. Select the “Startup” tab.
  4. Deselect all items other than the antivirus.
  5. Apply > OK
  6. Accept then restart.
Now, if it BSODs again, take a camera snap of the blue screen and upload it here. May be that the onscreen codes will give us some hint about the situation.
My System SpecsSystem Spec
07 Jan 2015   #5

Windows 7 professional 64-bit

Done and done. SPTD was not installed, or was removed along with daemon tools. Removing startup items feels like it is a little later in the boot process, but was good to try. No effect however.

Attached is a picture of the BSOD. Note that while it claims to have dumped physical memory I can't find any file on disk after rebooting...
My System SpecsSystem Spec
07 Jan 2015   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Really strange. The screen says that the crash dump is recorded.

Anyway, it is a stop 0x7E. And, as we dont have a clue right now, let us check all the probable causes?


Usual causes:
Insufficient disk space, Device driver, Video card, BIOS, Breakpoint with no debugger attached, Hardware incompatibility, Faulty system service, Memory, 3rd party remote control

ATM you have almost 13 GB free, which should be enough.

Stress test the Graphics Card using Furmark.
Video Card - Stress Test with Furmark
Take a screenshot of the furmark window before closing it. Upload the screenshot for us.

Apply the FD BIOS from GIGABYTE - Motherboard - Socket 1366 - GA-X58A-UD7 (rev. 2.0)

Test your RAM modules for possible errors.
How to Test and Diagnose RAM Issues with Memtest86+
Run memtest86+ for at least 8 consecutive passes.

If it start showing errors/red lines, stop testing. A single error is enough to determine that something is going bad there.

Run SFC /SCANNOW Command - System File Checker

Let us know the results.

** Edit: Also make it sure that your SSD is running with the latest firmware.
How to Upgrade Intel SSD Firmware | - Storage Reviews
My System SpecsSystem Spec
07 Jan 2015   #7
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Could you do this tutorial by Golden so Arc can have a look.

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec
07 Jan 2015   #8

Windows 7 professional 64-bit

Here is a screen shot of the disks system. SFC reported no errors. I will run memtest overnight, but the fact that the boot consistently fails at the same point in the boot makes me suspect it is not a random error, but something in the drivers
My System SpecsSystem Spec

 The joy of Windows Update: Gremlins in udfs.sys causing BSOD?

Thread Tools

Similar help and support threads
Thread Forum
Windows Update is causing cpu to run at 100%
My computer was running very slowly. I went to Task Manager and looked at the processes running. Nothing showed a very high percentage. I looked at "All Processes" and found that the svchost.exe file was using 100% of the cpu. I checked my computer for viruses, Avast found nothing. I checked for...
Performance & Maintenance
Windows Update(s) causing BSOD
Hi Guys, As mentioned in the title, I'm getting a BlueScreen after doing my latest round of Windows Updates. I'm sure its one (or multiple) update(s) causing the problem because after I did a system restore, I've regained stability. After the first BSOD, I updated my BIOS and confirmed all...
BSOD Help and Support
Windows 7 SP1 update failed, causing Windows Update errors
Hi, Running IE 9 and tried to update to IE 11. Said I needed to update my Windows 7, 64 to SP1. found the update and attempted to install. Install failed and message said "restart your computer and try again" tried again and it failed again. Now Windows Update cannot update the PC, error message...
Windows Updates & Activation
New Windows update causing launch failure
Hey guys. I really need help with this. When I install these new Windows 7 updates, and shut down the computer, Windows won't launch. So I always have to do the startup repair option, which is getting annoying. I've attached a screenshot of the updates, and I wanted to know which one(s) were...
Windows Updates & Activation
serious crash Gremlins in the works?
Well what a day I will begin I have linux kubuntu on one of my ssd drives seperate to windows 7 and I was updating it today when horror a power cut pc went off 10 mins. My ups kicked in and hibernated the system for me so when power was restored I booted up. Could not boot into kubuntu to start...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:58.
Twitter Facebook Google+