Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when using internet with Ethernet cable

30 Mar 2015   #1

Windows 7 Pro 64bit
BSOD when using internet with Ethernet cable

Hello all,

I am getting a BSOD whenever i use the internet while connected with an ethernet cable. When I am online via wifi however I do not get the error message.

I am noticing that I am getting information in the BSOD regarding anodlwfx.sys

I have attached the zip file. Any help would be greatly appreciated!
My System SpecsSystem Spec
30 Mar 2015   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi usurp.

Do you use the D-Link one? If not disable it. If you ever use it, update the driver to D-Link DWA-125 Wireless N 150 USB Adapter(rev.A2) from D-Link Technical Support

Also update the driver to realtek ethernet. Go to .... get the 4th item of the list (the "Win7 and Server 2008 R2 Auto Installation Program" one) and install it.

Report us for any further BSOD.
BugCheck D1, {fffff880056d1048, 2, 0, fffff88003eff875}

*** WARNING: Unable to verify timestamp for anodlwfx.sys
*** ERROR: Module load completed but symbols could not be loaded for anodlwfx.sys
*** WARNING: Unable to verify timestamp for Rt64win7.sys
*** ERROR: Module load completed but symbols could not be loaded for Rt64win7.sys
Probably caused by : anodlwfx.sys ( anodlwfx+2875 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: fffff880056d1048, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88003eff875, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800030b3100
GetUlongFromAddress: unable to read from fffff800030b31c0
 fffff880056d1048 Nonpaged pool


fffff880`03eff875 8b040a          mov     eax,dword ptr [rdx+rcx]





ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre


TRAP_FRAME:  fffff88003399440 -- (.trap 0xfffff88003399440)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa8007771298 rbx=0000000000000000 rcx=fffffa8007771860
rdx=fffffdfffdf5f7e8 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88003eff875 rsp=fffff880033995d8 rbp=fffff880056d0a80
 r8=00000000000005cc  r9=0000000000000000 r10=00450008ce3c6211
r11=fffffa8007771298 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`03eff875 8b040a          mov     eax,dword ptr [rdx+rcx] ds:fffff880`056d1048=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e79469 to fffff80002e79ec0

fffff880`033992f8 fffff800`02e79469 : 00000000`0000000a fffff880`056d1048 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`03399300 fffff800`02e780e0 : 00000001`00000000 00000000`00000000 00000000`00000000 fffffa80`07492af8 : nt!KiBugCheckDispatch+0x69
fffff880`03399440 fffff880`03eff875 : fffff880`03eff490 00000000`00000028 fffff800`02faf1ee fffffa80`0773e920 : nt!KiPageFault+0x260
fffff880`033995d8 fffff880`03eff490 : 00000000`00000028 fffff800`02faf1ee fffffa80`0773e920 fffffa80`07740bb0 : anodlwfx+0x2875
fffff880`033995e0 00000000`00000028 : fffff800`02faf1ee fffffa80`0773e920 fffffa80`07740bb0 fffffa80`074929f0 : anodlwfx+0x2490
fffff880`033995e8 fffff800`02faf1ee : fffffa80`0773e920 fffffa80`07740bb0 fffffa80`074929f0 fffff880`03efeb99 : 0x28
fffff880`033995f0 fffff880`018e44d0 : 00000000`00000000 00000000`00000028 fffffa80`00000001 00000000`000007ff : nt!ExAllocatePoolWithTag+0xfe
fffff880`033996e0 fffff880`03eec505 : 00000000`00000000 00000000`00000000 00000000`00000001 00000000`00000006 : ndis!NdisAllocateNetBufferListContext+0x60
fffff880`03399710 fffff880`018fc0a7 : 00000000`00000000 fffffa80`06ccc1a0 00000000`00000000 00000000`00000000 : vpcnfltr!FilterReceiveNetBufferLists+0x60d
fffff880`033997b0 fffff880`0f416c50 : fffffa80`07458000 00000000`00000006 fffffa80`07458618 00000000`00000000 : ndis! ?? ::FNODOBFM::`string'+0xcd8f
fffff880`03399800 fffffa80`07458000 : 00000000`00000006 fffffa80`07458618 00000000`00000000 00000000`00000001 : Rt64win7+0x16c50
fffff880`03399808 00000000`00000006 : fffffa80`07458618 00000000`00000000 00000000`00000001 fffffa80`09b4d830 : 0xfffffa80`07458000
fffff880`03399810 fffffa80`07458618 : 00000000`00000000 00000000`00000001 fffffa80`09b4d830 00000006`09b48000 : 0x6
fffff880`03399818 00000000`00000000 : 00000000`00000001 fffffa80`09b4d830 00000006`09b48000 ffff0000`00000006 : 0xfffffa80`07458618


fffff880`03eff875 8b040a          mov     eax,dword ptr [rdx+rcx]


SYMBOL_NAME:  anodlwfx+2875

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: anodlwfx

IMAGE_NAME:  anodlwfx.sys


FAILURE_BUCKET_ID:  X64_0xD1_anodlwfx+2875

BUCKET_ID:  X64_0xD1_anodlwfx+2875


FAILURE_ID_HASH_STRING:  km:x64_0xd1_anodlwfx+2875

FAILURE_ID_HASH:  {4614fb58-4f4f-1189-1a8f-278dd5fb8bec}

Followup: MachineOwner

2: kd> lmvm anodlwfx
start             end                 module name
fffff880`03efd000 fffff880`03f06000   anodlwfx T (no symbols)           
    Loaded symbol image file: anodlwfx.sys
    Image path: \SystemRoot\system32\DRIVERS\anodlwfx.sys
    Image name: anodlwfx.sys
    Timestamp:        Fri Mar 06 15:40:08 2009 (49B0F680)
    CheckSum:         0000A8C3
    ImageSize:        00009000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
2: kd> lmvm rt64win7
start             end                 module name
fffff880`0f400000 fffff880`0f4a0000   Rt64win7 T (no symbols)           
    Loaded symbol image file: Rt64win7.sys
    Image path: \SystemRoot\system32\DRIVERS\Rt64win7.sys
    Image name: Rt64win7.sys
    Timestamp:        Tue Sep 27 20:20:33 2011 (4E81E2B9)
    CheckSum:         0009FB77
    ImageSize:        000A0000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Internet won't connect with ethernet cable.
Hey everyone, got an issue that's stumping me. I bought a new computer here at work, and am having issues getting the ethernet port to work. I know the port itself works because it worked on Windows 7 when I first got the computer, but when I got it, I immediately did a clean install of Windows...
General Discussion
Can't connect to the internet through ethernet cable. No driver?
I cannot connect to the internet with my ethernet cable. The signal is broadcasting fine from my router, so I can connect with my wireless card, but I would rather do it directly with the ethernet. My computer fails to recognize any cable I put in and it says it's missing the driver. Windows can't...
Network & Sharing
Cant connect to internet with ethernet cable.
I cant connect to internet with ethernet cable it doesnt even show my cable is plugged in. The cable is okey i tried other computer and i got in internet with it. if i restart my computer it comes back for like 5 -10 mins then it disappears again shows that the cable isnt plugged in and if i...
Network & Sharing
How do I connect laptop to internet through the ethernet cable?
my 3 year old Dell Studio laptop connects fine via wireless to home router and internet; but I cannot connect through the ethernet cable. I've done the troubleshooting; disabled/enabled the network adapter; updated the drivers. I'm using an ethernet cable which normally connects an XP, so I know...
Network & Sharing
ethernet cable screwed up wireless internet?
Hi all, I am running an IBM T60P. with Windows 7. a Cisco Router "linksys E3000" My wireless has been running fine for the last few years. (win xp and win 7) Today I wanted to try something (I knew it wouldn't work but figured what the hell" I plugged in an ethernet cable and hooked it up...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:06.
Twitter Facebook