Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD upon repair mode, UBS boot disk created but no repair option

01 Apr 2015   #1

Windows 7 Home Premium x64
BSOD upon repair mode, UBS boot disk created but no repair option

Hi all - my laptop refuses to boot and when I start in repair mode I get the BSOD with just the cursor visible and nothing happens.

If I reboot in safe mode then it hangs at windows\system\drivers\bootdefragdriver.sys

I have researched and believe this driver is linked to Glarys Utilities, but am obviously unable to uninstall the program or driver because I can't boot into Windows.

I therefore downloaded an ISO file and created a USB boot disk (as per one of your tutorials) with the intention of rebooting into repair mode, but when I boot from the USB and press F8, there is no repair mode option. All it does it try to reinstall windows from scratch, which I am reluctant to do.

Does anybody have any suggestions of how I can either delete the bad driver (if that is indeed the problem) or how I can still get into repair mode from the USB drive?

Many thanks
My System SpecsSystem Spec
02 Apr 2015   #2
SGT Oddball


I think if you don't want to reinstall then you could try booting the laptop with a Linux live cd/usb and renaming/deleting bootdefragdriver.sys and seeing if that helps

Peppermint Live CD/DVD/USB - Create for Emergency Backup
My System SpecsSystem Spec
03 Apr 2015   #3

Windows 7 Home Premium x64

Hi - I've now tried that and upon booting from the USB, it starts to load Peppermint setup but then the screen goes completely black and nothing else happens.

Furthermore, if I then try and boot from the hard drive again, I just get a flashing white cursor in the top left of a black screen and it hangs indefinitely. I can't even use the F8 menu anymore to try safe mode etc.

Have you got any other ideas? I really hope I haven't lost all my data permanently.

My System SpecsSystem Spec

03 Apr 2015   #4
Microsoft MVP

Windows 10 Pro x64 ; Xubuntu x64

Please try and create a new bootable version of the PepperMint USB or sounds like you got a bad installer.

Once booted, follow the rest of the tutorial to backup any data.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
windows 7 start only in safe mode and the repair option is missing
Hi first of all sorry for my bad English... I can not start the computer in normal mode, only in safe mode I tried system restore but still I can not run Windows 7 in normal mode When I press f8 at startup option to repair your computer is not listed as an option. i tried system restores...
Performance & Maintenance
SMART disk drive error-can't access Advanced Boot Options repair mode
My system is showing an internal hard drive error and F8 advanced boot options page doesn't appear to exist anymore (lost recovery via F8). That limits my troubleshooting. The system is a Dell Inspiron 560 desktop with core 2 quad Q8300 CPU at 2.5 ghz. 6.144 GB of RAM with DDR3 SDRAM. It's 3...
Hardware & Devices
Can I run a Windows 7 repair disk that was created on a different PC?
I have an issue with my desktop PC. I believe I have a corrupted system file since the HDD is no longer bootable; however I have been able to remove the infected drive and install it as a slave on my HTPC. This has allowed me to backup all my important files. My question... I'd like to run a...
Installation & Setup
Advanced boot with repair partition does not show repair option.
(first, I posted this on windows7forums two weeks ago, and no one replied. I'm not sure why) Hello. My friend recently encountered the error "Disk read error occurred." It seems to be because her MBR is damaged, according to other forums I've read, and a partition recovery program that listed...
General Discussion
System repair disk could not be created
Win7Pro64. Using recdisc.exe, Getting error message "The parameter is incorrect. (0x80070057)" CD/DVD drive works fine. SFC shows no problems. System working OK. Any help appreciated.
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:23.
Twitter Facebook