Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bad_Pool_Header 0x00000019 after wake up

21 Apr 2015   #1

Windows 7 Home Premium 64bit
Bad_Pool_Header 0x00000019 after wake up

Dear Sevenforums members,

English is not my native language, but I'll try to explain myself.
I've had some BSOD's after waking up my computer from sleep mode.
I've searched for some solutions but I don't know which driver is the cause of this error.
When it's active there have been no problems.

I've added my zip file.

If someone could look at it, it'll be appreciated.
My System SpecsSystem Spec
21 Apr 2015   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi JohnnyG.

Use the Intel® Driver Update Utility and search for any possible update for Intel(R) 82579V Gigabit Network driver. The last few BSODs are caused by it, and it is somehow old.

Let us know the result.
BugCheck 19, {20, fffffa80081c7c40, fffffa80081c7d60, 4120008}

*** WARNING: Unable to verify timestamp for e1c62x64.sys
*** ERROR: Module load completed but symbols could not be loaded for e1c62x64.sys
Probably caused by : e1c62x64.sys ( e1c62x64+1bec2 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 0000000000000020, a pool block header size is corrupt.
Arg2: fffffa80081c7c40, The pool entry we were looking for within the page.
Arg3: fffffa80081c7d60, The next pool entry.
Arg4: 0000000004120008, (reserved)

Debugging Details:

BUGCHECK_STR:  0x19_20

POOL_ADDRESS: GetPointerFromAddress: unable to read from fffff800034b7100
GetUlongFromAddress: unable to read from fffff800034b71c0
 fffffa80081c7c40 Nonpaged pool





ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre

LAST_CONTROL_TRANSFER:  from fffff800033b2cbe to fffff8000327dec0

fffff880`0a060da8 fffff800`033b2cbe : 00000000`00000019 00000000`00000020 fffffa80`081c7c40 fffffa80`081c7d60 : nt!KeBugCheckEx
fffff880`0a060db0 fffff880`016b5195 : 00000000`fffeffff 00000000`00000000 00000000`51314549 fffffa80`06cf3600 : nt!ExFreePool+0xd8a
fffff880`0a060e60 fffff880`04135ec2 : 00000000`00000010 fffff880`017295ff 00000000`00000010 00000000`00010246 : ndis!NdisFreeMemory+0x15
fffff880`0a060e90 00000000`00000010 : fffff880`017295ff 00000000`00000010 00000000`00010246 00000000`00000000 : e1c62x64+0x1bec2
fffff880`0a060e98 fffff880`017295ff : 00000000`00000010 00000000`00010246 00000000`00000000 00000000`00000000 : 0x10
fffff880`0a060ea0 fffffa80`07adf000 : 00000000`00000000 fffff880`04149c56 00000000`00000004 fffff880`016af8ef : ndis!ndisMiniportPreRemoveWOLPattern+0xf
fffff880`0a060ed0 00000000`00000000 : fffff880`04149c56 00000000`00000004 fffff880`016af8ef 00000000`00000000 : 0xfffffa80`07adf000


fffff880`04135ec2 ??              ???


SYMBOL_NAME:  e1c62x64+1bec2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: e1c62x64

IMAGE_NAME:  e1c62x64.sys


FAILURE_BUCKET_ID:  X64_0x19_20_e1c62x64+1bec2

BUCKET_ID:  X64_0x19_20_e1c62x64+1bec2


FAILURE_ID_HASH_STRING:  km:x64_0x19_20_e1c62x64+1bec2

FAILURE_ID_HASH:  {2bdb3d26-cacf-ebd0-bf25-d32ebc771694}

Followup: MachineOwner

1: kd> lmvm e1c62x64
start             end                 module name
fffff880`0411a000 fffff880`04193000   e1c62x64 T (no symbols)           
    Loaded symbol image file: e1c62x64.sys
    Image path: \SystemRoot\system32\DRIVERS\e1c62x64.sys
    Image name: e1c62x64.sys
    Timestamp:        Sat Aug 11 04:14:15 2012 (50258EBF)
    CheckSum:         000829CE
    ImageSize:        00079000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
21 Apr 2015   #3

Windows 7 Home Premium 64bit

Thank you, I wasn't aware of the fact that the driver wasn't updated.

Will post results if something like this happens again.
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
Hey So I got my German uncle's laptop, and by default it was in german. I installed Windows live essentials and the English language to change it, it told me to restart and I did. When it opened again the blue screen showed up on the "welcome" screen (which was still in German) I tried opening...
BSOD Help and Support
Hello to all! This is my first post so please bear with me. I have had previous blue screens in the past but have not been able to read the error name in time, this one took time to compile the memory dump; therefore I had finally enough time to read it. This error appeared after defragmenting and...
BSOD Help and Support
BSOD BAD_POOL_HEADER error 0x00000019
Hi all, I've been getting hit with Bad pool header BSODs for a few days now. It just started recently, and no new hardware has been installed (aside from plug and play headphones getting plugged and unplugged every so often which never seemed to cause a problem before. Unfortunately, my...
BSOD Help and Support
System freezes, then restarts then blue screens. Performed operating re-installation already, but still does not work. Please advise. Thanks
BSOD Help and Support
I've got a Asus G75V running windows 7 that's barely 3 months old but I've been plagued with BSODs since about week 3. About 12 so far. The first half dozen were solved when I changed my modem/router, but now there seems to be a new issue. I've had 5 error code 19's and the seem to be getting...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:16.
Twitter Facebook