Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Bug in Windows Explorer: Doubleclick doesn't work

08 Nov 2009   #1
taurus7050

Win 7 RC
 
 
Bug in Windows Explorer: Doubleclick doesn't work

Trying to open an Excel sheet with a doubleclick in Windows Explorer I always get the following message: An error occurred in sending the command to the application. Error Number: 1156 (0x484). Error Code: ERROR_DDE_FAIL.
The files are ok, I can open them from Excel. The file association with Excel is ok too. SFC doesn't find any corrupted files, reinstallation of MS Office 2003 doesn't solve the problem.
It seems to be a Win7 bug because it occurs on several computers with Win7 Ultimate 32bit (final). I didn't have the problem in Vista and on Win7 Beta and RC. Disabling the Windows firewall and anti-virus-software provides no help. Other filetypes (doc, jpg, txt) aren't affected.

Many thanks for any assistance and kind regards
Taurus


My System SpecsSystem Spec
.
08 Nov 2009   #2
H2SO4

Win7x64
 
 

It's not a bug. Make sure you haven't configured Excel to "ignore DDE requests". The setting is somewhere in Excel options.

DDE is an ancient mechanism but it's still used as a message-passing conduit by some of the Office apps. They register file-specific handlers which make the act of double-clicking one of those files (in Explorer) send a DDE message to the app to tell it that somebody just double-clicked the file.

In your case, the error message is effectively saying "I sent the DDE message but it seems nobody was listening at the Excel end". Hence, make sure you haven't configured Excel to ignore DDE. Look up the setting in Excel help if necessary.
My System SpecsSystem Spec
09 Nov 2009   #3
taurus7050

Win 7 RC
 
 

Thanks for your assistance. But in Excel and the whole Office package I can't find any option to influence the DDE settings.

I have 3 computers with Win7 Ultimate 32bit final and Office 2003. The problem occurs on two of them. So I have imported the DDE registry settings from the laptop, which works fine, to one of the affected notebooks and restarted Windows. Now I get the message "Wrong parameter" when I try to open an Excel file from Windows Explorer.
My System SpecsSystem Spec
.

09 Nov 2009   #4
taurus7050

Win 7 RC
 
 

Problem solved: Excel | Options | General - I've deactivated the setting "Ignore other applications". Many thanks for the tip about the Excel-Options.
My System SpecsSystem Spec
09 Nov 2009   #5
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by taurus7050 View Post
Problem solved: Excel | Options | General - I've deactivated the setting "Ignore other applications". Many thanks for the tip about the Excel-Options.
Glad to hear it's all working now :)
My System SpecsSystem Spec
Reply

 Bug in Windows Explorer: Doubleclick doesn't work




Thread Tools




Similar help and support threads
Thread Forum
Netflix doesn't work on Windows 7 Internet Explorer
Symptom: Netflix movie thumbnails (including their links) don't show up. There's one "dash" per row in their place that turns into finger on mouseover but doesn't do anything. However you still see the arrow navigation controls with "page indicator". Works on Chrome. Failed attempts to...
Software
Search doesn't work in Windows explorer
The search in Windows explorer has been working inconsistently in my mother's computer for as long as I remember. There are several folders where no results are displayed whatsoever, no matter what you search for. Solutions I've tried so far: Using the Windows built in Troubleshooter for...
Performance & Maintenance
Windows Explorer doesn't work after resuming from sleep
Hello, I have a Dell XPS L702X (i5 -2.3 Ghz, 6GB RAM) laptop running Windows 7 Home Premium 64-Bit that has been giving me issues for some time now and I haven't been able to find a solution. Windows explorer works fine when I start the computer. However, after resuming from sleep, 90% of the...
General Discussion
[HELP] Internet Explorer 10 doesn't work with some custom shell32.dll
I've modified the icons in my shell32.dll using Resource Hacker and when I've applied it Internet Explorer fails to start. It gives an error which reads, "iexplore.exe - Entry Point Not Found" The procedure entry point shell32.SetCurrentProcessExplicitAppUserModeID could not be located in the...
Customization
Help WIN+E shortcut to explorer doesn't work!
All of a sudden here in my win7 build 7048 x64 my keyboard shortcut for explorer.exe win+e an error screen pops up saying this file does not have a program associated with it...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:19.
Twitter Facebook Google+