Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while playing games. Multiple Error codes

21 May 2015   #11

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That's rather confusing!
The file is definitely present, and appears to be OK - but Windows/SFC is not apparently seeing it. All permissions are as expected, and there are no obvious problems.

I can only think that there's a registry problem.

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or OneDrive) and post a link.

My System SpecsSystem Spec
21 May 2015   #12

Windows 7 pro x64

My System SpecsSystem Spec
22 May 2015   #13

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The problem is a missing entry in the registry...

I've uploaded a file - - to my OneDrive at Noel's OneDrive
Please download and save it to your desktop.
Right-click on the saved file and select Extract all...
Save it to the default location
This should create a file khaab.reg

right-click on the file, and select Merge
Accept the warnings, - you should then get a 'Success' message.
Close all windows, and reboot.

Run CheckSUR again, and post the new log.
My System SpecsSystem Spec

22 May 2015   #14

Windows 7 pro x64

I am getting an error messages that says "Cannot import C:\Windows\khaab.reg: Error accessing the registry.".
My System SpecsSystem Spec
22 May 2015   #15

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

OK - this should help...

Open an Elevated Command Prompt, and run the following command


Then try the registry merge again - it should work now.
My System SpecsSystem Spec
22 May 2015   #16

Windows 7 pro x64

File attached with results from latest SFC /scannow
My System SpecsSystem Spec
23 May 2015   #17

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Here's the new summary...
2015-05-22 13:01:22, Info                  CSI    00000352 [SR] Repairing 1 components
2015-05-22 13:01:22, Info                  CSI    00000353 [SR] Beginning Verify and Repair transaction
2015-05-22 13:01:22, Info                  CSI    00000354 Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\ do not match actual file [l:24{12}]"" :
  Found: {l:32 b:FAEZKiflOiLCOqAa0MS5v3+ESiId8lC76TIolP23ss8=} Expected: {l:32 b:6510UErwHGoFg3sRd3gzh3HSbTceuHem3Rnk0NraKS8=}
2015-05-22 13:01:22, Info                  CSI    00000355 [SR] Cannot repair member file [l:24{12}]"" of Microsoft-Windows-Unified-Telemetry-Client, Version = 6.1.7601.18839, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
So we solved one problem, and another has reared its head.

SFCFix Script

Warning: this fix is specific to the above corruptions only, do not run these fixes if you do not have these corrupt files.
  • Download SFCFix.exe (by niemiro) and save this to your Desktop.
  • Download from the below link, and save this to your Desktop. Ensure that this file is named – do not rename it.
  • download this version: SFCFix(x64version)
  • Save any open documents and close all open windows.
  • On your Desktop, you should see two files: SFCFix.exe and
  • Drag the file onto the file SFCFix.exe and release it.
  • SFCFix will now process the script.
  • Upon completion, a file should be created on your Desktop: SFCFix.txt.
  • Copy (Ctrl+C) and Paste (Ctrl+V) the contents of this file into your next post for me to analyse please – put tags around the log to break up the text.
  • Right click on the Start button
  • Click on Command prompt (Admin) => Press Yes on the prompt
  • Inside the Command Prompt windows copy and paste the following command SFC /SCANNOW
My System SpecsSystem Spec
23 May 2015   #18

Windows 7 pro x64

Output from FSCFix:

SFCFix version by niemiro.
Start time: 2015-05-23 09:00:11.018
Microsoft Windows 7 Service Pack 1 - amd64
Using .zip script file at C:\Users\kharma\Desktop\ [0]

Successfully took permissions for file or folder C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\diagtrack.dll
Successfully took permissions for file or folder C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\telemetry.asm-windowsdefault.json
Successfully took permissions for file or folder C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\
Successfully took permissions for file or folder C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\utcresources.dll

The file \\?\C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\diagtrack.dll is in use and must be replaced over a reboot.
Successfully copied file C:\Users\kharma\AppData\Local\niemiro\Archive\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\telemetry.asm-windowsdefault.json to C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\telemetry.asm-windowsdefault.json.
Successfully copied file C:\Users\kharma\AppData\Local\niemiro\Archive\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\ to C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\
Successfully copied file C:\Users\kharma\AppData\Local\niemiro\Archive\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\utcresources.dll to C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\utcresources.dll.

Successfully pended file for replace over reboot: \\?\C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\diagtrack.dll

Successfully restored ownership for C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\telemetry.asm-windowsdefault.json
Successfully restored permissions on C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\telemetry.asm-windowsdefault.json
Successfully restored ownership for C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\
Successfully restored permissions on C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\
Successfully restored ownership for C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\utcresources.dll
Successfully restored permissions on C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\utcresources.dll
PowerCopy:: directive completed successfully.

Reboot:: directive completed successfully.

No hash verification failures detected.
PostRebootCorruptionDetection:: directive completed successfully.

Successfully restored ownership for C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\diagtrack.dll
Successfully restored permissions on C:\Windows\winsxs\amd64_microsoft-windows-u..ed-telemetry-client_31bf3856ad364e35_6.1.7601.18839_none_fe0845bb1d97efda\diagtrack.dll
PostRebootRestorePermissions:: directive completed successfully.

Successfully processed all directives.
SFCFix version by niemiro has completed.
Currently storing 4 datablocks.
Finish time: 2015-05-23 09:02:08.269


Output from SFC SCANNOW:


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>SFC /SCANNOW

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

My System SpecsSystem Spec
23 May 2015   #19

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Lookin' good!

So - how is the system behaving now?
My System SpecsSystem Spec
23 May 2015   #20

Windows 7 pro x64

Right now it is working pretty well. Haven't had a blue screen since the last fix (which has only been half a day). I will wait a few more days and if nothing new happens I will go ahead and mark this as solved. Otherwise I will update this with any issues.
My System SpecsSystem Spec

 BSOD while playing games. Multiple Error codes

Thread Tools

Similar help and support threads
Thread Forum
BSOD playing computer games, multiple error codes (0x0000003B, ect)
Hello, and thanks for trying to help with this. I am having issues with several crashes, and one thing is constant. It only happens when graphics are involved. My pc crashes on games such as LoL, CoD:BO 1 and 2, Minecraft, and (for that random variable) Grim Fandango Remastered. I get 0x0000003B,...
BSOD Help and Support
BSOD playing Diablo3, multiple error codes
Good Afternoon, I came across this website during my search to fix my recent BSOD's, and it looks like a great place to get some help. I've been running the same programs with zero problems for months on end. However, within the past week, I've started getting BSOD's at what started as...
BSOD Help and Support
Multiple BSOD codes, playing games in Full Screen error 0x00000050
I keep getting the following BSOD error codes:- On Tue 25/12/2012 00:01:06 GMT your computer crashed crash dump file: C:\Windows\Minidump\122512-22744-01.dmp This was probably caused by the following module: cdd.dll (0xFFFFF9600067DC51) Bugcheck code: 0x50 (0xFFFFF900C32EE7A0, 0x0,...
BSOD Help and Support
BSOD playing games/streaming netflix multiple error codes
Hi all, I built my first computer about six months ago. After first completing it it never really crashed. Now, I get BSOD regularly when playing games (Civ 5, DOTA 2, Shogun 2) or when streaming netflix, just talking on skype. Here's just one of the error codes and dump files. This is a new...
BSOD Help and Support
BSOD playing various games, multiple error codes
Greetings, 7 forum. So let me start at the beginning of what's been happening. I bought my Cyberpower gaming PC from Newegg to play games like League of Legends, World of Warcraft, etc., and upon recieving the computer, which came with an integrated video card, I disabled the IVC and installed a...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App