Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HAL.DLL BSOD Need to diagnose failed hardware

07 Jul 2015   #1

Windows 7 Professional x64
HAL.DLL BSOD Need to diagnose failed hardware

I've recently started to get BSOD not long after startup, with the computer throwing a 0x00000124. I've been in and out of town over the last few weeks and I first noticed the issue after coming back for a day and booting up my PC only to have it BSOD while watching a YouTube video. After crashing once more I was able to play the Witcher 3 for a few hours with no trouble. After that I shut down the computer, turned it off and left town for a couple more weeks. Upon coming back last week I experienced the same issue of crashes not long after boot, but this time consistently after startup.

Booting into Safe Mode, the computer runs with no issues whatsoever.

Suspecting the GPU, based on the Safe Mode results, I tried rolling back the drivers, which didn't fix the issue but instead caused 0x00000101 errors, which persisted until I updated to the newest hotfix 353.38 drivers, at which point the 0x00000101 errors stopped and the 0x00000124 errors started again. I removed the GPU and
started up with only the integrated graphics. The system seemed to be more stable, but ultimately crashed again.

I've run Memtest86+ for 8 passes and gotten 0 errors, so I assume the RAM is good.
Samsung Magician indicates the drives are in good health, for what it's worth.

Prime95 in Safe Mode seems to run without issue, and I don't believe overheating to be the issue, as I just redid my water cooling loop about two months ago. However, at this point, my instinct is to blame the CPU, unless there is some sort of catastrophic driver error. Also worth noting is that while troubleshooting my Razer mouse stopped tracking, the buttons and scroll wheel still worked, but the cursor was frozen. I blame that on Razer drivers and Synapse though, as my Logitech USB mouse works fine, but I figured it may be relevant.

Long story short, it seems like I have a critical hardware failure, and I need help figuring out what to replace.

I've included two logs. One taken in Safe Mode and one I managed to get during a normal boot before the computer crashed.

My System SpecsSystem Spec
07 Jul 2015   #2

Windows 10 Pro/ Windows 10 Pro Insider

Hello, Genisi and welcome to the forums. I looked at the last 5 dump files you had but they are not telling me very much. Here's want I am getting

Use !analyze -v to get detailed debugging information.

BugCheck 124, {0, fffffa800fba5028, be000000, 800400}

Probably caused by : GenuineIntel

Followup: MachineOwner
That is a generic hardware error. Either a component has gone/is going bad or a bad driver is causing it to act that way. Please make sure your drivers are up to date and keep a close watch on temps of you GPU and CPU.

Please open an elevated command prompt ( click start, type cmd in the search box, right click on the cmd entry and select run as administrator) in the black box that opens, copy/paste sfc /scannow. If you decide to type it, notice the space between the sfc and the /. It is a system file checker which will scan your system files and attempt to correct any missing or corrupt files. What we want are the results to say windows found no integrity violations. If it says files were found but could not be repaired, close the box, reboot and run it again, after opening the administrative command prompt. You may have to reboot and run it three times for it to repair all system files. If it can't repair them after 3 reboots, let us know.
My System SpecsSystem Spec
08 Jul 2015   #3

Windows 7 Professional x64

As I said. There is no GPU installed at the moment and my temps do not go above ~40C.

My drivers are up to date, and I don't trust TweakBit, which is trying to install 32nm Xenon drivers on a 22nm i7, as well as AMD drivers, drivers that don't exist on Intel's site, and generic drivers over top of the official ASUS ones. The official Intel driver updater only updated the integrated HD graphics.

I ran the SFC 3 times in safe mode without it being able to fully validate. I attempted to run it under a normal boot environment and was able to fully verify the system without errors before the system BSOD again, this time throwing a STOP 0x00000101 error again except with yellow horizontal artifacts over the blue screen.

I'm fairly limited in what I can actually accomplish outside of Safe Mode (from which I'm doing this posting) as the system only tends to stay up for around 5 minutes, before crashing. I've gone into MSConfig and disabled all startup services, except for ESET, which will not let itself be disabled.

The only other thing that I can think of that may be related is installing some Windows Updates before the blue screens began last month, so I suppose possibly a corrupted update may be at fault.
I'm assuming I should just reinstall Windows at this point, and then replace my 4770k with a 4790 if that fails.
My System SpecsSystem Spec

08 Jul 2015   #4

Windows 10 Pro/ Windows 10 Pro Insider

Try uninstalling Chrome. You have had a dozen errors from Chrome in the past several days. Just see if it makes a difference. Sometimes a clean install is faster than tracking down the problem, but the error codes of 124 and 101 are a sign of hardware errors. Unless you have seriously abused it, you CPU would be the last piece of hardware I would suspect. A bad CPU is quite rare.

Check your hard drives with Samsung Magician

Run these online scanners

Scan with Kaspersky TDSSKiller:
Anti-rootkit utility TDSSKiller
Anti-rootkit utility TDSSKiller
ESET online scanner:
Free Virus Scan | Online Virus Scanner from ESET
Free Online Virus Scanner | ESET
SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!

then run memtest86+

Please Run Memtest86+

information   Information
Please download from this site only in the middle of the page are the Download links, you can download the or the Auto USB Flash Drive

Extract the Zip file. If you chose the ISO image, burn it to a CD using Windows Disk Image Burner or any Image burner you may have. If you downloaded the Auto USB installer, extract it, insert your USB 2.0 Flash Drive and take note of the drive letter. Run the installer, select the Flash Drive Letter, check the format box and press next. It will install memtest86+ to a flash drive. You can use either V4.20 or V5.01. Boot from your selected media. If you use V5.01 it will tell you to press certain buttons at the start, please press no buttons. The test will begin on it's own and continue to run until you stop it. It needs to run for 8 complete passes or until you receive an error. If you receive an error, stop the test. Even 1 error is a fail. Each pass tests a different part of the ram and each of the 10 tests in each pass tests something different. It takes a minimum of 8 passes to completely test the ram, more passes are better. It is quite a long test and will take several hours depending on how much ram you have. Due to the time length it is best to run overnight. If you have any questions, please do not hesitate to ask.

If all of those things don't show anything, then I would consider a clean install. But, I will stick with you and try to find the problem if you would like to.

You may want to try startup repair. Run it at least 3 times with attempted reboots between each one. Startup Repair
My System SpecsSystem Spec
08 Jul 2015   #5

Windows 7 Professional x64

As per my initial post, I've run MemTest86+ for over 10 hours and 8 passes with 0 errors and Samsung Magician indicates that the health of all the drives are good.

I scan regularly with ESET and it detects nothing.

So the only two things I can think of that would be causing this issue outside of Safe Mode is either the OS or the CPU.
My System SpecsSystem Spec

 HAL.DLL BSOD Need to diagnose failed hardware

Thread Tools

Similar help and support threads
Thread Forum
How to diagnose what hardware is disconnecting
Hi All, New to the forum hope someone can help. I have a htpc with windows 7 x64 installed. I have the system setup to turn off after 15 mins of inactivity. This used to work fine but now after 5 to 10 mins the system makes the sound of when you disconnect something from the usb, immediately...
Hardware & Devices
No power to USB after failed hardware install
Hello all. I am desperate for help! I have a Toshiba A300 laptop running Windows 7 Ult x64 I attempted to install a Logitech camera & webcam, Windows failed to install the drivers. After that, I lost all power to my left and right USBs. I tried System Restore, changing the Power Settings...
Hardware & Devices
DirectX hardware aceleration failed
Hello, have recently reinstalled windows 7 x64 and i guess that my directx got some problems. unable to start any game now. every time trying to lunch game, program gives different errors. now trying to start world of tanks and it saying: "Application has failed to start because DirectX...
Windows setup failed to configure on your hardware??!!
I am typing on my phone so hopefully you know my situation just by that! I had just replaced my hard drive from my sony vpccw29gx. It was corrupt. I bought a different brand hard druve, but same rpm. I ordered the recovery disks from sony. I installed the disks, but after the windows 7...
Installation & Setup
BSOD diagnose, thanks
This is my windows 7 HP dm1z laptop. Thanks
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:11.
Twitter Facebook Google+