Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD playing Far Cry 4, BugCheck 116

19 Sep 2015   #1

Windows 7 x64
BSOD playing Far Cry 4, BugCheck 116

Hello everyone,

I've just built a new computer about a week ago and have been having BSOD issues that I can't fix. My hardware specs are as follows:

CPU: Intel i7 5820K
GPU: MSI GeForce GTX 980 Ti
SSD: Intel 730 Series 480GB x2
Mobo: MSI X99A SLI Plus LGA 2011-v3
RAM: Corsair Vengeance LPX 32GB

I carried over one SSD from my previous computer and added a second new one. After having problems with BSOD, I did a fresh Windows install (Windows 7 x64), but the BSODs continued. The error message I'm getting is BugCheck 116, GRAPHICS_DRIVER_TDR_FAULT. Thinking my problem was the driver, I uninstalled my GPU driver and ran a 3rd party program in Safe Mode to remove all traces of it. I downloaded the latest driver from NVidia's site and kept getting the same BSOD. I only seem to get them when I'm gaming and only when playing Far Cry 4, I've played World of Warcraft and War Thunder with no problems.

I've checked CPU temperatures and they are normal, I don't have anything to test my GPU temp but both fans are running on it and I don't suspect that to be the problem. I ran Windows Memory Diagnostic to test my RAM and that came back with no negative results. I have the latest drivers on all other hardware and software, including Windows updates (current version is Service Pack 1). I am not overclocking and I am running 2 monitors.

I will post the Windows Debugger results below. Please help, thank you!

Microsoft (R) Windows Debugger Version 6.3.9600.17336 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\Minidump\091915-9032-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

************* Symbol Path validation summary **************
Response Time (ms) Location
Deferred srv*c:\symbols*
Symbol search path is: srv*c:\symbols*
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (12 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.18939.amd64fre.win7sp1_gdr.150722-0600
Machine Name:
Kernel base = 0xfffff800`03c56000 PsLoadedModuleList = 0xfffff800`03e9d730
Debug session time: Fri Sep 18 23:51:13.571 2015 (UTC - 4:00)
System Uptime: 0 days 0:22:43.802
Loading Kernel Symbols

Press ctrl-c (cdb, kd, ntsd) or ctrl-break (windbg) to abort symbol loads that take too long.
Run !sym noisy before .reload to track down problems loading symbols.

Loading User Symbols
Loading unloaded module list
* *
* Bugcheck Analysis *
* *

Use !analyze -v to get detailed debugging information.

BugCheck 116, {fffffa80217f24e0, fffff880050ddc30, ffffffffc000009a, 4}

*** WARNING: Unable to verify timestamp for nvlddmkm.sys
*** ERROR: Module load completed but symbols could not be loaded for nvlddmkm.sys
Probably caused by : nvlddmkm.sys ( nvlddmkm+84fc30 )

Followup: MachineOwner

11: kd> !analyze -v
* *
* Bugcheck Analysis *
* *

Attempt to reset the display driver and recover from timeout failed.
Arg1: fffffa80217f24e0, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff880050ddc30, The pointer into responsible device driver module (e.g. owner tag).
Arg3: ffffffffc000009a, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 0000000000000004, Optional internal context dependent data.

Debugging Details:

fffff880`050ddc30 48ff25d174eaff jmp qword ptr [nvlddmkm+0x6f7108 (fffff880`04f85108)]






ANALYSIS_VERSION: 6.3.9600.17336 (debuggers(dbg).150226-1500) amd64fre

fffff880`0b35fa48 fffff880`05733134 : 00000000`00000116 fffffa80`217f24e0 fffff880`050ddc30 ffffffff`c000009a : nt!KeBugCheckEx
fffff880`0b35fa50 fffff880`05706867 : fffff880`050ddc30 fffffa80`1e494000 00000000`00000000 ffffffff`c000009a : dxgkrnl!TdrBugcheckOnTimeout+0xec
fffff880`0b35fa90 fffff880`05732f43 : fffffa80`ffffd846 00000000`00000000 fffffa80`217f24e0 00000000`00000000 : dxgkrnl!DXGADAPTER::Reset+0x2a3
fffff880`0b35fb40 fffff880`0563803d : fffffa80`1a797d50 00000000`00000080 00000000`00000000 fffffa80`1e471010 : dxgkrnl!TdrResetFromTimeout+0x23
fffff880`0b35fbc0 fffff800`03f628e2 : 00000000`01e5a255 fffffa80`1e4c88b0 fffffa80`1a67d040 fffffa80`1e4c88b0 : dxgmms1!VidSchiWorkerThread+0x101
fffff880`0b35fc00 fffff800`03cbaf46 : fffff880`03342180 fffffa80`1e4c88b0 fffff880`0334d1c0 9d1f3602`0f1826d7 : nt!PspSystemThreadStartup+0x5a
fffff880`0b35fc40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16

STACK_COMMAND: .bugcheck ; kb

fffff880`050ddc30 48ff25d174eaff jmp qword ptr [nvlddmkm+0x6f7108 (fffff880`04f85108)]

SYMBOL_NAME: nvlddmkm+84fc30


MODULE_NAME: nvlddmkm

IMAGE_NAME: nvlddmkm.sys


FAILURE_BUCKET_ID: X64_0x116_IMAGE_nvlddmkm.sys

BUCKET_ID: X64_0x116_IMAGE_nvlddmkm.sys


FAILURE_ID_HASH_STRING: km:x64_0x116_image_nvlddmkm.sys

FAILURE_ID_HASH: {1f9e0448-3238-5868-3678-c8e526bb1edc}

Followup: MachineOwner

My System SpecsSystem Spec
19 Sep 2015   #2

Win7 Ultimate X64

I would firstly check your operating temps, you can use Speccy or HWinfo to see all the details you need

If temps seem ok try a different driver, if you have the latest try uninstalling it and using an older one just make sure its WHQL and not a beta, when uninstalling run Drivers - Clean Left over Files after Uninstalling to clean out any left overs and when installing only install the basic driver package.

If this doesn't work I would try running furmark to see if your gfx is functioning correctly and this will also give you an idea of gfx temps as this will stress test your gfx card

This covers the basics post back with your findings and a screenshot of furmark if you run it ?

ps don't leave furmark unattended and watch those temps if your gfx run too hot furmark will cook your card
My System SpecsSystem Spec
19 Sep 2015   #3

Windows 7 x64

I uninstalled my graphics driver, ran Driver Sweeper in safe mode and then installed an older driver version after it rebooted. Speccy showed normal temperatures (screenshot attached) but I got another BSOD when running Far Cry 4.

At this point I did a benchmark test using FurMark. For some reason it wouldn't let me use a preset benchmark test saying I had the wrong screen resolution, even though I didn't and even tried a few others with similar results. So I ended up doing a custom benchmark test and took a screenshot and attached that as well. It is also worth noting that I accidentally closed the results of the test without saving a screen shot and I ran a second test a minute after the first one. Just felt like that needed mentioning because the GPU hadn't completely cooled from the first test before I ran the second, so the GPU may reflect that.

One other thing that may or may not be worth mentioning, at this point I'm out of ideas on what the issue is and I'm grasping at straws. After I did a fresh Windows install, the .NET Framework 4 was giving me some error messages but after looking up solutions on the internet I ended up making my way to a screen that listed all the Framework software on my computer and I located .NET Framework 4 and chose restart. After doing that the error messages stopped appearing but I'm nervous that there might be an issue with the Framework since it didn't seem to install correctly the first time. Should I do a Windows repair install? I'm completely out of ideas here.
My System SpecsSystem Spec

20 Sep 2015   #4

Windows 7 x64


I went to the NVIDIA support forums and posted the issue there and the first response seems to have fixed the error (I will keep playing Far Cry 4 to confirm). I was instructed to disable the UPLAY overlay feature and to also disable some Gameworks features (like HBAO+, PCSS, TXAA, NVIDIA Godrays, and NVIDIA HairWorks etc.). I disabled the UPLAY overlay, changed the ambient occlusion setting from HBAO+ to none, and changed the Fur setting from enhanced to yes.

I was able to play for 30 minutes with no problems, whereas before it always crashed after 5 or 10 minutes without fail. As mentioned, I will continue to play for longer periods of time but 30 minutes problem free is a real big step in the right direction. If I do get another crash, I will know to keep turning other settings down or off (like anti-aliasing, godrays, etc.). I will mark this as solved for now and return with any updates, if any (in case there are others out there with the same problem). Thank you for your replies and help!
My System SpecsSystem Spec
21 Sep 2015   #5

Win7 Ultimate X64

Appreciate you sharing your solution with us, as you say this will help others in your situation :)
My System SpecsSystem Spec

 BSOD playing Far Cry 4, BugCheck 116

Thread Tools

Similar help and support threads
Thread Forum
BSOD/crashes playing Warcraft 3, bugcheck 0x00000116
I have started getting very frequent (nearly every game a few minutes in) BSODs or crashes without a bluescreen (but with the same errors in event viewer) while playing Warcraft 3. I've tried a number of things in attempts to fix it (checked for audio, video, chipset, and some other driver updates...
BSOD Help and Support
BSOD playing games or browsing web -The bugcheck was: 0x000000f4
Hello, computer is almost a year old but lately its been BSOD constantly. If im playing games, watching netflix, one time it happened as I was typing in my password to log into windows. The computer has rebooted from a bugcheck. The bugcheck was: 0x000000f4 (0x0000000000000003,...
BSOD Help and Support
BSOD Playing Crysis 3 error 0x0...0116 BugCheck
Hi! I got this error once now when i was playing crysis 3! I have attached the zip file from sf-diagnostic tool so can anyone please help me?i had lots of bsod but all of them were my own fault (bad software and stuff) and one was the asus suit 2 software from the driver disk but i don't have it...
BSOD Help and Support
BSOD playing FarCry2 bugcheck was 0x00000124
Second time I have had this BSOD in the last two days. I had been having skipping sound problems and had tried reinstalling sound drivers (same version) and video drivers (updated version). When those did not work I tried removing Speedfan (v 4.47) and that did work, reverting back to Speedfan...
BSOD Help and Support
BSOD when playing BF3 - The computer has rebooted from a bugcheck.
Hi all, New to the forum so hoping I get this right. Basically I have started experiencing BSOD's when playing BF3 as follows: The computer has rebooted from a bugcheck. The bugcheck was: 0x0000007f (0x0000000000000008, 0x000000008005f031, 0x00000000000006f8, 0xfffff880011acf4d). I have...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:26.
Twitter Facebook Google+