Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD 0x7e during boot; points to iaStorA.sys

26 Oct 2015   #1

Windows 7 Home Premium x64
BSOD 0x7e during boot; points to iaStorA.sys

Since this morning, I am unable to boot.
When starting up the computer I have the choice between booting normally or using "start help (recommended)" (exact terms might be off, translated from German Windows copy).

Starting normally:
I get to the windows logo, then I get a BSOD with
*** STOP: 0x0000007E (0xFFFFFFFFC0000005,0xFFFFF88001154CC6,0xFFFFF88003BE7648,0xFFFFF88003BE6EA0)

*** iaStorA.sys - Address FFFFF88001154CC6 base at FFFFF880010F6000, DateStamp 5147a504
Some of the hex values varying slightly, but always 0x7e and iaStorA.sys.
The reason I include this is because there are no dumps collected, even though collection is activated and I do have older dumps. (can manually check with ubuntu live cd)

Start help:
Again, I have two choices:
- "Use recovery tools ... . To do that, choose the OS that should be repaired." There is a list of installed OSs, however the list is empty and I cannot continue with this option.
- "Recover the computer with a previously created system image" (preselected) This gives internal error 0x80070002 "The system could not find that file". After I get to the default 5-option recovery menu. Automatic "system start repair" also doesn't work.

There was nothing unusual about working with the computer last night. I did not install any new Hard- or Software, nor Updates. I basically just used Firefox (youtube etc.) and Thunderbird and then shut down the pc normally.

What I've tried so far:
- Methods mentioned above
- Secure mode gets the same BSOD
- "Use last working configuration" gets the same BSOD
- One tip that came up in other threads was to rename iaStorA.sys so that it can't be found. This led to another BSOD while booting: 0x7B, no second row.
- Given other threads, the fact dumps aren't saved and the empty OS-list, it seems likely that it's a problem with Intel Rapid Storage Technology or Smart Response Technology (which uses the SSD with the HDD as a Hybrid). Unfortunately, while the mb supports it, I can only deactivate it via the windows drivers, not the BIOS. (i.e. currently not at all, afaik)

Any ideas other than "completely reinstall windows"? Would that even work with the driver acting up?


My System SpecsSystem Spec
26 Oct 2015   #2

Windows 10 Pro

Hi Tobl,

Welcome to the 7forums.

The 0x7B means your hard drive isn't recognized by the system, this could be due to the boot files corrupted, an infection, BIOS settings or a failing/faulty hard drive. There are some other causes, but I would say they are a little unlikely (because I have never seen it), like a 3rd party driver.

Please test your hard drives to start with.
For SSD's, only run chkdsk.

BSOD 0x7e during boot; points to iaStorA.sys Diagnostics Test BSOD 0x7e during boot; points to iaStorA.sys

Run SeaTools to check the integrity of your HDD. SeaTools for DOS and Windows - How to Use

Note   Note
Do not run SeaTools on an SSD as the results will be invalid.

Run chkdsk Disk Check
My System SpecsSystem Spec
26 Oct 2015   #3

Windows 7 Home Premium x64

Hi axe0,

Thanks for taking the time.

First of all, I was able to resolve the issue, so maybe only continue reading if you're interested in that.

chkdsk wasn't able to read the disks, it only analysed the 3mb partition that gets created for the recovery tools. I wasn't able to run SeaTools due to lack of internet for most of the time.
Tbh, at this point I had already resolved to just make a clean install. However, the installer also wasn't able to find the disks. While looking through the manufacturer's driver cd for which drivers to load, I noticed a file iaStorA.sys. After booting up the Ubuntu live distro once more, I replaced the file in system32/drivers with the one from the cd and (to my surprise) it worked. My best guess is, that the file itself must have become corrupted.

TL;DR: replaced faulty iaStorA.sys with copy from manufacturer's driver cd.
My System SpecsSystem Spec

26 Oct 2015   #4

Windows 10 Pro

Glad to hear you solved it :)
My System SpecsSystem Spec

 BSOD 0x7e during boot; points to iaStorA.sys

Thread Tools

Similar help and support threads
Thread Forum
BSOD on boot, 0x7E error.
Kinda new, dunno quite what to say but I Get the 0x7E error on start. I included the BSOD Zip that told me to.
BSOD Help and Support
BSOD iaStor.sys & iaStorA.sys
Have to post fast before computer crashes. More details to follow Okay, I'm on another computer. I'm not super computer savvy, but after looking around all afternoon this forum was the place with the most resolved iaStor.sys errors. This error seems to occur after I save to the hard drive...
BSOD Help and Support
BSOD error 1000007e, iastorA.sys
Hi all, I receive the iaStorA.sys error every 10 minutes and even after updating all the drivers from the Dell site and running multiple scans, it still returns. So I have completely wiped my laptop and updated the drivers once more but unfortunately it is back. I thought it was the IRST but now...
BSOD Help and Support
iastora.sys BSOD on HP ultrabook - can't even boot into windows
What a crappy day -.- I've had this HP ultrabook for just over a year now. When I first bought it I disabled intel rapid storage technology and did a fresh install of windows. After installing a clean copy I installed the intel rapid storage again and enabled acceleration. All has been...
BSOD Help and Support
BSOD 0x7E every type of boot: normal, any safe mode, even win 7 discs
Hello there! I am trying to help a friend with his computer and I have been unable to find any way to alleviate his problem. I have read the thread on how I'm supposed to correctly post BSOD problems but I can't even get into windows to begin with. On every type of boot, he is greeted with a BSOD....
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:33.
Twitter Facebook Google+