Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The Windows Installer Service could not be accessed

17 Nov 2009   #11

Windows 7 enterprise 64


My current imagepath is:

C:\Windows\System32\msiexec.exe /V

You are suggesting I change it to:

C:\Windows\System32\msiexec.exe file/v, i.

i.e. Is the ", i" and the "." (dot) at the end included?

by the way I have already done msiexec /regserver in safe mode (As instructed by some other post on the net)
But will do it again in case I did something wrong last time (After you reply to above..)

Also I wonder whether there is something wrong with my msiexec.exe becuase the icon shown against an msi is the default windows generic icon and not the msi icon that I see on my other windows 7 installation.
I think I'm going to also try copy and pasting the files from the other partition when in safe mode.
Any advice about this?? I will try after re-doing this registry stuff though...

In fact this is my export of the MSIServer registry key:

Windows Registry Editor Version 5.00
"DisplayName"="Windows Installer"

Many thanks,
Mike G

My System SpecsSystem Spec
17 Nov 2009   #12

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

In the Value Data box enter the location of the msiexec.exe file followed by /v, i. e.,

Yes, the dot is included and must be a typo there should be an e. at the end with a dot and comma. When I tried on my computer that entry was already in the data box. If I were making the changes, I would not have to input the entry myself.

I do not know about the icon, but if you paste from your other computer, it WILL be taken care of.

As I said, I am very cautious when it comes to the registry. Be careful, take your time and your system will be working again. There can only be two problems, corruption, which you will correct, pasting from your other computer
you have to register. Computers are not that profound. This will work. Either by registering or by pasting.
Just keep me informed.
Good Luck,

My System SpecsSystem Spec
17 Nov 2009   #13

Windows 7 enterprise 64

Well this is interresting....
On my broken win 7 install loads of MSI related registry keys are all messed up.
Keys in [HKEY_CLASSES_ROOT\Msi.Package]

What!! MsiExec in this folder which btw doesn't even exist!
On the working install it looked like this, which looks much more sensible...

It's not fixed yet though still same message when installing but the MSI icon is back on msi files which makes me feel I may just get there...
I think I just need to go through finding all msi related registry keys and then export from working install and import into not working install. (I hope!)

Anyway i've started looking at all reg keys I can find to do with msi.

If anyone out there has a list of all related keys for msi stuff then feel free to post.

In the mean time I'm off to search the net for them.

I'll post my findings when I'm done.

So far i've copied from these keys which were all different and what I would class as obviously wrong!
(I think this last one had some values that were correct, I assume they came from running msiexec.exe /regserver, but they still had some keys missing when compared to the working install)

By the way does anyone know of any program that during it's install it copies a version of msiexec into a temp folder and executes it? I wonder if stoping such a program mid install is what caused by issues...
My System SpecsSystem Spec

17 Nov 2009   #14

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Use plan B. You saved all the registry setting, import them back. Now go to your other dirve and copy exactly the settings for

msiexec.exe file followed by /v, i. e., Go by the settings in your other machine, not the one that is shown here.

Make sure reregister, and it should work. The only change you made was to the above script. If you change it to exactly what was shown on your other drive, it should be good to go.
My System SpecsSystem Spec
29 Jun 2010   #15

Windows 7 and Vista
Possible Solution

Due to this problem, I created a VM on VirtualBox running Windows 2008 Server R2 and hosted my IPod Nano there instead of my main Windows 7 machine. Eventually, this problem occurred on server as well. It has something to do with the iTunes install process which fires when you run iTunes as well as when you are asked if you want to pull down an update and install it. The only solution I used prior to today was to do a restore to an earlier date and time. Not the best because Windows 7 code has some problems with user ID's needing to be deleted and recreated. But that does resolve the problem as well, however, it's a bit ugly, but less than re-imaging your system

At any rate, I resolved this problem on a W2008 R2 which runs Windows 7 code.

Use the following reference:
Repair Windows Installer Service in Vista (All Versions) - Vista Forums

It's for a Vista system. However, I was not successful until I used this modified approach.

In short, they had me replace a folder in the registry, msiserver, from a working machine.

What I did differently was on the broken machine, I took the msiserver key and renamed it by putting a unique string at the end, msiserver.orig.

Then I imported the key from the working Windows 7 box...yes I took something from my working Windows 7 system and inserted it into the registry of my W2008 Server R2 VM.

Once done, I first tried to run iTunes...I did not try to run an install process. I also jumped to multiple login id's to test iTunes. I've seen iTunes error on one ID but not another for symptoms related to this problem.

Once I verified that iTunes was working, I ran the install process for the downloaded copy of iTunes 64-bit that I had so I could apply the latest update. I did not use the iTunes application to do a download and upgrade that way. That's what got me into trouble in the first place. I could work but I don't know.

The install ran properly. I then retested iTunes using different login id's and found that all was well.

At this point, I have a backup of that key saved on both systems to ensure that I can restore again if need be. It's possible that this problem is related to installing the latest 9.2 version of iTunes.

I hope that this problem is the final fix. I'm still not ready to install iTunes on my main Windows 7 box.



Quote   Quote: Originally Posted by richc46 View Post
While you were making your back up, I found the necessary register entry that will help you fix your computer.

The only thing that we are doing is reregistering the Window Server. You mentioned in your intital post that you did something similar, but it did not work. If you did it differently from my instructions you may want to try again. I truly believe that this will work. You checked and you said that the registry setting are ok and that the service is actually running. There is really nothing else I can think of.

My original thought was to take the command from your other computer, but that will not help because the command is ok in your problem computer.

My last piece of advice. I do not like fooling around with the registry, but we have 2 backup, so it should be ok.

Go to run, enter regedit
go to HKEY_local_machine\system\currentcontrolset\services\msiserver

On the right click ImagePath and click modify
you should see or enter msiexec.ele file/v, i.

Contiue and confirm that you want to make the chaneg
click ok and exit registry.

Restart your computer in safe mode. This is done during reboot by holding down f8 and by selecting safe mode. click start
then go to run and enter msiexec /regserver

Hit ok hit start and restart computer in the norml way.

Get back to me so I know what happened
My System SpecsSystem Spec

 The Windows Installer Service could not be accessed

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 installer service could not be accessed
I have tried all the suggestions I can find, including the ones listed here 2+ years ago. I tried MS's repairs, the unregister, etc. Any ideas?
General Discussion
Windows Installer Service cannot be accessed.
Okay, so i was trying to install .Net Framework 4.5, when all of a sudden, it rolls back the download, and displays a message "Installation did not succeed, .Net Framework has not been installed because: The Windows Installer Service could not have been accessed. This can occur if the Windows...
General Discussion
the windows installer service could not be accessed
I get the error when i install or uninstall any program please do help : I have attached the screenshot of the error. thanks in advance
Installation & Setup
Windows Installer Service could not be accessed.
This happened the last time I reformated and I don't really understand what's going on. I have 4 harddrives. 1 SSD and the rest are standard 7200RPM drives. This is the error I get when I try to install something. Weird thing is...
BSOD Help and Support
Windows installer service could not be accessed
I suffered from a Power_driver_state_failure problem, which Windows7 forums helped fix. However at some point the problem appears to have damaged my windows Installer. I am having problems installing new updates on my Norton and itunes no longer works and will not reinstall. The message I keep...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:37.
Twitter Facebook Google+