Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The instruction at ____ referenced memory at ____... I/O error status

09 Jun 2016   #1

Windows 7 Professional 64 bit
The instruction at ____ referenced memory at ____... I/O error status


I've been having this issue for about 2 months now. Randomly the system will freeze with the error message popping up for various applications running at the time. This occurs many times in a week, often multiple times in a day. I've searched various online forums online and tried various solutions to no avail.

Here's what I've tried:
  • /sfc scannow
  • Memtest86+ (passed)
  • Windows Memory Diagnostic (passed)
  • Repairing startup files
  • Replacing hard drive SATA cables
  • Updating Java
  • Uninstalling and re-installing missing / faulty drivers
  • Checking SSD health and running benchmarks (seems fine)
I am sure it is either a hardware failure or driver error that is causing the problem.
I would very much appreciate any help/advice on how to fix this.


My System SpecsSystem Spec
09 Jun 2016   #2

Windows 7 Professional 64 bit
In my haste to post, I forgot to add:

I've also tried chkdsk.exe.

Sometimes the computer would hang on loading windows and I'd reset it multiple times until it would finally get to the login screen.

Attached are the zipped logs.
My System SpecsSystem Spec
10 Jun 2016   #3

Windows 10 Pro

Could you provide more details about what you've done and how you came to conclusion about certain things.
What was the result of SFC?
How many passes did you run with MemTest86+
How did you repair the startup files?
What drivers did you install and how did you figure out they were faulty?
With what program did you check the health and benchmark?

It would be preferred if you could make screenshots/photos of certain things, I'll post what exactly when you answer the questions above :)
The screenshots is just to let us check the result so we won't forget them.

Please remove following programs
Start Menu\Programs\ASUS	Public:Start Menu\Programs\ASUS	Public
Start Menu\Programs\ASUS\AI Suite 3	Public:Start Menu\Programs\ASUS\AI Suite 3	Public
Start Menu\Programs\ASUS\AI Suite II	Public:Start Menu\Programs\ASUS\AI Suite II	Public
Start Menu\Programs\ASUS\AO Help	Public:Start Menu\Programs\ASUS\AO Help	Public
Start Menu\Programs\ASUS\ASUS Boot Setting	Public:Start Menu\Programs\ASUS\ASUS Boot Setting	Public
Start Menu\Programs\ASUS\ASUS ROG Connect	Public:Start Menu\Programs\ASUS\ASUS ROG Connect	Public
Start Menu\Programs\ASUS\ASUS ROG Connect Plus	Public:Start Menu\Programs\ASUS\ASUS ROG Connect Plus	Public
Start Menu\Programs\ASUS\HomeCloud	Public:Start Menu\Programs\ASUS\HomeCloud	Public
Start Menu\Programs\ASUS\HomeCloud\Media Streamer	Public:Start Menu\Programs\ASUS\HomeCloud\Media Streamer	Public
Start Menu\Programs\ASUS\KeyBot	Public:Start Menu\Programs\ASUS\KeyBot	Public
Start Menu\Programs\ASUS\MemTweakIt	Public:Start Menu\Programs\ASUS\MemTweakIt	Public
Start Menu\Programs\ASUS\WebStorage	Public:Start Menu\Programs\ASUS\WebStorage	Public
Start Menu\Programs\DAEMON Tools Pro	Public:Start Menu\Programs\DAEMON Tools Pro	Public
Start Menu\Programs\IObit Uninstaller	Public:Start Menu\Programs\IObit Uninstaller	Public
Start Menu\Programs\IObit Unlocker	Public:Start Menu\Programs\IObit Unlocker	Public
I'm not sure about this program, but it doesn't sound very proper, many of the things described are useless things, I would ask that you remove it.
Start Menu\Programs\SSD Tweaker	Public:Start Menu\Programs\SSD Tweaker	Public
My System SpecsSystem Spec

10 Jun 2016   #4

Windows 7 Professional 64 bit
Uninstalled Tweaker

SSD Tweaker is a program I installed last year and completely forgot about. It just checks that Pre-fetch and Superfetch are disabled. I've now uninstalled it.

I'll respond back in a day after I uninstall all the ASUS software.

Just curious, why uninstall DAEMON Tools Pro and Iobit's Uninstaller?
I am quite fond of them.
My System SpecsSystem Spec
10 Jun 2016   #5

Windows 7 Professional 64 bit
In response to the questions above:

Verification 100% complete. Windows Resource Protection did not find any integrity violations.
I forget how many passes I ran... for sure a minimum of 8. I had it on for about a day.
I used startup repair to repair the files.
I uninstalled and reinstalled Daemon Tools Pro and its SCSI driver (fixing that issue).
I used Crystal Disk Mark and Crystal Disk Info. In addition, I utilized SanDisk's own software, SSD Dashboard to run SMART tests.

I think the SSD is at fault. Today I realized some of the times I Blue Screen is when the system is downloading or writing large amounts of data when not much disk space is left. It may be encroaching on the page file, triggering the shutdown? I find that going into Safe Mode and uninstalling large programs increases the chance I am able to boot back into normal mode and stay there without crashing.

I was able to instigate the Blue Screen by attempting to download a game through Steam, which began allocating 20 GB of storage when all of a sudden the system crashed.
My System SpecsSystem Spec
10 Jun 2016   #6

Windows 10 Pro

Daemon tools uses drivers known for causing BSODs.
Removing IObit is to prevent it from causing (more) problems, recently I helped a user who was getting many BSODs that were all caused by all IObit software only. It wasn't shown in the dumps but removal of the programs and reverting back the changes did the trick.

HOW did you repair the startup files, not why

Blue Screen is when the system is downloading or writing large amounts of data when not much disk space is left
That can have more causes.

Did you check your SSD for firmware updates?

What do those programs show for your SSDs, again, a screenshot is requested.
My System SpecsSystem Spec

 The instruction at ____ referenced memory at ____... I/O error status

Thread Tools

Similar help and support threads
Thread Forum
Old Game: "The instruction at xxxx referenced memory at xxxx"
I'm trying to play an really old economy simulator game called "Wet Attack" from 1999. I'm under Win 7 x64 HP with a i5-2500k @3,3k with 8 GB DDR3 ram and a GeForce GTX 560 TI. All drivers are up to date. The game installed just fine and start ups smoothly. The movie files play fine too....
Stop c0000006 the instruction at 0x%p referenced memory at 0x%p. Hello all i am new (joined Today) i have the same problem it shows me X:.... i followed all things that you wrote here but to me doesnt show any volume or disk maybe that my...
Hardware & Devices
Virtualization of ____ Failed. An Unexpected Error Occurred
I finally bypassed the error I was receiving due to a problem with my network sharing, and VMWare Workstation finally started to virtualize my PC. I was extremely happy that it was finally working, so I left it for around a half hour and let it do its work. I came back and the green bar was...
tweak ui came over with transfer wizard/oh ____!!!
I refreshed a pc from xp pro to 7 ent 64-bit. I used the wizard to bring over the user profile. The userhad tweak ui(not sure what version) installed for xp. In 7, what should I remove in the registry from the tweak ui xp tranfer jumble?? Does anyone think remnants of tweak ui could be...
The instruction at 0x66d38681 referenced memory at 0x7f7f7fa3
the instruction at 0x66d38681 referenced memory at 0x7f7f7fa3 the memory could not be written. How can I fix this error? The top of the error box is in Chinese characters. It also cause Shockwave to crash.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:14.
Twitter Facebook Google+