Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New to Windows 7, Crash Report Inside

19 Nov 2009   #1

Windows 7
New to Windows 7, Crash Report Inside

So I got new parts today (they are in my parts) Im also new to Windows 7 (hi all).
I originally had windows vista......and it was causing a TON of errors, I mean i got like.....4 BSOD's and I play a game called Heroes of Newerth (It's like DOTA if you've ever heard of it) and the game crashed on me like 6 times in game......needless to say it was bad.

Since our University lets u get a free copy of windows 7 (one per person) I decided to try that. I played around 5 hours of the same game, no problems whatsoever.

But I did get one crash (BSOD) But I have the memory dump file. as well as the debugging report (with proper symbols)

i tried uploading the memory.dmp file but it wont let me. so i'll post what I have (from the debugger MS provides, with the symbols file properly done)

Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`0260d000 PsLoadedModuleList = 0xfffff800`0284ae50
Debug session time: Wed Nov 18 21:53:25.293 2009 (GMT-5)
System Uptime: 0 days 0:26:45.274
Loading Kernel Symbols
Loading User Symbols
PEB is paged out (Peb.Ldr = 00000000`7efdf018).  Type ".hh dbgerr001" for details
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {ffffffffffff58a9, 2, 1, fffff880042d2820}

PEB is paged out (Peb.Ldr = 00000000`7efdf018).  Type ".hh dbgerr001" for details
PEB is paged out (Peb.Ldr = 00000000`7efdf018).  Type ".hh dbgerr001" for details
Probably caused by : mouclass.sys ( mouclass!MouseClassDequeueRead+14 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: ffffffffffff58a9, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff880042d2820, address which referenced memory

Debugging Details:

PEB is paged out (Peb.Ldr = 00000000`7efdf018).  Type ".hh dbgerr001" for details
PEB is paged out (Peb.Ldr = 00000000`7efdf018).  Type ".hh dbgerr001" for details

WRITE_ADDRESS:  ffffffffffff58a9 


fffff880`042d2820 488d9158ffffff  lea     rdx,[rcx-0A8h]



PROCESS_NAME:  firefox.exe

TRAP_FRAME:  fffff88002d227d0 -- (.trap 0xfffff88002d227d0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=a10181039b014e03 rbx=0000000000000000 rcx=0000000000ffffff
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880042d2820 rsp=fffff88002d22968 rbp=0000000000000018
 r8=fffffa80018bb968  r9=0000000000000000 r10=000000000000001c
r11=fffff88002d229b0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`042d2820 488d9158ffffff  lea     rdx,[rcx-0A8h]
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000267e469 to fffff8000267ef00

fffff880`02d22688 fffff800`0267e469 : 00000000`0000000a ffffffff`ffff58a9 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`02d22690 fffff800`0267d0e0 : 00000000`00000000 fffffa80`018bb780 00000000`00000002 fffffa80`0375e1a0 : nt!KiBugCheckDispatch+0x69
fffff880`02d227d0 fffff880`042d2820 : fffff880`042d28e0 fffffa80`018bb780 fffffa80`018bb660 fffffa80`018bb8d0 : nt!KiPageFault+0x260
fffff880`02d22968 fffff880`042d28e0 : fffffa80`018bb780 fffffa80`018bb660 fffffa80`018bb8d0 00000000`00000007 : mouclass!MouseClassDequeueRead+0x14
fffff880`02d22970 fffff880`04727c79 : 00000000`00000002 00000000`ffffffff fffffa80`018bb660 fffffa80`0282cde0 : mouclass!MouseClassServiceCallback+0x88
fffff880`02d229f0 fffff800`02681516 : fffffa80`0198d7e3 fffff880`00000000 fffffa80`00000000 00000000`00000000 : mouhid!MouHid_ReadComplete+0x69d
fffff880`02d22a70 fffff880`04705acc : fffffa80`03098700 fffffa80`03098606 fffffa80`03094b00 00000000`00000000 : nt!IopfCompleteRequest+0x3a6
fffff880`02d22b50 fffff880`04705d35 : fffffa80`01902a02 fffffa80`01902af0 fffffa80`03094b60 00000000`00000004 : HIDCLASS!HidpDistributeInterruptReport+0x130
fffff880`02d22be0 fffff800`02681516 : fffffa80`02aa6e53 00000000`00000000 fffffa80`03094901 fffffa80`02aa6c60 : HIDCLASS!HidpInterruptReadComplete+0x235
fffff880`02d22c70 fffff880`03f915d9 : fffffa80`01831050 fffffa80`03631c00 00000000`00000000 00000000`00000000 : nt!IopfCompleteRequest+0x3a6
fffff880`02d22d50 fffff880`03f91ab7 : fffffa80`043dec02 fffffa80`02aa6c60 00000000`ffffffff fffffa80`01831ea8 : USBPORT!USBPORT_Core_iCompleteDoneTransfer+0xa15
fffff880`02d22e30 fffff880`03f8f64f : fffffa80`01831ea8 fffffa80`018311a0 fffffa80`01832040 00000000`00000000 : USBPORT!USBPORT_Core_iIrpCsqCompleteDoneTransfer+0x3a7
fffff880`02d22e90 fffff880`03f80f89 : fffffa80`01831050 00000000`00000000 fffffa80`01831e02 fffffa80`01831ea8 : USBPORT!USBPORT_Core_UsbIocDpc_Worker+0xf3
fffff880`02d22ed0 fffff800`0268a5dc : fffff880`009e8180 fffffa80`01831ea8 fffffa80`01831ec0 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`02d22f00 fffff800`02685065 : 00000000`00000000 fffffa80`0399bb60 00000000`00000000 fffff880`03f80db0 : nt!KiRetireDpcList+0x1bc
fffff880`02d22fb0 fffff800`02684e7c : fffffa80`022ea9c0 00000000`00000010 00000000`00000001 00000000`00000000 : nt!KxRetireDpcList+0x5
fffff880`073a7be0 fffff800`026ca793 : fffff800`0267a8e3 fffff800`0267a94f fffffa80`0399bb60 fffff880`073a7ca0 : nt!KiDispatchInterruptContinue
fffff880`073a7c10 fffff800`0267a94f : fffffa80`0399bb60 fffff880`073a7ca0 00000000`00000000 00000000`00000020 : nt!KiDpcInterruptBypass+0x13
fffff880`073a7c20 00000000`6ccede0d : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiChainedDispatch+0x19f
00000000`0314f830 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x6ccede0d


fffff880`042d2820 488d9158ffffff  lea     rdx,[rcx-0A8h]


SYMBOL_NAME:  mouclass!MouseClassDequeueRead+14

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: mouclass

IMAGE_NAME:  mouclass.sys


FAILURE_BUCKET_ID:  X64_0xD1_mouclass!MouseClassDequeueRead+14

BUCKET_ID:  X64_0xD1_mouclass!MouseClassDequeueRead+14

Followup: MachineOwner
Keep in mind this only happened once, but I was worried so i thought i'd check, but I think the last crashes were because of faulty LAN drivers with vista. since I had alot of netsomething and server event errors.

From what I can tell firefox.exe was the problem....but mouseclass.....I dunno what that means. I do rememeber however I had just got done installing firefox and my ati drivers, and was downloading my game when this happened. So mebe firefox just messed up? and also why does it say VISTA_CLASS_PROBLEM when Im using windows 7....makes no sense since I formatted and deleted the partition when I installed windows 7, so it was fresh install...

Also one thing I wanted to ask. Do motherboards commonly cause BSOD's? What about processors for that matter? Or is it usually a memory/bad memory stick problem? (just curious, since my last mobo was bad.....hopefully I wont have 2 in a row bad) But so far it's been good.

Edit: Oh ya ran memtest for 3 hours, no errors.

Thanks all. sorry for the HUGE message

My System SpecsSystem Spec
19 Nov 2009   #2

7600.20510 x86


If you zip or rar the dump file, we will have suggestions on how to proceed to fix this 0xD1 stop for you.

You may attach it to a post using the paperclip above where you type.
My System SpecsSystem Spec
19 Nov 2009   #3

Windows 7

Well it hasn't happened again.
but ill post it and see what yall think?

Im just surprised firefox.exe could cause this......and then the mouse thing?

And are bsod's from hardware usually caused by mobo's/cpu's or RAM?

edit: I tried to upload it. but it's saying the file is too big? but I mean I debugg'ed the memory.dmp file and thats what I got? and I used the proper symbols file.

I mean it only happened once, so theirs only 1 error debug info. and so far it hasn't happened again. I just want to make sure my mobo/cpu and other hardware is ok. Kinda weird it says VISTA_DRIVER_FAULT when im using 7 lol

Ill post my dxdiag. see if that helps. my memory.dmp file is just too big to post on here
My System SpecsSystem Spec

19 Nov 2009   #4

7600.20510 x86

The Vista Driver fault is standard debug for 7. Everyone with bsod has that.

It probably wasn't caused by Firefox per se, rather a driver on the system is my guess. (Possibly a poorly written plugin.)

You have to either .rar or .zip the file(s) to attach it/them. You could check to see that your computer is set to output minidumps as opposed to full kernal dumps. If you never changed it, it will be set to minidump and you could just zip or rar, then attach.
My System SpecsSystem Spec
19 Nov 2009   #5

Windows 7

It's def set to kernal memory dump.
and even when I zip it the file is rather large.
like 356 mb large? rar'ing only brought it down to 69mb (which seems awfully big for ONE bsod?)

Regardless it hasn't happened again? do you think it's hardware related? (like memory/mobo/cpu) since they are new parts. or just driver issues (cause i'd hate it to be a bad mobo or cpu)....but they seem to be working ok so for
My System SpecsSystem Spec
20 Nov 2009   #6

Windows 7

is there any way to make the file smaller? or not really
My System SpecsSystem Spec
20 Nov 2009   #7

7600.20510 x86

Yes, there is. Set it to small memory dump.
My System SpecsSystem Spec
20 Nov 2009   #8

Windows 7

Quote   Quote: Originally Posted by torrentg View Post
Yes, there is. Set it to small memory dump.
will that change the one I already have. since I havent had a crash yet it must've just been a fluke thing where I was installing a bunch of stuff at once
My System SpecsSystem Spec

 New to Windows 7, Crash Report Inside

Thread Tools

Similar help and support threads
Thread Forum
random computer crashing (eventvwr report inside)
Hey, i built my computer a few months back and have recently (last few weeks) been getting random crashes/freezes where my only solution is to hold down the power button (reset button doesnt work either). i have checked event viewer and the only error is this: Event filter with query "SELECT *...
General Discussion
Windows 7 Crash Report Points to USB Hub!
Followed instructions on how to read the dmp file that came out of my recent crash. It seems to point to 'usbhub.sys'. The machine has had the following things installed recently: Q-Dir 5.36, a file manager, Oracle's VirtualBox (Running Ubuntu 12.04), Version 4.1.22 and Microsoft Security...
BSOD Help and Support
HDD failure on its way? disk scan report inside
Hello everyone, I'm using a Toshiba Satellite laptop that I purchased in December 2010 and I received a few messages today telling me that "Windows detected a hard disk problem" and advising me to backup everything and contact the manufacturer. The HDD is a Toshiba MK5065GSXN. I'm using Windows...
Hardware & Devices
Windows Crash Report Need Help
Is Windows 7... x64 Original installed OS Full retail version 1 year old (Christmas) Have not reinstalled OS My computer (Asus CG1330) randomly shuts off at times and i dont know how to fix it. Hoping you guys can help. I have included Windows_NT6_BSOD_jcgriff2 and...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App