Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After successful installation, application crashes. Any help?

13 Jan 2017   #1
motoxkid

Windows 7 Professional SP1 64Bit
 
 
After successful installation, application crashes. Any help?

I recently installed a Win7 compatible application used for programming two-way radios. It installed successfully, but when launched, I get the message "A problem caused the program to stop working correctly. Please close the program." and that is as far as I get.

Windows Event Viewer shows the following in the Windows logs:

From "Application Error":

"Faulting application name: mototrbocps.exe, version: 13.5.679.0, time stamp: 0x579b5e3b
Faulting module name: ntdll.dll, version: 6.1.7601.19045, time stamp: 0x56258e62
Exception code: 0xc0000005
Fault offset: 0x0003d968
Faulting process id: 0xa3c
Faulting application start time: 0x01d26e0e8e035f2c
Faulting application path: C:\Program Files (x86)\Motorola\MOTOTRBO CPS\mototrbocps.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: cc8d4a06-da01-11e6-a986-705812dcd38d"

From .NET Runtime:

"Application: mototrbocps.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
Stack:
at <Module>.createCLL(CLL.ConfigInfo*, CLL.DeviceInfo*)
at MSI.CommonClientLicensingInterface..ctor(MSI.ConfigInfo, MSI.DeviceInfo)
at commonLicensing.CommonLicenseInterface.InitializeLicensing(System.String, commonLicensing.ApplicationType, System.String, Boolean)
at SfcLicenseManager.CLicenseManager..ctor()
at mototrbocps.CMainFrame..ctor(System.String, Boolean, resource_handler.CResourceHandler, RegistryAccess.ILanguageSettings, RegistryAccess.IPersistentApplicationSettings, System.String, Controller.v, SSKM.SoftwareSystemKeyManager, mototrbocps.CMultiSelectHelper)
at mototrbocps.CMainFrame.a(System.String[])"

I also get a lot of this:

From the application log:

"The Software Protection service has stopped."

This software runs fine on other Win7Pro64 workstations. This is a Panasonic Toughbook CF19 Core i5 vPro with 8GB RAM.

sfc /scannow reports "Windows Resource Protection found corrupt files but was unable to fix some of them."

Any help?

Thanks,

Chris


My System SpecsSystem Spec
.
13 Jan 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Chris now some more specs would be handy mate System Info - See Your System Specs

Now as the sfc found problem files I would suggest you try running a chkdsk first up
Disk Check < if necessary include the /f and /r in the command line as per Option2
Run these in safe mode and the sfc often best run for two to three runs you can leave out the /r switch in ckdsk if you feel it not necessary
As a by the by some like to run sfc for more than one scan too but that is your choice

After that I would run these too
SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!
Malwarebytes | Malwarebytes Premium
AdwCleaner Download
ADW download from bleeping computer delete any rubbish found with the malware scans
(NB If you are running Kaspersky as the main AV then it might need disabling it when trying ADW because it does not like it at times)

Now as this has happened after the installation of that program I am thinking that it might have some thing to do with the issue, but lets start with the above.
My System SpecsSystem Spec
13 Jan 2017   #3
motoxkid

Windows 7 Professional SP1 64Bit
 
 

I will try the chkdsk. What I find interesting is that this install of Win7 that came on the machine shows a Dell logo in the My Computer > Properties window. This is a Panasonic Toughbook. I wonder if this installation of Windows 7 is just plain effed, and I should format & reinstall using a non-Dell disc?
My System SpecsSystem Spec
.

13 Jan 2017   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate am not sure what is meant by My Computer?? do you mean Computer from the start menu? If it is then the Dell logo will probably be a bit of their bloatware - am not sure.

Now if you want to do a reinstall with a Windows ISO then that is easy as long as you know the activation code (on the sticker) .

If you don't know the activation code then you can find it with this Product Key Number for Windows 7 - Find and See - option #2 and #3 are equally good.

For a clean install Clean Install Windows 7 if you go to the in point #1 Heres how there is a link to the place where the ISO can be downloaded just be careful you only get the right version - the one that you already have and make a bootable disk or stick from it - I prefer a disk but the choice is yours.

You could of course do a factory restore but frankly you get back the bloat.
Personally I hedge my bets when doing this and use a new drive for the reinstall this avoids any corruption from the old setup if you haven't done a thorough wipe / clean all of the original drive but that loses all chances of running at least some system rather than one at all. If that does not make sense I mean that I would save the original drive making it possible to swap it back in for a machine that works if not that well.

The choice and budget of course is yours.
My System SpecsSystem Spec
Reply

 After successful installation, application crashes. Any help?




Thread Tools




Similar help and support threads
Thread Forum
Random BSOD and application crashes
Had a few similar (although not as serious issues) a few months back which reformatting seemed to fix, however just recently it has started to happen again. About 1 month ago issues started appearing again including the following symptons: - Google Chrome crashing (Aw, Snap! message) during...
BSOD Help and Support
Computer keeps randomly freezing after successful installation
Hi guys, I've been having problems with my windows 7 lately. I originally had a HDD with XP installed on it and then I decided to install Windows 7 on my brand new SSD. I have an AMD high-end processor ( i forget the number), 4 GB of RAM, and a geforce 9800 gt, all in a antec nine hundred...
BSOD Help and Support
SD card not detected after successful installation
hi I am Deepak , I have a problem when i connect devices to my lap. When i connect my phone to my laptop, it installs the drivers for mass storage .and give a successful installation message .When i Open the removable drive shown in My Computer after some time it gets disconnected .this ...
Hardware & Devices
Application crashes on Win7
Greetings. New user here looking for some assistance if possible. IE 7, Firefox, Vanguard (MMO game) are all crashing on me, and have been since I installed them. I've gotten the correct drivers from Intel for the board, I've run with and without sound. I've tried all the listed Win7 video...
BSOD Help and Support
Installation successful!
Well, I got Windows 7 installed and it's up and running like a charm! I love way more than Vista, and get this: my old Windows Movie Maker 6 folder and file was saved in windows.old! How great is that? I also imported the old Windows Mail from Vista too. I love Windows 7!!!:party: Oh, and how...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App