Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD random 0xF4, no dumps; stuck on "initializing disk"

02 Feb 2017   #21
axe0

Windows 10 Pro
 
 

RAID & AHCI configuration could cause a lot of problems, including BSODs as you may read. I cannot confirm nor deny that it may have anything to do with the issue, but it is a possibility.


My System SpecsSystem Spec
.
15 Mar 2017   #22
luckycharms

Windows 7 Professional x64
 
 

I just wanted to get back with what finally solved this vexing issue. I tried reinstalling the entire OS, and went with Windows 10 to see if there was some sort of NVMe support issue with Windows 7. But, the same BSOD occurred with Win 10.

After trying some other things, I did two things that actually, finally, gratefully, fixed the issue.

First, I switched from Intel RAID to AHCI. I had to boot into windows safe mode with AHCI enabled first, and then I could boot regularly into AHCI. That fixed a number of problems. Notably, apps such as CrystalDiskInfo could not see the NVMe drive when Intel RAID was enabled. I'm not sure if that's normal or not... but once booting into AHCI, CrystalDiskInfo could see the NVMe drive just fine. After I did this, I didn't get a BSOD at all, for a day or two.

After running like that for a day or two, I also replaced the 1TB Toshiba NVMe drive with a 1TB SK Hynix NVMe drive (having cloned from one to the other first).

I have now been running for over a week with AHCI and the SK Hynix drive, and no BSODs. I'm quite sure the issue is solved now. Whether the root of it was Intel RAID (which I suspect), or the drive itself, I can't be sure. But I did want to report back in case anyone else was having similar issues!

Thanks again for your attention, axe0.
My System SpecsSystem Spec
Reply

 BSOD random 0xF4, no dumps; stuck on "initializing disk"




Thread Tools




Similar help and support threads
Thread Forum
Restoring, but for past 24 hours get "system restore is initializing"
Should I do a hard shut down? Then what?
Backup and Restore
Stuck on "Start Windows normally" and "Launch startup repair"
I am stuck on "Start Windows normally" and "Launch startup repair" When I choose "Start Windows Normally",it gives me blue screen with the following error:Unmountable_Boot_Volume.On "Launch startup repair" I am stuck on the Windows 7 wallpaper with cursor and can't even open Cmd trough...
General Discussion
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
BSOD stops at "Initializing disk for crash dump...
Hello, I have been experiencing a BSOD periodically, however the blue screen never gets past "Initializing disk for crash dump". As a result there are no related minidump files in the minidump folder. Any ideas on how to begin trouble shooting this? I am able to boot fine and can play games,...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App