Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: atikmdag.sys error when watching YouTube videos

11 Mar 2017   #1
Seven Fan

Win 7 Pro x64
 
 
atikmdag.sys error when watching YouTube videos

Whenever I watch YouTube videos there is a chance I will get a BSOD. It doesn't happen every time, but it does occur about once a day. So far, this has ONLY happened while playing YouTube videos. All of the info below was acquired using Blue Screen View.

This is the dump from the last crash:
Dump File: 031117-27596-01.dmp
Crash Time: 3/11/2017 9:54:59 AM
Bug Check String: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Bug Check Code: 0x1000007e
Parameter 1: ffffffff`c0000005
Parameter 2: fffff880`0f0f7fdb
Parameter 3: fffff880`021e9228
Parameter 4: fffff880`021e8a80
Caused By Driver: atikmdag.sys
Caused By Address: atikmdag.sys+1243af
File Description: ATI Radeon Kernel Mode Driver
Product Name: ATI Radeon Family
Company: Advanced Micro Devices, Inc.
File Version: 8.01.01.1379
Processor: x64
Crash Address: atikmdag.sys+c4fdb
Stack Address 1:
Stack Address 2:
Stack Address 3:
Computer Name:
Full Path: C:\Windows\Minidump\031117-27596-01.dmp
Processors Count: 4
Major Version: 15
Minor Version: 7601
Dump File Size: 276,520
Dump File Time: 3/11/2017 9:56:53 AM

This is the properties of the atikmdag.sys file:
FIlename: atikmdag.sys
Adress In Stack: atikmdag.sys+1243af
From Address: fffff880`0f033000
To Address: fffff880`0fdd5000
Size: 0x00da2000
Time Stamp: 0x533bca5c
Time String: 4/2/2014 1:29:16 AM
Product Name: ATI Radeon Family
File Description: ATI Radeon Kernel Mode Driver
File Version: 8.01.01.1379
Company: Advanced Micro Devices, Inc.
Full Path: C:\Windows\system32\drivers\atikmdag.sys

According to my research, the problem is the file in question wasn't expanded. These are the steps I have taken to fix the problem:
1: Go to C:\Windows\System32\Drivers and rename atikmdag.sys to atikmdag.sys.old.
2: Copy C:\drivers\AMD Win7 Driver(VGA, HDAudio, SATA)\Packages\Drivers\Display\W76A_INF\atikmdag.sy_ to Desktop
3: Run cmd as admin
4: Change the directory to Desktop by typing “chdir C:\Users\<name>\Desktop”
5: Type “expand.exe atikmdag.sy_ atikmdag.sys”
6: Copy the new atikmdag.sys from your Desktop to C:\Windows\System32\Drivers
7: Restart your computer.

The above steps have not fixed the problem, and further searches have not revealed anything useful.


My System SpecsSystem Spec
.
11 Mar 2017   #2
ChrisCamm

Windows 7 Home 64bit
 
 

Try disabling hardware acceleration in your browser options. That wont solve your issues but At least you Will be able visualize vídeos normally
My System SpecsSystem Spec
12 Mar 2017   #3
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Seven Fan mate first up please follow these
Dump Files - Configure Windows to Create on BSOD
&
Blue Screen of Death (BSOD) Posting Instructions

It makes it easier to help if we have those dumps on hand. But in any case it looks like you have a graphical issue a reference to atikmdag.sys in the dump info you have posted has a suggested fix of uninstalling the Catalytic Control Center and use only the driver from the card manufacturer and as your specs do not name the card I cannot link you to the driver. So please let us know what card it is and those dumps too.
My System SpecsSystem Spec
.

12 Mar 2017   #4
Seven Fan

Win 7 Pro x64
 
 

Quote   Quote: Originally Posted by ChrisCamm View Post
Try disabling hardware acceleration in your browser options. That wont solve your issues but At least you Will be able visualize vídeos normally
Actually, the videos play normally until a crash happens.
Quote   Quote: Originally Posted by ICIT2LOL View Post
Hello and welcome Seven Fan mate first up please follow these
Dump Files - Configure Windows to Create on BSOD
&
Blue Screen of Death (BSOD) Posting Instructions

It makes it easier to help if we have those dumps on hand. But in any case it looks like you have a graphical issue a reference to atikmdag.sys in the dump info you have posted has a suggested fix of uninstalling the Catalytic Control Center and use only the driver from the card manufacturer and as your specs do not name the card I cannot link you to the driver. So please let us know what card it is and those dumps too.
I tried to upload the dump by following those steps in the tutorial, but the window just goes white after clicking upload. Also, I do have the most up to date graphics driver. I even re-installed it.
My System SpecsSystem Spec
12 Mar 2017   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate now you might try going back a version of the driver sometimes the latest one is not always good.

Now what you can also do is to run these in safe mode
SFC /SCANNOW Command - System File Checker
Disk Check < if necessary include the /f switch and if this does not make any improvement then just run this switch instead /r in the command line as per Option2
Run these in safe mode and the sfc often best run for two to three runs – you can leave out the /r switch in ckdsk if you feel it not necessary

Now it might also be worth doing the automatic driver update from this http://pcsupport.lenovo.com/au/en/pr...0-75/downloads it is not going to hurt and that white screen may just be something to do with the chipset or whatever net connection you have for example. Now you will see on that site if you look at the drivers individually there are references to three different LAN devices again for example we might have to fidn otu which it is as well.

Just how old is this machine by the way??
My System SpecsSystem Spec
13 Mar 2017   #6
Seven Fan

Win 7 Pro x64
 
 

Quote   Quote: Originally Posted by ICIT2LOL View Post
Ok mate now you might try going back a version of the driver sometimes the latest one is not always good.
I'll see if I can find an earlier one.

Quote:
Now it might also be worth doing the automatic driver update from this http://pcsupport.lenovo.com/au/en/pr...0-75/downloads it is not going to hurt
That's where I got the drivers last time.

Quote:
white screen may just be something to do with the chipset or whatever net connection you have for example.
I seriously think that problem was this site. Only the upload window went white. Everything else, including the main browser window, was still normal. Plus, I've never had problems uploading or downloading files on any other sites with this PC.

I just tried uploading the file again, and this time it displayed the message, "invalid file". I tried both .dmp and .7zip.

Quote:
Just how old is this machine by the way??
I bought it new just a couple months ago. This model was released in 2016.
My System SpecsSystem Spec
13 Mar 2017   #7
Seven Fan

Win 7 Pro x64
 
 

I couldn't find older drivers at Lenovo's site, so I tried AMD's. There, I discovered Lenovo's so-called "Latest Driver" was severely out of date. AMD had a much more recent version.

I downloaded this and didn't notice any problems. Now I'm going to try to crash my PC with YouTube again and see what happens. Hopefully this is the fix I'm looking for. *fingers crossed*
My System SpecsSystem Spec
13 Mar 2017   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate good idea and for the record I find that some of the manufacturers sites are really convoluted and I am surprised to see you found the Lenovo site (though I put it in the convoluted list) was so out of date.

Now keep in mind that you may have to return this machine under warranty so don't go doing too much to it - all the same you shouldn't be having such an issue with a new machine either.
My System SpecsSystem Spec
13 Mar 2017   #9
Seven Fan

Win 7 Pro x64
 
 

Quote   Quote: Originally Posted by ICIT2LOL View Post
Ok mate good idea and for the record I find that some of the manufacturers sites are really convoluted and I am surprised to see you found the Lenovo site (though I put it in the convoluted list) was so out of date.
Me too, but the numbers prove it.

Also, I probably should've thought about it sooner. Lenovo's touch pad driver refused to install. The error message displayed something about unsupported hardware. I think Lenovo gave me the wrong driver for that. Fortunately, the touch pad works without it.

Maybe that touch pad has a site with the right driver...

Quote:
Now keep in mind that you may have to return this machine under warranty so don't go doing too much to it - all the same you shouldn't be having such an issue with a new machine either.
I've played YouTube videos most of the day without a crash, so it's looking good so far. If I can do that again, then I'd consider this cured.

Also, I think I may have voided the warranty already. I completely removed 10 and replaced it with 7. That's also when the problem started, lol.
My System SpecsSystem Spec
13 Mar 2017   #10
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok now I think maybe if you did not clean the drive before you installed 7 over the 10 it may have left remnants of 10 behind and could possibly be interfering with the system.

I always clean drives when I so this and in fact I find it easier to just buy a new drive anyway because a new SSD of say 500GB is not that expensive. Plus if you have the code for the 10 you can also make the machine a dual boot

Now have a look at my little ditty and see if you can find the brand of the touchpad and I have attached pics to show what you may see. You can view any of the components in in depth detail too using this software
Using HW Info
PART A:
You can test the volts on the PSU with HW Info HWiNFO - Download < download the right bit version and close the right hand window select Sensors and scroll down to the power section where you will see what the volts are doing see my pic. In my pic the section (Nuvoton) with VBATT as a dead give away you are in the section for the rail voltages. There are other section titles and one that pops up often is ITE (sometimes the usual one for Gigabyte boards)
Now the voltage on the different rails have to be within 5% =+/- of what is required or the machine will not work properly if at all.
Limits +/- (minimum - correct - maximum)
12v1 = 11.4 - 12 - 12.6v
12v2 = 11.4 - 12- 12.6v
5v = 4.75 – 5 - 5.25v
3.3v = 3.135 – 3 – 3.465v
-12v = -10.80 - -12 - -13.20v
+5VSB = 4.75 – 5 - 5.25v
The Power good signal voltage at pin 8 on the 24 pin plug (grey cable) should be the same as the 5v rail reading/s
See this for the rail voltage info
PSUs 101: A Detailed Look Into Power Supplies (Section 2.)
The original right hand window shows the machine running and is handy for that but for looking at the components in some detail close it and use the main left hand side panel
FOR OTHER COMPONENTS
PART B:
Open each small square with + in it on the section the components are in and then click on the individual component/s (it will highlight in blue) - in the right hand side will appear all sorts of details including brands speeds and other essential info that particular device. See pic for example.

So use PART B:


Attached Thumbnails
atikmdag.sys error when watching YouTube videos-touchpad.png   atikmdag.sys error when watching YouTube videos-hw-info-devices.png  
My System SpecsSystem Spec
Reply

 atikmdag.sys error when watching YouTube videos




Thread Tools




Similar help and support threads
Thread Forum
BSOD while watching videos/on Youtube, error 0x7E (atikmdag.sys)
Hello! I've been getting the same BSOD within an hour or two of using my computer. It's usually while I watch videos, but I've gotten instances of it while listening to music as well. I'm at a bit of a loss. I've updated my BIOS recently and that's solved many problems I've been having, but this...
BSOD Help and Support
error code : 0x1000007e while watching videos on youtube.
hello, I've had this rather peculiar problem as of late upon where while watching some form of video (usually happens while on youtube by coincidence) the audio will stutter everything will freeze and my pc will just restart. Initially I made nothing of it the first time and just ran start up...
BSOD Help and Support
BSOD watching youtube videos, error 0x0000007E
Hi, for months i would get a BSOD about once a week. A few weeks ago it started happening a couple minutes into every youtube video i try and watch. I can play games fine without getting BSOD and from my experience twitch also runs fine apart from being a bit jumpy for the first few seconds of...
BSOD Help and Support
BSOD watching YouTube Videos, error 0x000000d1
Good Afternoon, I am currently using an HP Compaq Elite 8300 SFF with Windows 7 Professional. I had an aftermarket graphics card installed (nVidia NVS 310) to be able to operate dual monitors. Typically the BSOD appears whenever I am attempting to watch a video online. Please help! Chris
BSOD Help and Support
BSOD when watching youtube videos, error 0x000000d1
For about a few weeks ive been getting BSOD sometimes i get them a couple times a day and sometimes a can go several days without one but they always happen when im watching youtube videos or playing games. To be honest im not very good with this kind of stuff so I'm sorry if I'm leaving something...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App