Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD After Trying to copy files to a raid storage pool

26 Sep 2017   #1
1971camaroguy

Windows 7 Pro 64 Bit Service Pack 1
 
 
BSOD After Trying to copy files to a raid storage pool

Hi Everyone,

First time poster here and I need some help. I am trying to get my NAS server running and I am getting a BSOD and shutdown. This is has happened twice after trying to copy files to the newly created storage pool.

This is a new build, with a new motherboard and used ram and processor. Not sure what is going on and feel like it has something to do with my raid, maybe?

I'm using megaraid storage manager (software based) to run my raid instead of the hardware raid controller.

I filled out the details of my system. Attached is the zipped file with the details of the error. If you need anything else let me know.

If anyone can help that would be awesome, I am not sure how to read these errors and don't want to start throwing parts at the build.

Thanks a bunch


My System SpecsSystem Spec
.
26 Sep 2017   #2
1971camaroguy

Windows 7 Pro 64 Bit Service Pack 1
 
 

Doing some digging, I was coming up with a few things. The BSOD death the 2nd time seemed to be caused by file afd.sys which is a Ancillary Function Driver for WinSock. Maybe try a different network driver? or an older version? I still need to complete some windows updates. I just paused it when copying files over.

The first one was an IRQL_NOT_LESS_OR_EQUAL caused by ntoskrnl.exe driver. Again, maybe this is an update issue?

Any ideas?
My System SpecsSystem Spec
26 Sep 2017   #3
1971camaroguy

Windows 7 Pro 64 Bit Service Pack 1
 
 

I did some updates and tried again, started copying files over and it crashed again cause by driver ntfs.sys....but I noticed all three of these errors were caused at crash address ntoskrnl.exe+6f980 each time.

I am really leaning towards this being memory issues, especially since I am using questionable ram purchased off eBay. I'm going to run memtest when I get home and see if I can narrow this down

Hopefully it's just a bad stick
My System SpecsSystem Spec
.

27 Sep 2017   #4
1971camaroguy

Windows 7 Pro 64 Bit Service Pack 1
 
 

Ran memtest and immediately started getting errors, ended up pulling all the ram out and adding it back one at a time until I found the culprit ....narrowed it down to one stick of bad ram (I hope)

Ran memtest against the three remaining sticks and got a pass

Thanks, glad I figured it out
My System SpecsSystem Spec
27 Sep 2017   #5
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi 1971,

Event logs are also flagging bad blocks

please run a disc check
chkdsk /r

Roy
My System SpecsSystem Spec
27 Sep 2017   #6
axe0

Windows 10 Pro
 
 

It looks like you may have issues with multiple drives.
Run chkdsk /r on your OS drive and on your RAID drives.
My System SpecsSystem Spec
Reply

 BSOD After Trying to copy files to a raid storage pool




Thread Tools




Similar help and support threads
Thread Forum
MP4 files work until I copy them to my generic usb mass storage device
Hi guys, I am attempting to simply copy downloaded mp4 files from my laptop/PC to my generic usb mass storage device. When I copy the files they lose the picture of the file and no longer play even after they have fully transferred and the size is exactly the same as the original file. Any...
Music, Pictures & Video
BSOD on Steam Update, Bad Pool Caller or Bad Pool Header, no dmp files
Good day all, I hope someone can help me with a consistent BSOD problem I've had today. Every time my Steam client starts up and attempts to download its latest update, I get a BSOD with a Bad Pool Caller (one time out of about a dozen crashes it was Bad Pool Header instead). I have tried the...
BSOD Help and Support
Win 7 Reinstalled - can't find my old storage RAID 0
Hi all, I recently had to reinstall Windows 7 on my SSD and can't get the fresh install to "see" my RAID 0 array that I've been using for storage. Here's my setup: SSD - Windows 7 =x64 Samsung Spinpoint F3 (2) - RAID 0 Biostar TA790GX 128M - using hardware RAID The hardware is all...
Hardware & Devices
RAID 5 switched from single storage to raid 5, lost drive letter
I am running 7 pro 64bit on a ASUS p8p67 deluxe mobo and I copied all data from my 1tb storage D: drive to a backup external and proceded to install raid 5 with 3 single 1tb drives and the raid is up an running. However using Intel Rapid Storage Technology to setup the raid inside windows I had to...
General Discussion
BSOD - Bad Pool Caller - Files Attached
Hello, I have been getting the BSOD error "Bad Pool Caller". Usually I am able to troubleshoot my problems and get it fixed, however this one is giving me fits, it seems to only happen when I am downloading something. I have attached the files, requested. Please give any advice! ...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:43.
Twitter Facebook Google+