Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD after RAID 1 is configured

11 Nov 2017   #1
askic

Windows 7 64 vir
 
 
BSOD after RAID 1 is configured

Hello to all,

I have one Dell T5500 workstation on which I can practice and experiment different things. I have come across to a very interesting problem.
I have tried to set up RAID 1 configuration with existing windows installation without loss of data using Intel Rapid Storage Technology software.

I have made all steps described here in this instruction.

So, there are really a lot of topics on various forums discussing BSOD caused creating RAID but this is in my opinion really specific case.

As I said I have DELL Precision T5500 workstation in which two disks are installed. The disks are not configured as RAID member disks and I want to them to be.
One disk is uninitialized. In BIOS setting "RAID ON" is enabled. So Windows 7 pro 64 bit is already installed on one HDD (SATA port 0).
During computer start, I can clearly see in Intel Matrix Storage Manager that both drives are listed as Non-RAID disks. There are no problems at all, the machine boots fine.
So in order to avoid loss of data or windows re-installation I have found instructions set how to configure RAID in windows.

So I have installed IRST software and followed all steps and everything went exactly according to the manual. When Migration data was finished (100%), I close IRST (actually minimized) and continue working in Windows.
However, after first reboot I received error message 0x000..7B (which meas windows cannot find bootable drive).
This BSOD is typical for example if BIOS setting is changed from ATA to AHCI or from AHCI to RAID.
But in my case nothing was touched in the BIOS. BIOS was already enabled with RAID ON and I only added second disk that was previously uninitialized and I created volume.
After very first restart, both disks were listed now as RAID members but windows didn't boot and ended with BSOD.

After reset disk to non RAID (both drives), Windows can boot without problems.

So, what could be the reason for this behavior here? The manual was very clear and I didn't make anything which was not described.
One thing that I don't know is how windows was installed in the first place, but I doubt that is important since it was booting OK when RAID is ON in BIOS.

To summarize, I didn't touch BIOS setting and only followed manual to create RAID volume in Windows (I was careful to migrate data from system drive to secondary drive). When boot from WIN PE disk or windows boot CD I can see that both drives have all folders and data.

On some other web sites I have found info that it is not possible to configure RAID without windows re-installation and that recommended procedure is to set up RAID 1 first and then to install Windows.
But I have found instruction on official manufacturer's site that states otherwise.

Do you have any advice?
Thank you


My System SpecsSystem Spec
.
11 Nov 2017   #2
rvcjew

7 Pro x64, 10 Pro x64
 
 

First of all do you have the optional PERC 6/i PCIe SAS/SATA/SSD hardware RAID card in this machine? Also do you have an external that an OS image can be saved to? If you are doing software RAID turn RAID off in BIOS if hardware then you get a bsod as the RAID drivers have to be in windows first.

Dell SAS 6/iR Adapter, v.00.25.47.00.06.22.03.00 , A05 Driver Details | Dell US
My System SpecsSystem Spec
11 Nov 2017   #3
askic

Windows 7 64 vir
 
 

Hello rvcjew,

thank you for your reply. I don't have separate RAID card in the machine. The controller is on the motherboard itself. BIOS options are:
RAID Autodetect/AHCI
RAID Autodetect/ATA
RAID on.
It is really a funny thing that is happening. RAID ON is enabled, and windows can start without any problem when it is Non RAID disk.
When I create new RAID volume in Windows using IRST and migrate all data , I can work in windows without any problems. First next reboot is BSOD STOP 0x0000007B (0xFFFFF880009A9928, 0XFFFFFFFFC0000034, 0X0000000000000000, 0X0000000000000000)

When enter Intel Matrix Storage controller during POST phase of computer's start and reset to non raid disks, computer can boot.

What is really really strange is this. When reset to non RAID disks, computer can start from any of the disks, so I have created a copy of a disk, which is to expect since RAID1 mirrors disk.
However, If I leave one disk (no problem booting) and add new, uninitialized disk, and then clone disk with Acronis true image sector, by sector (option As is) and when I leave only clonned disk, I get same BSOD message .

I cannot explain this behavior at all. So with no BIOS changes I clone bootable disk and the result is non bootable disk.
My System SpecsSystem Spec
.

11 Nov 2017   #4
rvcjew

7 Pro x64, 10 Pro x64
 
 

That's because your making a RAID 1 so its a mirror so its good till you reboot. If after you create the RAID volumes and the BIOS says it is one array now I personally would do it this way. Remove raid, get Macrium Reflect Free and make an image of your first OS disk on an external, then make the raid and go into Macriums windows PE bootable it has you make on a flash drive (when it launched) and you should see your Two drives as the one on there and if you do then select it and make it erase and put your os image on it and it will be as windows wants it. The hardware will do the mirroring for you as it is set as a RAID 1 Array for all data on it. EDIT: once you make the array please post a pic of your Disk Management in windows.
My System SpecsSystem Spec
11 Nov 2017   #5
askic

Windows 7 64 vir
 
 

Hello rvcjew and thank you very much for your suggestion. I'll have a chance to test it on Monday. Just want to be sure that I understood correctly.
I'll boot windows on non Raid disk, install macrium reflect, create bootable cd or usb and then make image of this hdd.
Then, I will connect second hdd on sata port 1, boot into windows and create Raid1. After few hours when data migration is completed, I will reboot machine and start from macrium PE bootable cd or usb. Then I'll restore image on new volume and hopefully after restart it should work?

There is one thing I don't understand though. I' d make image from non raid hdd and then I' d restore it on Raid volume. Why windows would boot in that case?

Maybe I should create macrium image after IRST in windows completes data migration?

definitely there is no Raid HW card. Raid is implemented in BIOS, so it needs raid drivers and causing BSOD 0x0...7B
My System SpecsSystem Spec
11 Nov 2017   #6
rvcjew

7 Pro x64, 10 Pro x64
 
 

Yes except that if you can build your array after making the Image in the bios app Intel matrix application do that and forgo using irst to build it.
My System SpecsSystem Spec
11 Nov 2017   #7
askic

Windows 7 64 vir
 
 

Yes, I can use matrix storge to define raid member disk in bios phase. When I encounter BSOD, I use intel matrix storage in bios to reset disks to non raid in order to boot again.
Ok, I will use macrium to make image of bootable non raid disk to external drive, then I will set up raid in matrix storage in bios (this will wipe data) and then I'll restore macrium image to new raid volume.
My System SpecsSystem Spec
11 Nov 2017   #8
rvcjew

7 Pro x64, 10 Pro x64
 
 

Good luck and macrium should see the two disks as one if you set it up right.
My System SpecsSystem Spec
12 Nov 2017   #9
askic

Windows 7 64 vir
 
 

Hello,
I tried the suggested solution and it didn't work. I have installed Macrium reflect together with PE on bootable drive and made complete image (whole drive with partitions). After that, I have removed that drive and install two new with the same capacity (500GB). During boot with Ctrl+I I have entered Intel Matrix storage and defined both drives as RAID 1. The drives are WD Blue 7200 rpm. The original (bootable)drive is Seagate st500dm002.
After started from Macrium Rescue CD, I've chosen image from extern USB drive but couldn't find destination disk. RAID volume is simply not visible by Macrium reflect.

I tried that very same with Acronis 2016. Acronis did see RAID WD disks as one volume 500 GB (465.8) and I use this volume as destionation, but result was the same BSOD.

In order not to play too much with original drive, I reseted all drives to non RAID and picked one of the WDs. This time, the drive was visible to Macriuem and I used this drive as destination. I have restored image from original ST drive to WD and tried to boot from WD. It ended with BSOD. So I cloned original drive to other WD drive. Again, boot ended with BSOD.

I don't know how to explain this. Maybe this has nothing to do with RAID. Is it possible that this original ST drive is somehow protected?

I cannot understand why cloning doesn't work. I also noticed one more thing on working ST drive. Usually win 7 have one 100 MB partition that is used to boot, but in this case there is no reserved partiion. C partition is both boot and active.

Maybe to try to install windows 7 on new HDD (WD) and then to use Macrium or Acronis to restore drive but without MBR restore?
My System SpecsSystem Spec
13 Nov 2017   #10
askic

Windows 7 64 vir
 
 

i have made few more tests today. All were unsuccessful, but I have found out more things.

First things first. I have not made existing installation. This installation doesn't contain 100 MB reserverd partition for boot purpose, ike "normal" windows installation would make. Partition C is primary, boot and active.
Second I reset all disks to non Raid, remove them from computer, put back original disk, make backup image on external drive with Acronis as well as Macrium. These backup creation ended successfully.
Next step is to remove original disk, put new Hdd in the machine and restore image (even with disk signature in Acronis). The recovery ends without problems, but when trying to boot again BSOD. So I made fresh new installation of windows just for testing, created backup and restore to the ssecond HDD and in this case windows boots Ok.

So it must be some kind of setting in windows on original drive that prevents boot after recovery on new disk.
I examined the original windows and saw that there were some changes in group policy. For example when switching between different accounts in the device manager Dvd drive is listed as not installed correctly. I need to go manually and chose update driver, and after few seconds Dvd drive is visiblw in "my computer". It is exactly the same when reinserting network card.
Is it possible that some group policy in windows prevents normal boot?

I have found this and that made me thinking.
Acronis Backup Software: BSoD after Restore to New Hardware with "Stop 0x0000007B" Due to Restricted Installation of Devices | Knowledge Base
I have found this and will try it to see if this is the cause.
My System SpecsSystem Spec
Reply

 BSOD after RAID 1 is configured




Thread Tools




Similar help and support threads
Thread Forum
Click to run not configured
Upon trying to open forms from websites I get little prompt in bottom left corner once clicked I get "click to run not configured". How do I fix this annoying little message?
Browsers & Mail
All my apps think I have 2.0 configured but 5.1 is set
I have Windows 7 Professional x64, and a Xonar DS I have been searching over and over on how to fix this, but VLC and all my games are defaulting to 2.0, Yet I've set all the options I can find to 5.1. http://i.imgur.com/ei8yP.png As you can see everything is set to 5.1, but VLC is still...
Sound & Audio
15 PC's all configured similar all experiencing random BSOD's
Hello experts, I am an IT provider and I set up 15 heavy duty computers at 15 client locations. They are all exactly the same PC: Dell Optiplex 990 Core i7 4GB RAM preinstalled + 8GB RAM installed by me 500GB HDD Ruuning the preinstalled OEM copy of Windows 7 64-bit.
BSOD Help and Support
Configured 8 TB external drive as a RAID 5 + 1, how can I verify?
Hello, Purchased a 8 TB LaCie 4 Big Quardra U device, decided to configure it as RAID 5 + 1. Followed instructions, but just want to verfiy that I did it correctly. Where would I look on my system to confirm that I did it correctly. Is this something that would be reflected in...
Backup and Restore
Can FF Menu Bar be configured?
Using FF 3.6.10. Can the menu bar be configured? I would like to remove the "History" pulldown option from the Menu Bar. Is this possible? Thanks.
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:57.
Twitter Facebook Google+