Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD "UNMOUNTABLE_BOOT_VOLUME" when replacing DATA drive

02 Aug 2019   #1
JoHel

Windows 7 Professional 64bit
 
 
BSOD "UNMOUNTABLE_BOOT_VOLUME" when replacing DATA drive

So I have this problem that I am currently unable to use a new bigger SSD that I acquired as new "data" drive. What looked like a simple cloning/replacement operation to get going without a lot of hassle, is now giving me a headache. Because it seems clear that SOME KIND of small subtle tweak should be able to FIX this, but getting it wrong and messing things up could very easily totally spin out of control and end up with MORE effort than just starting all over, lol... And THAT is exactly what I wanted to avoid, half a year before I imagined a reinstall to Win10-only would be needed anyway. It's just NOT the moment here to spend days on this stuff.

In order to be able to at least use the drive from within my Windows 7 - all other consequences be damned ! - I AM willing to troubleshoot a lot deeper, but ONLY if someone has a pretty good idea where the problem might be and how it could be fixed without borking the Windows 7 installation in an endless trial & error nightmare, lol... I envision that some targeted edits to the BCDstore and/or registry could get things in working order, even just the Windows 7 installation. A proven way to CLONE the Windows7 from the PCIe to the SATA, and repurpose the PCIe drive as a datadrive is another compromise that I could accept.

UltraShort version:

Unable to reach the login screen on my Windows 7 Professional (on PCIe M.2) laptop as soon as I replace an existing 1TB SATA SSD in the 2"5 bay by a new 2TB SATA SSD.

Slightly longer version:

I have a perfectly working system with dual-boot between Win7Pro (PCIe M.2 drive) and Win10Pro (2"5 SATA SSD). See attached Disk Management screenshot for the layout as seen from within Windows 7. The Windows 7 Pro system partition is encrypted with TrueCrypt (TrueCrypt password is the VERY first thing that I have to enter when my laptop leaves the BIOS, then I can choose Win7 or Win10), but currently I don't think this is part of the actual problem, just potentially a bit of complication for troubleshooting and fixing.

I ASSUMED that it would be trivial to replace the 1TB by a 2TB by just cloning the contents, but various cloning attempts, although reporting "success", invariably end up with a Windows 7 that bluescreens somewhere between the "spinning fading balls" logo and the login screen, and an IMMEDIATE lightblue boot error screen when trying to boot into the Windows 10. (specific errors further down). Even "Safemode with commandprompt" doesn't make it, so it looks like a fix would need to go through a boot from installation media (AND temporarily decrypting the Windows 7... arg) (However, the Windows 7 works perfectly as long as just the original drives are in the system, so I could also do changes while it is running, BEFORE changing the SATA disks... Just afraid of breaking the WORKING system that way)

It seems reasonable to suspect that this specific dual-boot setup (more about it later) is the root cause.


The new disk itself is perfectly fine, as I was able to install and use Windows 10 on it when using it in a situation when it is the only drive in the laptop. (PCIe disabled in BIOS)


I also confirmed that currently the PCIe SSD IS the "first hop" after leaving the BIOS, as the system is not able to leave the BIOS when I remove the PCIe from the "boot order" list there.


Some further non-destructive testing that I did DOES confuse me somewhat, as it seems to suggest at the same time that nothing ESSENTIAL is on the replaced SSD for making the Windows 7 functional (I can leave the bay empty!), but the mere PRESENCE of the disk causes the bluescreen:

  • when I use EasyBCD from within the Win7Pro to remove the Win10 entry from the bootmenu screen, and I also remove the driveletters from all partitions that were NOT on the PCIe SSD in the hope that NOTHING would still be referenced on other disks than the M.2, the Win7Pro (on the M.2 SSD !) STILL bluescreens with the error
  • when I remove ALL cloned partitions and disk structures again from the 2 TB SSD and put it in the system, the Win7Pro (on the M.2 SSD !) STILL bluescreens with the error
  • when I remove the 2 TB SSD COMPLETELY (empty slot), the Win7Pro only goes through "diskcheck" requests, but then boots just fine!


Still more detail:


DELL Precision 7510 laptop with:

  • 512GB M.2 PCIe SSD, with Win7Pro System partition
*** this is currently still the OS that I use 95% of the time, and my priority would be to KEEP this functional EVEN if it would mean that I wouldn't be able to boot into the Win10 for a while until I reinstall everything when Win7 support stops ***
  • 1TB SAMSUNG 2"5 SATA SSD, with Win10Pro System partition, and the main data partitions for the Win7Pro

When I installed the system 3 years ago, I went through quite a bit of trouble (making Win7 able to boot from PCIe for example) to get this into a dual-boot config. On top of that, and I'm not 100% sure to what extent this complicates matters, the Win7Pro System partition is encrypted with TrueCrypt. Too long ago to remember the exact details of how and in which order I achieved all this, but I do seem to remember that it required quite some trial & error, and it ended up with this specific setup/order because nothing else seemed to work.

When I boot the laptop I first have to provide the TrueCrypt password, I then get the "Windows 7 style" black text screen choice of which OS to boot, in which I also have an entry for the (not encrypted) Win10 Pro on the 1TB SATA SSD, and I can boot into either of them.

Diskspace shortage is the reason for the disk replacement. Both current and new SSD are SAMSUNG EVO.

First approach was to boot into the Win10 on the current SATA SSD, and use the Samsung data migration tool to just clone the system partition "live" over a USB-to-SATA adapter. However this fails at the very end of trying to transfer this system partition (offers no clues why). I then used the free "AOMEI Partition Assistant" tool, and this seems to do totally fine with for example "Disk Clone", it reports that cloning is successful, I find the partitions on there etc.

So I remove the 1TB SATA and put the 2 TB SATA with the cloned contents in the system.

BUT... WHATEVER I try(cloning partitions or full disk, sector-by-sector or just data...), not only does the Win10Pro on the new SSD fail to boot with this error:

File: \WINDOWS\system32\winload.exe
Error code: 0xc000000e

EVEN the Win7Pro (which boots from the PCIe SSD that wasn't touched!) bluescreens with:

"UNMOUNTABLE_BOOT_VOLUME"
STOP: 0x000000ED



What I also tried for "non-destructive testing", is virtualising the current setup with VMWare vCenter Converter, and trying to run that VM in VMWare workstation. Basically, the virtual machine that I get that way behaves identically to the physical system when the 2TB SATA disk replaces the 1TB SATA! The conversion itself fails at the end with a message that indicates that there are problems when trying to "adapt" things like BCDstore or registry or something to the virtualised hardware/disklayout situation. And ALL the attempts that I did on the VM to "fix startup problems" with bootrec commands and such, and/or removing disks or changing the order, or removing partitions before trying repair options etc. FAILED. So THIS in particular makes me uncomfortable at the idea of going that way with trial & error on my physical system. The most "standard" recommended actions do NOT seem to fix the issue.



My System SpecsSystem Spec
.
02 Aug 2019   #2
JoHel

Windows 7 Professional 64bit
 
 

Thanks everyone in advance for suggestions and brainstorming!

Possible outcomes, in order of preference:

1) I'm able to clone the contents of the 1TB SATA to the new 2TB SATA, fix the problems with some BCDstore and/or registry edits, and use the system exactly as it is currently used, with the diskspace bonus as expected

2) I'm able to at least keep using the current Windows 7 Pro installation on the PCIe SSD, giving up on the current dual-boot setup, with the 2TB SATA available for datastorage. I suppose THAT would also mean that at least it would still be possible to install Windows10 on the 2TB SATA while that is the only available drive, such that the two OSs are not aware of each other, and afterwards achieve dual-boot - with the two drives enabled - by going through the BIOS boot selection screen.

3) I'm able to transfer the existing Windows 7 installation from the PCIe to the new 2TB SATA in bootable fashion, and start from there , re-purposing the PCIe drive as a data-drive only, but at least I have the extra diskspace of the new 2TB SATA available then. The extra speed from PCI M.2 is mostly convenient for rapid experimentation with VMs in VMware workstation, anyway.

4) nobody is REALLY confident enough to pinpoint the rootcause, and in frustration I order an extra 1TB PCIe so I can clone that one first in an attempt to get a "fallback" Windows 7 Pro PCIe. Then I would no longer be afraid to go through risky trial&error repair steps on the existing PCIe (and then when solved repeat them on the new one). Would give me even MORE extra diskspace, but would also feel as a defeat and negate the feeling that I had about how the 2TB was a "good deal", LOL

X) no solution found: complete reinstall necessary starting from situation with PCIe + 2TB SATA drive in system
My System SpecsSystem Spec
12 Aug 2019   #3
JoHel

Windows 7 Professional 64bit
 
 

This seems to be a tough one? Nobody any suggestions? Could additional BSOD information provide any useful clues?

What I DID find out, is that at least the Windows 10 boot error makes sense on some level: apparently, the BCDstore stores somekind of hash value partially based on a unique harddrive identifier. That one CHANGES even if you make a one-on-one perfect clone from one SSD/harddrive to a new one. The way to fix THAT, would be to boot into the Windows 7 installation and do a BCD repair, so it fixes the entry for the dual-booted Windows 10.


However, so far it seems to remain a MYSTERY why the Windows 7 ITSELF bluescreens (and prevents me from taking that step). And even MORE so, WHY does it NOT bluescreen when that drive is NOT in the system, but DOES once it is just in the slot without even any partitions on it???


I'm hesitant to try out BCD repairs on the Windows 7 from recovery media, as long as there's no plausible explanation for that one... At least I have a perfectly usable system right now, and I could easily f*ck that up when I first have to decrypt the TrueCrypt system encryption, and then go through BCDrepair steps that sound poorly understood right now..


Pretty frustrating to have that shiny new 2TB SSD just lying unused on the table in front of me right now, though LOL.
My System SpecsSystem Spec
.

12 Aug 2019   #4
JoHel

Windows 7 Professional 64bit
 
 
diagnostics upload

since I see thread has been moved...


Attached Files
File Type: zip 7510HOME-ma_12_08_2019_173219,90.zip (2.06 MB, 0 views)
My System SpecsSystem Spec
Reply

 BSOD "UNMOUNTABLE_BOOT_VOLUME" when replacing DATA drive




Thread Tools




Similar help and support threads
Thread Forum
How to point "Desktop" to D-Data drive from current C-Program drive?
Hi, I just got a new pc for my wife with two (2) 256GB Program SSD's, two (2) 1-TB Data SSD's all done up in a RAID config and Windows 7 Pro.
General Discussion
"Unmountable_boot_volume" error. urgent.
Hello everyone, I need help fixing a "Unmountable_Boot_Volume" error on windows 7 home premium. what happens is you get a windows error recovery screen on boot. but when you click on "launch startup repair" you get normal "windows is loading files and they it just goes back to the original error...
BSOD Help and Support
BSOD , After "Shut Down noise" : "Unmountable_Boot_Volume"
So I basically heard a "shut down noise" from my PC that lead to the blue screen. After I restarted it I only had, Repair system and Start Normally. There was no safe mode. I used build in system check and it stop on 50% on my hard-drive saying "biohd-8" error. I did a crc check in system repair,...
BSOD Help and Support
"Reboot and Select proper Boot device" with only 1 data drive
Hello, So a while ago my computer crashed and I wasn't sure what it was so I tried many things because I wasn't getting any BIOS beeps so I thought it was the motherboard but long story short it's the graphics card, so I've replaced that with my old one for now. But since I took out so many...
Installation & Setup
Does a system image save "deleted" data on the hard drive
I'm trying to wipe/secure erase my computer hard drive and put it back to factory settings--the computer is getting sold. From reading the forums, I realize I can use clean all or other programs to write over the "deleted" data with ones or zeros. However, my plan of action was to: 1. Use...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:40.
Twitter Facebook