Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD due to RAID to AHCI

3 Weeks Ago   #1
pooze

64 bit Windows 7 Enterprise
 
 
BSOD due to RAID to AHCI

So, I need some adult help here... let me explain my problem:

I have a Win 7 64 bit enterprise install on a Dell Latitude E7450--it's an MBR install with legacy mode enabled in the BIOS and 'RAID' selected for the SSD.

I need to image this machine as is and transfer it to different one--I've tried to this with various options (Clonezilla, Acronis, AOMEI) with the various 'recovery' options and always wind up with a BSOD 7B error.

I've narrowed down the reason for it being that the Latitude is said to RAID and the other machine (although it also has RAID options in the BIOS) is incompatible no matter how I set it (SATA or RAID, M2 etc);

Working on the other machine I've tried just about everything I could find online (about 2 weeks so far now at this) including as previously mentioned using things like ACRONIS recovery, the registry editing of controlset drivers, etc. nothing works--same BSOD.

Let me be clear--I cannot do a clean install, because I need the image as is for reasons I cannot elaborate on. I was able in testing to do a clean install of Win7 on the new machine and it works fine.

Now, working on JUST the Latitude, I figure if I can get the thing to boot properly with AHCI enabled instaed of RAID, the image should function on the other machine--but I can't even get this to work.

I've tried the Win7 repair disk trick, as mentioned enabling pretty much every driver through the registry by setting the start keys to 0 and booting multiple times, into safe mode (which also crashes on both machines, every single time when reaching classpnp.sys or some other driver).

At my wits end here--nothing seems to enable win7 to boot when changing RAID to AHCI in the bios, no matter how I prep the machine. I also cannot do a sysprep /generalize because it will destroy what I'm trying to achieve here which is a full transfer of my existing system including domain accounts.

Any ideas? I've tried going to GPT/UEFI, messing with BCD, to no avail. I even took the entire registry (controlset) from the clean win7 install that worked, along with the sys32 drivers and copied that to the non-working install--that managed to get windows to boot past the moving fire balls but stalled anyways. In safe mode it just hangs on classpnp.sys and won't go any further. I've tried the control+break trick and it doesn't do anything.

FYI--I've also tried all the scripts and so forth to install and enable pretty much every driver (resulting in very long safemode boots)--but it still hangs. Just can't get this to work.

Also--this laptop does not have IDE mode available, only RAID or AHCI--and a single SSD installed.


My System SpecsSystem Spec
.
3 Weeks Ago   #2
johnhoh

Win7 pro x64
 
 

I agree with your idea of getting it working in AHCI mode as a first step. RAID aside, the most common reason I've found that a windows drive won't boot on another motherboard is hard drive controller incompatibility, and the solution is to switch the drive controller driver to the generic controller. That is, when you switch from RAID to AHCI in bios, you have to change your drive controller driver first. So here are several methods, try each individually
------------------------------------
1. Run MSCONFIG
2. Enable Safe Boot (minimal)
3. Reboot into UEFI/BIOS and change to AHCI
4. Boot up into safe mode
5. Run MSCONFIG and disable Safe Boot.
6. Reboot
-----------------------------
1. change the START value to 0 in each of these keys
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi
2. then reboot and change to AHCI in bios
--------------------------------
1. go into device manager and change your hard drive controller to "Standard AHCI 1.0"
2. then reboot and set AHCI in bios
----------------------------
My System SpecsSystem Spec
3 Weeks Ago   #3
pooze

64 bit Windows 7 Enterprise
 
 

So I've tried this and it doesn't work.

If I do steps 1-3, it won't boot into safe mode, I get a BSOD on step 4.

I've done steps 1-2 below, rebooted multiple times to allow windows to 'load' the drivers, then tried changing to AHCI, BSOD's.

Can't change the SCSI adapter in the device manager to AHCI. Can't add the AHCI controller.
My System SpecsSystem Spec
.

3 Weeks Ago   #4
johnhoh

Win7 pro x64
 
 

Somehow you've got to rid of that scsi driver. Somehow.

Yeah my bad, the ahci driver is not going to load as long as you have booted with raid selected in bios. Have you tried removing the scsi driver from device manager but NOT replacing it, just immediately restarting? Or removing it then immediately restarting into safe mode? Or removing it while in safe mode, shut down, then select ahci in bios, then powering up?
My System SpecsSystem Spec
3 Weeks Ago   #5
pooze

64 bit Windows 7 Enterprise
 
 

Well I've taken the working image on the Latitude, installed all the drivers (including the disk controllers) for the other machine (a thinkpad), imaged that, copied it over and it still BSOD's no matter how I set the controller in the BIOS.

In Safe mode it makes it to disk.sys then crashes... before it that it appears to succesfully load just about every SCSI / sata driver there is... so not sure what the hanging point is now. I did install the intel chipset drivers for this as well...

I should mention one other thing I guess in terms of combinations:

The host computer that is being imaged has RAID mode with 'legacy' MBR boot;

The new computer does NOT allow this combination. If I select RAID (either SATA or M.2) it defaults to UEFI ONLY with supposed legacy support (CSM). If I disable RAID, then it allows me a different option in the BIOS for full legacy support and the ability to choose it in preference to UEFI.

Wonder if this is an issue? I have converted the imaged disk to UEFI by creating new partitions and re-creating the BCD--it's the only way I could get it to boot with RAID enabled (which the host machine had by default).

Stupid.
My System SpecsSystem Spec
Reply

 BSOD due to RAID to AHCI




Thread Tools




Similar help and support threads
Thread Forum
Going from AHCI to RAID
So, I wasn't able to install W7 in RAID because the installation wouldn't recognize any proper driver for the installation. I have no idea why, but anyway, I decided to proceed by installing in AHCI mode. So now, Windows is fully installed, I have an ASUS Rampage Formula IV motherboard (X79)...
Drivers
Switching BIOS SATA RAID/AHCI setting causes BSOD at Windows Start
I just changed my disk setup from: 1 SATA HDD Primary OS Disk 2x SATA HDD Backup Disks in RAID 1 TO: 1 SATA SSD Primary OS Disk 1 SATA HDD Backup Disk
Hardware & Devices
Raid vs AHCI
While experimenting with a USB bootable Macrium Restore thumb drive I created, I was looking in my Bios and noticed the SATA controller was set to Raid. I have only one internal HD. I changed it to AHCI and booted up, got a notice that new drivers were being installed and rebooted. The...
Hardware & Devices
Raid, AHCI or IDE
I have a friends HP system I'm fixing for him. His hard drive died, totally inaccessible (750GB SATA 3 Seagate). I ordered the recovery DVD and a new hard drive. In BIOS, the SATA controller can be set to Raid, AHCI or IDE. My question is, which is the right one to use. It was set to Raid but...
Installation & Setup
Ahci & raid
I recently bought 2 120GB OCZ Vertex 2 SSDs, a new CPU heatsink, and 2 new video cards (5850s). I was running my Windows 7 64 on 2 WD velociraptors in RAID0 prior to rebuilding my system. I never had any issue with Windows installation. I tried setting up my system to where my SSDs would be in...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:41.
Twitter Facebook