Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Getting a blue screen of death!

01 Dec 2009   #1

Windows 7x64
Getting a blue screen of death!

I've been getting a blue screen of death. It started pretty recently and seemingly randomly. Here's the minidump.


My System SpecsSystem Spec
01 Dec 2009   #2

Windows 7x64

Some extra details:

We tested the ram, there was nothing wrong with it (as of yesterday anyway). The problem had occurred with updated video drivers, following advice saying that Dragon Age was crashing with the latest nVidia drivers and to roll back, we rolled back to 90 drivers as opposed to the 95 drivers.
My System SpecsSystem Spec
01 Dec 2009   #3

Windows 7x64

Starting to think it's the HD dying. I've since gotten a Page Fault BSOD and a memory management error. Gonna try ghosting to a new HD and see if that solves it. The HD in there is one salvaged from a computer that was hit by lightning.
My System SpecsSystem Spec

01 Dec 2009   #4

Win 8 Release candidate 8400

Quote   Quote: Originally Posted by Coridan View Post
I've been getting a blue screen of death. It started pretty recently and seemingly randomly. Here's the minidump.


Hi and welcome.

I took a quick look at your dmp while we are waiting for an expert at this I noticed a couple of things
First, several drivers are more than 3 years old and need to be updated. Second this dump probably was caused bu indexing, and it took ntkrnl with it.

I would update the drivers

Since a system file was involved I would run a system file check to verify and repair system files
to run type cmd in search>right click and run as admin>sfc /scannow.

As usual
If you are overclocking stop
if you have a raid update its driver

downloading memtestx86 might be called for and should be run for several hours

If you have any more bsod upload the dmp

Hope this helps

Ken J+

ASACPI.sys fffff880`02be5000 fffff880`02bed000 0x00008000 0x42476c4c 3/27/2005 9:30:36 PM
secdrv.SYS fffff880`08731000 fffff880`0873c000 0x0000b000 0x4508052e 9/13/2006 8:18:38 AM
speedfan.sys fffff880`01883000 fffff880`0188a000 0x00007000 0x45168798 9/24/2006 8:26:48 AM
x10ufx2.sys fffff880`04087000 fffff880`04093000 0x0000c000 0x456f66db 11/30/2006 6:18:51 PM

Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\K\Desktop\120109-25084-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*d:\symbols*Symbol information
Executable search path is:
Windows 7 Kernel Version 7600 MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`01a57000 PsLoadedModuleList = 0xfffff800`01c94e50
Debug session time: Tue Dec 1 09:11:52.430 2009 (GMT-5)
System Uptime: 0 days 0:05:38.242
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
* *
* Bugcheck Analysis *
* *

Use !analyze -v to get detailed debugging information.

BugCheck A, {8000000028, 2, 1, fffff80001adfd79}

Probably caused by : ntkrnlmp.exe ( nt!KeReleaseSemaphore+329 )

Followup: MachineOwner

1: kd> !analyze -v
* *
* Bugcheck Analysis *
* *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.

If a kernel debugger is available get the stack backtrace.
Arg1: 0000008000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
bit 0 : value 0 = read operation, 1 = write operation
bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80001adfd79, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80001cff0e0


fffff800`01adfd79 f083402801 lock add dword ptr [rax+28h],1




PROCESS_NAME: SearchIndexer

TRAP_FRAME: fffff8800a803790 -- (.trap 0xfffff8800a803790)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000008000000000 rbx=0000000000000000 rcx=0000000000000001
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80001adfd79 rsp=fffff8800a803920 rbp=fffffa8006038f28
r8=0000000000000000 r9=0000000000000000 r10=0000000000000000
r11=fffff8a00601ee00 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl nz na po nc
fffff800`01adfd79 f083402801 lock add dword ptr [rax+28h],1 ds:00000080`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80001ac8469 to fffff80001ac8f00

fffff880`0a803648 fffff800`01ac8469 : 00000000`0000000a 00000080`00000028 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0a803650 fffff800`01ac70e0 : 00000000`00000000 fffffa80`06038f20 00000000`00000000 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`0a803790 fffff800`01adfd79 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x260
fffff880`0a803920 fffff800`01dc74d4 : fffffa80`00000000 fffff8a0`00000001 00000000`00000000 fffff8a0`0601ed00 : nt!KeReleaseSemaphore+0x329
fffff880`0a8039a0 fffff800`01dc593e : 00000000`00000000 00000000`00000000 89800000`0010001b fffff880`0a803a10 : nt!AlpcpCompleteDispatchMessage+0x9a4
fffff880`0a803a30 fffff800`01dc5f4f : fffffa80`00010000 fffff8a0`01669118 00000000`00000001 fffff880`00000000 : nt!AlpcpDispatchNewMessage+0x24e
fffff880`0a803a90 fffff800`01db2de7 : 00000000`00000000 00000000`00000001 00000000`00000000 00000000`00000001 : nt!AlpcpSendMessage+0x4ad
fffff880`0a803b90 fffff800`01ac8153 : fffffa80`04fd9b60 fffff880`0a803ca0 fffffa80`05fc65f0 00000000`00000000 : nt!NtRequestPort+0x9f
fffff880`0a803c20 00000000`770012ea : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`04c4f628 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x770012ea


fffff800`01adfd79 f083402801 lock add dword ptr [rax+28h],1


SYMBOL_NAME: nt!KeReleaseSemaphore+329



IMAGE_NAME: ntkrnlmp.exe


FAILURE_BUCKET_ID: X64_0xA_nt!KeReleaseSemaphore+329

BUCKET_ID: X64_0xA_nt!KeReleaseSemaphore+329

Followup: MachineOwner
My System SpecsSystem Spec
01 Dec 2009   #5

Windows 7x64

Here is all the mini dumps from today


As for the 3 year old drivers, those are all accounted for and irrelevant drivers (one is for ATI Remote wonder for example) There were no driver changes before the crashes started to occur (we have since updated some to try and solve it, to no avail.)
My System SpecsSystem Spec
01 Dec 2009   #6

7600.20510 x86

Hi Coridan.

This is your problem:

ASACPI ASACPI.sys Sun Mar 27 22:30:36 2005
speedfan speedfan.sys Sun Sep 24 09:26:48 2006

Update to a 2009 driver for those or uninstall the apps that installed them. The first one is a motherboard utility driver, ATK0110.
My System SpecsSystem Spec

 Getting a blue screen of death!

Thread Tools

Similar help and support threads
Thread Forum
Stuck on black screen of death, after blue screen of death
In need of serious help.* To begin, I am stupid and haven't backed up any of my files so for now a windows reinstall is out of the question. (unless it's completely necessary) okay, so the problem: I was using my computer as normal. Then while on Google Chrome, it started getting slow and said...
General Discussion
Geforce 7300 LE - Blue screen of death - Multiple lines down screen.
Today I booted my computer up to be promoted with a black screen, I gave it a good half an hour before forcing it to shutdown, to which when I booted it back up. Was then promoted with a blue screen about the video card not being able to lead, that happened twice. I then booted it into safe...
Graphic Cards
Blue screen of death!!
:cry: i am doing my own things when suddenly the blue screen of death appears.WINDOWS HAS SHUT DOWN TO PREVENT DAMAGE TO YOUR COMPUTER,it happened 3-5 times Help please:cry:
BSOD Help and Support
blue screen of death
Ok. I was looking for free movies online when when I click this download I know I shouldn't have but anyway I got the blue screen so I shut down my p.c rebooted then tried to restore it to factory settings but I stell have it I tried rolling back all the drive it would let me that didn't work after...
BSOD Help and Support
Black Screen of Death/Blue Screen of Death
Hello everyone. I have a Toshiba Satellite L450D-13X computer for the kids, and for the price it's a good laptop. Have had no issues with it until two weeks ago when the screen froze for the boys whilst playing a game and downloading a program from the net. Had to do a force shutdown and since...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App