Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Boot\bcd error, /fixboot dosent work

26 Dec 2009   #11
Darsiant

Windows 7 ultimate x86
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Let me get this straight: you boot into the Repair Disc and it finds the installation?
No, I go to repair instalation but it dosent show any os's in the list, however it still let's me go into the recovery options (startup recovery, command prompt, etc.) without selecting an os


My System SpecsSystem Spec
.
26 Dec 2009   #12
Jonathan_King

Windows 7 Professional x64
 
 

I must confess I am stumped. I have never before seen a case in which marking the partition as active, then running Startup Repair 3 times did not work. Hang on, I will send out a call to our experts. Stand by!
My System SpecsSystem Spec
26 Dec 2009   #13
Darsiant

Windows 7 ultimate x86
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
I must confess I am stumped. I have never before seen a case in which marking the partition as active, then running Startup Repair 3 times did not work. Hang on, I will send out a call to our experts. Stand by!
Thank you for the help. I just thought that I'd add that the results of the startup repair say "root cause found, partition table is corrupt on disk \device\harddisk0."
My System SpecsSystem Spec
.

26 Dec 2009   #14
Jonathan_King

Windows 7 Professional x64
 
 

Thanks, that helps a lot. Let me get back to you.
My System SpecsSystem Spec
26 Dec 2009   #15
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Which of the 3 Hd's did you install Win7 on ? What was the first OS on harddisk0 ?
My System SpecsSystem Spec
27 Dec 2009   #16
Jonathan_King

Windows 7 Professional x64
 
 

Could you try running bootrec.exe /FixMBR again?
My System SpecsSystem Spec
27 Dec 2009   #17
Darsiant

Windows 7 ultimate x86
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Could you try running bootrec.exe /FixMBR again?
Tried it, restarted, same error.
My System SpecsSystem Spec
27 Dec 2009   #18
gregrocker

 

Be aware the GRUB-corrupted Win7 MBR's are nearly impossible to recover if any remnants of GRUB remain.

Please unplug all other drives but Win7.

Boot into Win7 DVD and click through to recovery tools to run Startup Repair 3 separate times.

It must first attempt to repair the MBR and then rewrite it to Win7. It assumes each fix given will work until you return for another.

All bootrec and bootsect commands are now automated in Win7 Startup Repair, the exception being if no installation is found to repair. Bootrec/bootsect can then trigger discovery.

You say that you used Partition Wizard to restore the MBR. Which exact feature of PW did you use and how?
My System SpecsSystem Spec
27 Dec 2009   #19
Darsiant

Windows 7 ultimate x86
 
 

Quote   Quote: Originally Posted by DocBrown View Post
Which of the 3 Hd's did you install Win7 on ? What was the first OS on harddisk0 ?
Sorry I forgot to mention that. Windows 7 is installed on a partition that spans the entire 115 gb drive. Ubuntu was installed on the40gb disk before I wiped it. The 500gb is just for storage.
My System SpecsSystem Spec
27 Dec 2009   #20
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Quote   Quote: Originally Posted by Darsiant View Post
Quote   Quote: Originally Posted by DocBrown View Post
Which of the 3 Hd's did you install Win7 on ? What was the first OS on harddisk0 ?
Sorry I forgot to mention that. Windows 7 is installed on a partition that spans the entire 115 gb drive. Ubuntu was installed on the40gb disk before I wiped it. The 500gb is just for storage.

If the 115 is harddrive0, then you should do exactly as gregrocker says above.
My System SpecsSystem Spec
Reply

 Boot\bcd error, /fixboot dosent work




Thread Tools




Similar help and support threads
Thread Forum
Windows won't boot, startup won't work, safe mode dosent work
Today my laptop was working fine but then I shut it down and turned it on again, when I turned it back on, after the Starting Windows and windows logo disappear I get a blue screen for half a second then my computer try's to reboot, I've tried to use startup reapir but u just have a crusor with a...
General Discussion
Normal Boot on windows 7 does not work correctly, no error message.
Hey there folks. I've been using the EAH5570 for a few months now, it's an excellent card for the price. But one day, after reinstalling the latest ATI Drivers (completely uninstalling everything first and clearing out the GAC files because I had the issue in which Catalyst Control Center...
Graphic Cards
Fixboot in command prompt- not found??
Late Monday night my computer decided to present me with a black screen and one blinking cursor. The hard drive still works and runs but the computer will not boot past this black screen. I created a recovery disk and can run the command prompt there but no commands work: X:/Windows/System32/...
General Discussion
My High End Workstation dosent work when I install Windows 7 64bit
Hi, I have the following workstation configuration : PROCESSOR - Dual (two processors) - Xeon E5520 8M Cache, 2.26 GHz, 5.86 GT/s Intel® QPI MOTHERBOARD - Intel Workstation board S5520 SC GRAPHICS CARD - Palit Nvidia GeForce GTX 275 (986 MB) Dual DVI out
Hardware & Devices
Booting errors fixboot element not found etc
Before I start, I must warn you that all this was typed on my iPod touch. grammar and spelling may not be that good . My booting errors first occures after i tried to clone my hard drive numerous times. First I tried with windows tools and apps but to avail. Then I tried with Linux and no...
Hardware & Devices
WMC dosent show avi files
When i add library folder to video where my AVI files are it pulls up the avi files sub folder but shows zero contents in the folder when there is a avi file to be played in it. The files are playable in WMP thru sharks application but can not play in WMC I could plays avi files in vista media...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App