Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I keep losing my external drives

22 Jan 2010   #41
Greenfaldo

windows 7
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Forgot to ask, what format is the drive? FAT32 or NTFS?
One is a FAT32 and the other is NTFS


My System SpecsSystem Spec
.
22 Jan 2010   #42
Greenfaldo

windows 7
 
 

Quote   Quote: Originally Posted by Pauly View Post
I wouldnt rule out software problems totally, some drive manipulation software (imaging/partitioning etc) can cause problems like this

I have seen a few computers bsod or drives become non responsive or disappear because acronis for example was installed with usb and esata external HDDs connected, and after uninstalling everything returned to normal, its quite rare but can happen

This may well not be the case but do you have any software like this on your machine
I have started the computer in safe mode and tried it and it did do exactly the same thing.
My System SpecsSystem Spec
22 Jan 2010   #43
Greenfaldo

windows 7
 
 

One thing i have just thought of, is when i've tried to transfer something and it hasn't worked i get a funny noise come through the speakers and then i get a little box come up in the bottom right of the screen saying that a device has just been unplugged from the audio plug, something like that.
My System SpecsSystem Spec
.

22 Jan 2010   #44
Jonathan_King

Windows 7 Professional x64
 
 

Did you do an upgrade from Vista, or did you do a clean install?
My System SpecsSystem Spec
22 Jan 2010   #45
Greenfaldo

windows 7
 
 

We got the computer last sept time and we got the windows 7 upgrade a spart of the deal when we bought the computer and i'm not sure about a clean install.
My System SpecsSystem Spec
22 Jan 2010   #46
Jonathan_King

Windows 7 Professional x64
 
 

You may consider a clean install. Create a system image, first, in case it does not work.
My System SpecsSystem Spec
22 Jan 2010   #47
neoravenn

Windows 7
 
 
same problem

hi im also having the same problem..

my external WD HDD enclosure will work fine on my win 7 32bit RC laptop.. but the same problem with the poster with my brand new win 7 64bit RTM desktop...

after a few minutes.. i can still access the external HDD but when i open any folder, all files inside are gone.. but when i try it on my laptop i can see all the files missing..

OS: Clean Install Win 7 64 bit ultimate
Desktop specs: MOBO: foxconn destroyer.. i see we have the same chipset.. nvidia sumthing..
My System SpecsSystem Spec
22 Jan 2010   #48
computersplus

Windows 7 Ultimate 32 bit
 
 

My System SpecsSystem Spec
22 Jan 2010   #49
Greenfaldo

windows 7
 
 

Just tried it but after the link is sent toy your email address it does find the page when you click on it. I'll try again later, fingers crossed
My System SpecsSystem Spec
22 Jan 2010   #50
computersplus

Windows 7 Ultimate 32 bit
 
 

it sounds like the issue you are having it should fix the problem
My System SpecsSystem Spec
Reply

 I keep losing my external drives




Thread Tools




Similar help and support threads
Thread Forum
2 hard drives with different content - how to sync without losing info
I have thousands of photographs on 2 drives and always intended for the two drives to contain mirror copies but I'm a bit lax in applying myself so have ended up with "2011", "2012", "2013" and "2014" on both drives but there are photos on one drive that aren't on the other and vice versa. Short of...
General Discussion
All Flash Drives & External Hard Drives NOT ACCESSIBLE?
I set up a new computer. Windows 7 Pro 64x Everything was fine but then I connected a flash drive to it and I get: Location Not Available H:\ is not accessible. Access is denied If I go into the properties to the “security” tab, it says “you do not have permission to view or edit this...
Hardware & Devices
SATA drives : internal appear as External drives !
Hi very bizarre : - 3 of my 6 drives SATA connected to internal SATA connectors on board ( Z87 Deluxe) - are shown in explorer "my computer" as hard disks ( while correctly DVD and USB are in removable drives list) - however these 3 drives appear in the list of removable drives Under the W7...
Hardware & Devices
Losing drives when do backup??
Have a a Win 7x64 Pro system with 24GB memory Intel DX58SO2 CPU. The drive configurations are: C: 80GB SSD (Intel) which contains the OS D: Programs)/E: Data) WD 1T F: (Misc) WD 1T Attempt to backup to the F: drive, above, as well as an external 1T drive connected via USB2 to the computer....
General Discussion
Losing network drives
Hi, I'm hoping someone can help answer this. I have one user and her laptop is constantly losing connection to the server. When she loses connection to the server she can still access the internet but not the server or any of the mapped drives. She has to constantly reboot in order to get...
Network & Sharing
Windows 7 x64 losing network drives
I have a small home network with my main PC running Windows 7 x64 Pro, a network printer and a couple of other machines (Vista and XP). Connections are via a Gigabit switch to my router. I am deliberately not using a Win 7 Homegroup because my other machines are not running Win 7. All was...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App