dllhost.exe crash / com surrogate

Page 4 of 6 FirstFirst ... 23456 LastLast

  1. Posts : 445
    Vista Ult 64bit - Windows 7 Ult 7264 64bit
       #31

    This was a common error when Vista first became public release as well. Com Surrogate errors were common place with Vista until an update repaired it.
    The workaround in Vista was to use DEP.
    Control Panel - System - Advanced system settings, click "settings" in the performance box, then DEP tab. Put a check in the "Turn on DEP for all programs & services except those I select". Then click "Add" & navigate to the dlhost.exe and add it to the list. This stopped the errors in Vista and it may do the same here in W7 too.
    One other thing is that DEP may cause other programs to malfunction and you need to add their exe to the list as well if this happens.

    Good luck, I hope this works in W7.


    Dave

    NOTE - Once this is fixed, I believe it was graphics driver related..I'll have to go back to research the fix, but once this issue is resolved you HAVE to remember to return the DEP settings to default and remove any other program exe's you added to the list.
      My Computer


  2. Posts : 1
    Windows 7 build 7000(beta 1)
       #32

    Same issue.


    I'm having the same issue with Windows 7 Beta1(build 7000) x64. It started happening for me when I go to open a file in Photoshop. I get the dialog saying COM Surrogate has stoped working twice, and then the file opens with no issue. Really more of an annoyance, but would really like to make it go away. Unfortunately, the DEP fix doesn't work in x64.

    -Paul.
      My Computer


  3. Posts : 4
    windows 7 x64
       #33

    ans


    yes it did not work in win7 x64 based systems, and when i try to enter cpanel it problem occur, i wait for a fix from microsoft that this problem solve...
      My Computer


  4. Posts : 4
    windows 7
       #34

    Hi everybody i had the same problem and fixed it on this way. control panel won't start because 2 things in my case neroburnrights and adobeversioncue. i fixed it by simply removing icons from control panel. it's not complicated.
    1. if you have nero go to nero burnrghts folder (probably located in somewhere like this C:\Program Files (x86)\Nero\Nero 9\Nero BurnRights), then find NeroBurnRights_cpl.cpl and rename it to NeroBurnRights_cpl.nocpl or something like that
    2. if you have adobe collection go to probably same folder like me C:\Program Files (x86)\Common Files\Adobe\Adobe Version Cue CS4\Server\bin and rename VersionCueCS4.cpl to VersionCueCS4.nocpl

    that fixed my problem and i hope that will fix your also. if this doesn't help, maybe you have something else installed that integrates in cp. simply rename it's cpl.
    cheers:)
      My Computer


  5. Posts : 4
    windows 7 x64
       #35

    very very thanks... renaming VersionCueCS3.cpl to nocpl solve my problem.
      My Computer

  6.    #36

    Sure enough version cue for CS4. The file rename solves the problem. I am sure there will be a patch for it someday. Thanks for the hot tip.
      My Computer


  7. Posts : 4
    windows 7
       #37

    i'm very glad that it helped. if i may i would post also some problems that i experienced in windows 7. it's not the subject but maybe will someone read. :)
    i had problem installing ati drivers for 4800 card (maybe it's same problem for some oder model, i do not know that). the problem was that installing driver stopped on one part and didn't go further. well the sollution was in uninstalling old ati catalyst center and also deleting all ati drivers ( i used driversweeper Guru3D - Driver Sweeper (Setup) download from Guru3D.com after unninstalling with catalyst unninstaller) and ati's driver for windows 7 installed perfectly after that.
    2. thing i had problem with daemontools. unfortunatelly there's no daemon tools for windows 7 so i use alternative virtual clone drive SlySoft Download | AnyDVD, CloneDVD, CloneCD, GameJackal, Any DVD, Clone DVD, Clone CD, Game Jackal
    3. tweakvi dooes not work with windows7 unless it hasnt been previously installed in vista (if you go with the update). i hate arrow on shortcut icons so if you want to remove it go to registry (start-->run-->regedit) and delete isshortcut (i deleted all)
    4. if you want vista dreamscene on windows 7 there is a patch for it but i don't like icon font transparency (it isn't sam like in vista, it's very hard to read icon text). if you want it you can find it here
    http://www.ziddu.com/download/317595...Scene.exe.html
    5. if you want something for saving desktop icon position i recomend this
    MIDIOX (there is also a version for 64 bit os)
    6. switcher works on windows 7 as well Switcher for Windows Vista
    7. i do not know if i can post this, but if you didn't know there is an activation crack for windows 7 (x86 and x64 separatly) by orbit (pluspatcher). you can also remove watermark and send feedback. i would not paste link. you have to google it

    i'm sorry for so long post and this is not subject but maybe it will be useful for someone. cheers :)
      My Computer


  8. Posts : 2
    windows 7
       #38

    hepek said:
    Hi everybody i had the same problem and fixed it on this way. control panel won't start because 2 things in my case neroburnrights and adobeversioncue. i fixed it by simply removing icons from control panel. it's not complicated.
    1. if you have nero go to nero burnrghts folder (probably located in somewhere like this C:\Program Files (x86)\Nero\Nero 9\Nero BurnRights), then find NeroBurnRights_cpl.cpl and rename it to NeroBurnRights_cpl.nocpl or something like that
    2. if you have adobe collection go to probably same folder like me C:\Program Files (x86)\Common Files\Adobe\Adobe Version Cue CS4\Server\bin and rename VersionCueCS4.cpl to VersionCueCS4.nocpl

    that fixed my problem and i hope that will fix your also. if this doesn't help, maybe you have something else installed that integrates in cp. simply rename it's cpl.
    cheers:)
    ... man its works . very ty!!.
    Windows 7 is great and im loving it... i only wish punkbuster have an easy solution like this one... to work under Win7 ..
      My Computer


  9. Posts : 4
    windows 7
       #39

    merck said:
    ... man its works . very ty!!.
    Windows 7 is great and im loving it... i only wish punkbuster have an easy solution like this one... to work under Win7 ..
    i'm glad it helped. punkbuster you say . cod also have punkbuster and it works nice. try installing punkbuster in compatibility mode as administrator.
    one more thing. disable DEP -open cmd as administrator and paste this

    bcdedit.exe /set {current} nx AlwaysOff

    cheers :)
      My Computer


  10. Posts : 2
    windows 7
       #40

    hepek said:
    i'm glad it helped. punkbuster you say . cod also have punkbuster and it works nice. try installing punkbuster in compatibility mode as administrator.
    one more thing. disable DEP -open cmd as administrator and paste this

    bcdedit.exe /set {current} nx AlwaysOff

    cheers :)

    Acess denied when i try run the script...
    Anyway, i think thats only a problem of 64x OS...

    We have a forum here about PB.

    Cheers :)
      My Computer


 
Page 4 of 6 FirstFirst ... 23456 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:18.
Find Us