Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 hangs when USB 2.0 enabled.

09 Feb 2010   #1
skrave

Windows 7
 
 
Win7 hangs when USB 2.0 enabled.

I'm using a Gigabyte GA-M750SLI-DS4 motherboard and Windows 7 hangs if I have USB 1.1 + 2.0 enabled in the BIOS. It hung on the very first installation screen, and when I try to re-enable USB 1.1 + 2.0 in the BIOS it hangs on the loading screen. I can only get it to work properly with only USB 1.1 enabled in the BIOS. When I have 1.1 + 2.0 enabled, my keyboard and mouse both turn off while it hangs, and don't turn back on to continue loading at all. I've tried updating the BIOS and chipset drivers with no luck. Also tried moving the keyboard/mouse into different USB ports with no luck either. Also disabled USB storage detection. Any other ideas?

Using Windows 7 64 bit OEM.



My System SpecsSystem Spec
.
09 Feb 2010   #2
Ch@n

 

Remove all devices conn to USB, use a KB/Mouse with a PS/2 and then try.
My System SpecsSystem Spec
09 Feb 2010   #3
skrave

Windows 7
 
 

If that were to work, would that mean it's a motherboard issue or Win 7 issue? I didn't want to spend the cash to hook them up PS/2 because it worked fine with XP, but if it will help to pinpoint the problem I'll do it.
My System SpecsSystem Spec
.

09 Feb 2010   #4
skrave

Windows 7
 
 

If that were to work, would that mean it's a motherboard issue or Win 7 issue? I didn't want to spend the cash to hook them up PS/2 because it worked fine with XP, but if it will help to pinpoint the problem I'll do it.
My System SpecsSystem Spec
09 Feb 2010   #5
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

Try to reinstall the USB drivers see whether that works

Good Luck,
Captain
My System SpecsSystem Spec
10 Feb 2010   #6
Ch@n

 

Its all a trial and error method buddy. If you have a spare ps/2 one, then u can try. Or, u can update the drivers and check.
In BIOS, you dont have the option of only USB2.0?
My System SpecsSystem Spec
Reply

 Win7 hangs when USB 2.0 enabled.




Thread Tools




Similar help and support threads
Thread Forum
packets forwarded to win7 PC with routing enabled not delivered
Picture 1: - The routing table in a Win7 PC with IP Routing Enabled (The service “Routing and Remote Access” also started) - 192.168.201.162 is the IP of the Ethernet adapter LAN. - 192.168.32.150 is the IP of the PPP adapter VPN. Picture 2: - The Win7 PC can reach a wanted destination...
Network & Sharing
Install Win7 w/Legacy Oprom enabled for installation - then disable?
Hi I have a brand new Dell Inspiron 15 7548 series that I want to quad boot with 8.1 (as main OS; will be using the OEM OS it came with) , 7 Ultimate, 10 Tech preview and Fedora 21. Because I can ;) I have figured out that i CAN install windows 7 in UEFI / GPT mode, but the "legacy Oprom" needs...
Installation & Setup
Second SATA HD hangs win7
Hope the title is good enough :) Following Kari's excellent tutorial I successfully transferred my WIN 7 and Programs (they are on an OCZ SATA SSD) to a new motherboard and CPU. Until here no problem, the OS started perfectly, went online and activated my copy of Win7. Then I shut down and...
Hardware & Devices
Clean Win7 install error: ensure disk controllers is enabled
I have a Samsung series 9 (NP9004XC) and I am upgrading the 128gb SSD that came with the computer to a Crucial M4 256GB mSATA. I am doing a clean install from a bootable USB that I created from the recovery disc that was included with the computer. I can load up setup but once I get to the part...
Installation & Setup
win7 x64 needs devices disabled/enabled after reboot, why?
I've posted elsewhere, no answers, so I thought I would try here... I rebooted my Win7 x64 machine the other day. It acted funny after boot. Device manager shows about 10 usb devices and my ethernet motherboard nics (2 of them) as 'error 10, cannot start' If I disable and reenable each one...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App