Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Editing Special Permissions for file deletion.

14 Mar 2010   #1

Windows 7, Mac OS X
Editing Special Permissions for file deletion.

Alright, I made a big mistake and downloaded a file that I didn't know where it came from in hopes it would speed up my Adobe Photoshop CS4 that I have installed. Now problems have arisen and the file is undeletable. It has made the cracked "faster" version of Photoshop is able to be used in the entire master suite. All of the other files have lost their registration and won't start, or will crash on startup.

The Program is Adobe Cybershop CS4 from CyberWarez, do not download at all costs.

Here's what's happening, in addition to the above ->

1) Right click on Cyber Warez in Program Files (X86)
2) Delete
3) Folder Access Denied, you need permission from Computer-name\Administrator to make changes to this folder. Mind you I am logged into the hidden Administrator account and attempting to delete.


1) Right Click -> Properties
2) Security Tab
3) And I see My admin account, my 2 user accounts and a few others
4) Trusted Installer which is okay, SYSTEM which is okay, and CREATOR OWNER which is baffling to me as I've never seen this before.

Creative owner has only special privelages
TrustedInstaller has List folder contents and Special permissions
and SYSTEM has everything but Special Permissions

I go into the advanced tab go to the owner tab and change owner to Administrator I also select replace owner on subcontainers and objects.

Apply. It says I've taken ownership. Hit okay, close, reopen and I have everything including special permissions. I go ahead and delete... and BING, you require permission from Computer-name\Administrator to make changes to this folder. I'm at a loss and have no idea what to do. Does anybody have any suggestions? Any help would be fantastic as it is Finals week and my entire CS4 is down due to my stupidity. Thanks I greatly appreciate your time.

EDIT -> looked into subfolder and I do not have permission in those. Repeated above steps and I don't gain special permission.


My System SpecsSystem Spec
14 Mar 2010   #2

Windows 7, Mac OS X

Alright, new situation. Went through and deleted the files, from the bottom up and somehow that allowed me. However that did not uninstall that crap that I installed. Went to Control Panel and tried to uninstall except, the uninstall option did not show, as it did prior to deleting. It was uninstallable from the beginning. Any suggestions? Thanks, Appreciate your time.
My System SpecsSystem Spec
30 Aug 2010   #3

Windows 7 Home Premium 64bit
Command Prompt

I would simply suggest manually removing it through the command prompt. I'm guessing this is too late, but worth a try!
My System SpecsSystem Spec

30 Aug 2010   #4

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

No need to worry about permissions etc. If you just installed use a system restore to remove.

If for some reason this is not possible, give your self permsissions. If that cannot be done give yourself ownership first.
After all the permissions are given and you still cannot delete, use the hidden adminsitrator, in safe mode to do it for you.
Built-in Administrator Account - Enable or Disable[2]=User Accounts
My System SpecsSystem Spec

 Editing Special Permissions for file deletion.

Thread Tools

Similar help and support threads
Thread Forum
Need special permissions back!
I am a teacher, and my district suddenly made it so there are things I can no longer do, like add/delete programs, system restore, look at msconfig from "run" etc. I swear I'm not going to do anything bad to the computer!! But there are programs that are starting up every time i turn on my computer...
General Discussion
File Permissions Will Not Allow Deletion
Hello, When I plug my WD Passport into my laptop and try to delete a folder I get an error saying I need to provide administrator permission to delete this folder. I click continue but then I get "you require permission from administrator to make changes to this folder" and the only option...
System Security
Windows 7 Special Permissions
Hi, I'm trying to take full control of my laptop that I own personally. I've taken control of the C Drive and changed the permissions to full control but for some reason it won't allow me to tick the Special Permissions option. Can you please advise how I can get special permissions? ...
System Security
Permissions For File Deletion?
I have only user account in Win7 (which is an Admin account, named "Admin") now when I go to one of my backup drives (in this case "D:\") and attempt to delete certain directories it gives me "Folder Access Denied - You Require permission from TrustedInstaller to make changes to this folder" ...
General Discussion
User account only has (Special permissions) checked.
User account only has (Special permissions) checked and I can't get it to change. I have activated the Admin account and I have gone into the admin account and tried to change the account permissions their and it shows that it does them. But when I try to run Avira or AVG it says that it can't...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App