Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: missing mfc80u.dll and comctl32.dll

07 Apr 2010   #1

Windows 7
missing mfc80u.dll and comctl32.dll

Windows 7 Pro 32 bit (virtual on a VMware ESXi host)

Hi, ESET NOD32 have erased mfc80u.dll and comctl32.dll from c:\windows\winsxs\folder

Itīs not possible to restore from quarantain or use system restore points.

How can i restore those files to each folder? I dont have permissions to restore files to folders in \winsxs.

VMware tools does not run and i had to reinstall NOD32.

regard nisse

My System SpecsSystem Spec
07 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X

I would suggest either a System Restore or a Repair Install.
My System SpecsSystem Spec
07 Apr 2010   #3

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard

Hi and welcome to the forums , have you tried running a repair install from your Windows 7 install disk?
This should fix the problem.


Edit: You beat me to it notsograymatter; you know what they say though great minds think alike, also he said he couldn't do a system restore.
My System SpecsSystem Spec

07 Apr 2010   #4

Windows 7


No, I havnīt tried a repair install, i hoped there should be an easier way...

Nce foruim, i will follow this forum for sure!
My System SpecsSystem Spec

 missing mfc80u.dll and comctl32.dll

Thread Tools

Similar help and support threads
Thread Forum
COMCTL32.OCX missing
I am trying to run an application (FS Flight Calculator) and it gives me this error message "Component 'COMCTL32.OCX' or one of its dependencies not correctly registered: a file is missing or invalid I have Win7 Ult 64b, I searched my OS HD and this file is not on the HD. In Windows\Sys32 I...
General Discussion
"Componet 'comctl32.ocx' not correctly registered
So I'm trying to run an application called Advance Text. It's used to edit the text in a ROM. Every time I try to run it an error message pops up, saying what is in the title- that comctl32.ocx or one of it's dependencies is not correctly registered. After a Google search, I entered "regsvr32...
COMCTL32.dll is missing
Hello, I can't run my computer. When I swich on computer i can see table : The program can't start because COMCTL32.dll is missing from your computer. try re-installing the program to fix this problem. how can I do this if my computer computer screen is black. I can just press enter then table...
General Discussion
comctl32.dll missing error
Hello. Just joined to get help on my PC. On logging in and opening programs, I get this message, screenshot in attachments. I tried doing a system restore but it doesn't show a restore point before the error began, and yes I did click "Show More Restore Points". I did a SFC Scan...
General Discussion
Application error explorer.exe caused by comctl32.dll (id 1000)
I can reproduce it randomly, when I try to copy and paste files in some folder. This is a Windows 7 x64 Ultimate restored with a repair install Copying and pasting a new comctl32.dll from my Windows 7 disk in the path indicated below doesn't help to solve this issue. My sfc /verifyonly didn't...
BSOD Help and Support
ComCtl32.ocx error with VB6 application
Hai, I have a vb6 application which uses ComCtl32.ocx, when I run this application in a normal user previlages in Windows 7, there is no issues, But I am getting following error when I tried to run as administrator. "Component 'Comctl32.ocx' or one of its dependencies not correctly...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 18:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App