Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Random BSOD

15 Apr 2010   #1

Windows 7 Enterprise 64-bit
Random BSOD


I'm having random Blue screens when I play games, it usually happends when I play GTA 4. It also happends when I leave the computer on for downloading at night.

I have absolutely no idea how to fix this. The error codes are random; in the most cases it's IRQL_NOT_LESS_OR_EQUAL, sometimes it's SYSTEM_SERVICE_EXCEPTION. I'm using Windows 7 64 bit right now but it happened with XP as well.

All drivers are up to date.

I put my videocard in another computer to see if it was a videocard problem, but that PC was fine. I have also bought another processor but the problem is still there. (Bought it for more speed)

PC temperatures are ok, processor never gets higher than 60 C and the videocard only gets to 70-80. (When playing a game).

By the way, sometimes the blue screens points out to "dxgmms1.sys" or something. But this does not always happen. Any thoughts on that file?

Any suggestions or help is greatly appreciated.

Thanks in advance,


PSU: 500 watt
Motherboard: Asus M3N-HD HDMI
Processor: AMD Phenom II X4 940
Videocard: ASUS EN9800 GT
Soundcard: USB speakers
Memory: Kingston 4x1 gig DDR2 800
HDD: Samsung 1x320 GB (SATA)

My System SpecsSystem Spec
15 Apr 2010   #2
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit

Hello !! Welcome to SF !!

Please post us the Dump files to analysis

- Captain
My System SpecsSystem Spec
15 Apr 2010   #3

Windows 7 Enterprise 64-bit

Hello and thanks for the welcome and the fast reply.

Here is the crashdump. I only have one, I think this one happened 2 days ago. Other ones are probably deleted by cleanup program.

My System SpecsSystem Spec

15 Apr 2010   #4
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit

Quote   Quote: Originally Posted by justin91 View Post
Hello and thanks for the welcome and the fast reply.

Here is the crashdump. I only have one, I think this one happened 2 days ago. Other ones are probably deleted by cleanup program.

Hello Justin !!

The Dump is pointing to some Windows Core files but it didn't find the exact driver. so please follow these steps

Run the Memory Diagnostic & HD Diagnostic

Also i would recommend to run System Integrity Checker
Start > Run > CMD >Right Click and Run as administrator > SFC/ SCANNOW
ASACPI.sys driver is from Asus its a utility which is well known problems. I'm attaching the file so download it and update it


Uninstall all the Asus Utilities Like PC Probe etc. then see whether it makes any diference

After doing so if it didn't resolved the we need to run the Driver Verifier !! Using Driver Verifier to identify issues with Drivers but please follow the other steps before you do so.

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: fffff80806aff8f8, memory referenced
Arg2: 000000000000000c, IRQL
Arg3: 0000000000000000, bitfield :
 bit 0 : value 0 = read operation, 1 = write operation
 bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800068d7115, address which referenced memory
Debugging Details:
READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80006aff0e0
fffff800`068d7115 4d8b9cf600892a00 mov     r11,qword ptr [r14+rsi*8+2A8900h]
PROCESS_NAME:  dwm.exe
TRAP_FRAME:  fffff88003516610 -- (.trap 0xfffff88003516610)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=00000000ffffffff rbx=0000000000000000 rcx=0000000000000019
rdx=f80006a3dc180c05 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800068d7115 rsp=fffff880035167a0 rbp=0000000000000000
 r8=0000000000000019  r9=0000000000000000 r10=0000000004000000
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff800`068d7115 4d8b9cf600892a00 mov     r11,qword ptr [r14+rsi*8+2A8900h] ds:00000000`002a8900=????????????????
Resetting default scope
LAST_CONTROL_TRANSFER:  from fffff800068c8469 to fffff800068c8f00
fffff880`035164c8 fffff800`068c8469 : 00000000`0000000a fffff808`06aff8f8 00000000`0000000c 00000000`00000000 : nt!KeBugCheckEx
fffff880`035164d0 fffff800`068c70e0 : 00000000`00000007 fffff880`009e5180 00000000`00000000 fffffa80`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`03516610 fffff800`068d7115 : 00000000`00000000 00000000`00001000 00000000`00040001 00000000`0000000d : nt!KiPageFault+0x260
fffff880`035167a0 fffff800`068d6dca : 00000000`00000000 00000000`00000000 00000000`00000000 fffff781`c0000488 : nt!KiIpiSendRequest+0x1d5
fffff880`03516860 fffff800`068dcc8b : 00000000`00005409 00000000`00000001 00000000`00000002 00000000`00005404 : nt!KeFlushMultipleRangeTb+0x22a
fffff880`03516930 fffff800`06949a0e : fffffa80`0566c3f8 fffff880`00000001 00000000`00000001 fffff880`03516bb0 : nt!MiAgeWorkingSet+0x36b
fffff880`03516ae0 fffff800`068dd6e2 : 00000000`000011fa 00000000`00000000 fffffa80`00000000 00000000`00000002 : nt! ?? ::FNODOBFM::`string'+0x49926
fffff880`03516b80 fffff800`068dd96f : 00000000`00000008 fffff880`03516c10 00000000`00000001 fffffa80`00000000 : nt!MmWorkingSetManager+0x6e
fffff880`03516bd0 fffff800`06b6c166 : fffffa80`036f8040 00000000`00000080 fffffa80`036d39e0 00000000`00000001 : nt!KeBalanceSetManager+0x1c3
fffff880`03516d40 fffff800`068a7486 : fffff880`03163180 fffffa80`036f8040 fffff880`0316dfc0 a5acc55a`5ae78535 : nt!PspSystemThreadStartup+0x5a
fffff880`03516d80 00000000`00000000 : fffff880`03517000 fffff880`03511000 fffff880`03516820 00000000`00000000 : nt!KxStartSystemThread+0x16
fffff800`068d7115 4d8b9cf600892a00 mov     r11,qword ptr [r14+rsi*8+2A8900h]
SYMBOL_NAME:  nt!KiIpiSendRequest+1d5
FOLLOWUP_NAME:  MachineOwner
IMAGE_NAME:  ntkrnlmp.exe
FAILURE_BUCKET_ID:  X64_0xA_nt!KiIpiSendRequest+1d5
BUCKET_ID:  X64_0xA_nt!KiIpiSendRequest+1d5
Hope this helps,
My System SpecsSystem Spec
15 Apr 2010   #5

Windows 7 Enterprise 64-bit

Hello again,

I ran the tests using diskettes. Both memory and HDD tests finished with 0 errors.
I've also installed the ASUS thing. I have no other ASUS software on my computer (asusprobe).
The CMD command returned with the message that everything is fine.

By the way, some while ago I used some driver checking utility built into Windows (not sure it's the same thing you posted) and it immediately threw a BSOD at me. I think it was my videocard driver. I tried the driver check on a different computer and again a BSOD while it has another videocard (both same drivers though).
The other PC had a 6800 I think and I have a 9800 GT.
This was with the Windows 7 RC (64 bit).

So, since the memory and HDD tests succeeded, should I proceed with the driver verifier?
My System SpecsSystem Spec
15 Apr 2010   #6

Windows 7 Enterprise 64-bit


Played GTA 4 5 minutes ago and got another Blue Screen. This time without a error code (like IRQL_NOT_LESS_OR_EQUAL).

Maybe this recent dump has some other useful information? I don't know how old the other one was.

Thanks for the help,

My System SpecsSystem Spec
15 Apr 2010   #7
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit

Hello Justin !!

Did you download the MemTest86+ and run upto 6 passes ?? Because the Mem Test in Windows is no longer recommended. Once you run the MemTest86+ and complete 6 passes without any errors then you can proced with Driver Verifier !!
My System SpecsSystem Spec
15 Apr 2010   #8

Windows 7 Enterprise 64-bit


I used memtest86+ with my diskette drive. I only let it do 1 pass, but I'll do 6 the next time.

I'll turn memtest on again tonight when I go to bed and tell you the results tommorow.

My System SpecsSystem Spec
16 Apr 2010   #9

Windows 7 Enterprise 64-bit

Back again,

Tested the memory again, with all 4 sticks in it gave 14 errors in just 1 minute.

I took 2 out and the test ran fine for 14 passes with no errors.

Then I put the other 2 in and again no errors.

I only have errors when I have all 4 sticks in the computer.

Btw: 1 of the 4 sticks hasnt got chips on both sides. Just 1. Also, I can't use this stick to run the pc in Dual-Channel mode. Theyre all kingston ddr2 800 though. I think I'll replace the stick anyway to get Dual-Channel mode (for my pc its called ganged or unganged mode).

I think the memory sticks dont like the fourth one. I remember buying it but I asked for exactly the same memory as I bought before. Maybe Kingston makes it differently now?

Looking forward to your reply,

My System SpecsSystem Spec
16 Apr 2010   #10

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

Are you doing any overclocking of CPU or memory ? Yes it sounds like 1 memory stick is mis-matched !
My System SpecsSystem Spec

 Random BSOD

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD problems in the past 2 days. Random errors at random times
Three days ago my water cooling failed (got up to 77C while gaming is when I noticed the problem as my CPU should not go over 62C). I decided to install an aftermarket heatsink instead of a new water cooling system ,and add a few more fans just to make sure my whole motherboard was getting plenty...
BSOD Help and Support
BSOD at seemingly random times, memory dump blaming random drivers
I've been plagued by odd problems since making this custom build about a month ago, but the latest is the increasing frequency of BSODs. They never occur at load (gaming with high end specs), but often occur at shutdown (forcing a restart before I can then actually shut down). I normally boot into...
BSOD Help and Support
Random BSOD at random moments on Toshiba L500 laptop; graphics card?
My GF has had a Toshiba L500 laptop for 4 years now. It's a great model and it worked well...till now. It started about two weeks ago, with 1 blue screen every 1-2 days. I haven't reinstalled her windows for about a year, so i figured that was the problem. Four days ago it started blue...
BSOD Help and Support
Random BSOD with random error code at random moment
Hello Ok now i'm out of solution so i come here hoping that someone could help me I always had bsod hapening randomly but not like the this week I got 2 bsod/day when i'm playing, when i'm staring at my monitor or even when i'm sleeping with random error code like 0x1e, 0x24, 0x3b, 0x4a or 0xa...
BSOD Help and Support
BSOD doing random things (Google Chrome, minecraft, random times)
I have finally had it up to here with the BSODs, so I really need help. I ran a windows memtest and it detected no errors. I just finished updating to SP1 with pretty much most updates too. The BSODs I get the most are: Driver IRQL not less or Equal System Service Exception and these two I...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:19.
Twitter Facebook Google+