Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Enabled in Bios - Win 7 Won't Start

15 Apr 2010   #1

Windows 7
USB Enabled in Bios - Win 7 Won't Start

I had WindowsXP SP3 installed on this home made desktop and everything worked fine. I formatted the drive to install Windows 7 Home Premium.

1-I had issues installing, it kept getting stuck after the install at the "Starting Windows" screen so I disabled USB in the bios.

-Now everything works great but when I re-enable USB it freezes in the same place.

-Taken out RAM and tried different sticks.
-Tried disabling the floppy and other drives
-Updated the bios

Any other ideas?

ABit KX7-333 Motherboard

AMD Athlon XP 2000+ @ 1.67 Ghz (I actually think that this is an XP 2300 or 2600 chip, that the motherboard is just running like a XP 2000+ chip)

All-In-Wonder 9600 TV Tuner
and Graphics Card

1.75 GB PC 2700 RAM (4-DIMMs)
Plextor DVDr Drive
Linksys Internal Gigabit Ethernet
60GB Primary Hard Drive
250GB Secondary Hard Drive
3.5” Floppy Drive

My System SpecsSystem Spec
15 Apr 2010   #2
Microsoft MVP


The motherboard isn't listed at the Windows compatibility site: Windows 7 Compatibility: Software Programs and Hardware Devices: Find Updates, Drivers, and Downloads

You might try this driver:
And install it using compatibility mode for Windows XP according to these directions:
Compatibilty Mode Driver Installation:
1 - Download the latest driver from the manufacturer's website.
2 - Uninstall the current drivers using the Control Panel...Programs and features...Uninstall a program applet. Then verify that the driver/device has been removed in Device Manager
3 - Right click on freshly downloaded driver installation file and select "Properties"
4 - Select the Compatibility tab - and do the following:
- Click on the "Change settings for all users" button
- Click on the box to select "Run this program in compatibility mode for" and then select Windows Vista Service Pack 1
- Click on the box to select "Run as administrator"
- Click on OK to exit all the dialogs
5 - Right click on the driver installation file and select "Run as administrator"
6 - Let it install and see if that stops the BSOD's.
Also, here's an article on adding legacy devices to Win7: Configure Legacy Devices to Run on Windows 7
If it doesn't work, you'll either have to avoid using the USB, or get a new motherboard.
My System SpecsSystem Spec
15 Apr 2010   #3

Windows 7 x64 Ultimate

In the BIOS: Try specifically denying USB devices from being bootable (remove them from the boot list) Or make sure that the boot order is after your main harddrive...
My System SpecsSystem Spec

16 Apr 2010   #4


Ensure Plug and Play OS is set to yes in the bios.
My System SpecsSystem Spec
16 Apr 2010   #5

Windows 7

Plug n Play is Enabled.

USB is not selected as a boot option.

I tried to install the new drivers listed but... it says it copies over the files then I have to reboot to finish the install. The computer reboots and the install doesn't start back up. If I double click it again it just does the same thing.

Any other ideas? This is getting silly.
My System SpecsSystem Spec
16 Apr 2010   #6
Microsoft MVP


If the drivers don't install, and the board isn't listed as Win7 compatible - then it would seem to me that the solution is to purchase a Win7 compatible mobo.
My System SpecsSystem Spec
16 Apr 2010   #7

Windows 7

I don't like that answer ;-)

I might have to though... but it did pass the compatibility test so I figured I was good.
My System SpecsSystem Spec
16 Apr 2010   #8


Use the device manager to manually install the driver Usasma pointed to.

Extract the driver's contents to a folder.

Then open device manager. Go to the usb controller adapter and right click it. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now find and double click on the .inf in the extracted folder. Hit ok. Hit next and let it install.
My System SpecsSystem Spec
29 May 2010   #9

windows 7

hi guys....i am having similiar problem with my sony vaio i just remember i install windows 7 from a usb flash drive now i was doin some work on my comp and it seems like i uninstall something which corrupt some driver file in the comp so i try to do a reinstall of the OS using my flash drive and i couldnt do as i wasnt seeing my usb in the bios so i did the install from a dvd........but now i want to do a reinstall again from my usb flash drive and i,m still not seein my usb in the bios........can someone help with this problem??

thanks in advance
My System SpecsSystem Spec

 USB Enabled in Bios - Win 7 Won't Start

Thread Tools

Similar help and support threads
Thread Forum
Enabled CPU Virtualization in BIOS, Still Can't Virtualize
See my signature for system specs. I enabled virtualization in my BIOS so I could install lubuntu in a virtual box and I still get the 'hey, slow down now,' "this kernel requires a x86 or x64 cpu but only detected an i686 cpu. Unable to boot. Please use a kernel appropriate for your CPU" error. ...
Windows won't get past Start Up screen with Nvidia drivers enabled.
This started about a month ago when a system restore completely mucked up my computer. I've managed to fix most of the problems (NoelDP is a wizard) but I can't get past the start up screen with the Nvidia drivers enabled. I think I managed to get past it once after a clean install but then I kept...
Graphic Cards
New vid card, no sound. BIOS enabled, drivers updated, device active..
I know, hate to be that guy bringing up a topic people have been complaining of for years. But trust me, I would not be posting this if I had not spent the last 48 hours with 80 tabs open as I simultaneously browse a dozen forums while ripping my hair out... Anyway, I have a brand new out of box...
Sound & Audio
hiberation not in start menu (but it IS ENABLED)
After some recent updates and/or software installs, at some point the "hiberation" option no longer appeared in my start menu shutdown options. I searched the web and found many posts suggest that the fix is simple -- all I have to do is enable hiberation via one of two ways - run "powercfg -h...
Performance & Maintenance
HD not recognized at all if AHCI enabled in bios - please help -
Hi, I got a weird thing going on and have NO clue whats the cause. I want to install win7 on a clean drive.... but I cant even get to the install options, because the drive is not recognized when i turn on the machine. It stalls, even before I can get into the BIOS settings. I need to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App