Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD in windows 7

20 Apr 2010   #1

Windows 7
BSOD in windows 7

Hello all,
I am new here :)
Sorry for my english..

I had a bluescreen 3-4 times, and I downloaded the "WinDbg" from microsoft.
The analyze showed the problem is in "NETIO.SYS".

What should I do?
Will uploading the minidump file will help?

My System SpecsSystem Spec
20 Apr 2010   #2

MS Windows 7 Ultimate SP1 64-bit

Could you zip up the minidump file and attach it to your next post?

There are some experts here at diagnosing the dump files.

My System SpecsSystem Spec
21 Apr 2010   #3

Windows 7

Sure, Thanks for the quick comment.
And I have another question.
I have a folder named "windows.old" in "C" , I dont need it, because it was an older version of W7, so can I delet it?
My System SpecsSystem Spec

21 Apr 2010   #4

Windows 7 Professional x64

Welcome MaoR!

First, the Windows.old folder can be deleted. There is a trick to it, however. You can't just send it to the recycle bin. See this tutorial: Windows.old Folder - Delete

Now, for the BSOD. It looks like your network driver Rt86win7.sys is causing the issue. I recommend updating your network drivers in Device Manager.

I also believe AVG might have something to do with it. Uninstall AVG completely, and install Microsoft Security Essentials instead.

Be sure to run AVG's removal tool after uninstalling AVG from Programs and Features:

Let us know how it works out.

Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Jonathan\Desktop\042010-22074-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.x86fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0x82c49000 PsLoadedModuleList = 0x82d91810
Debug session time: Tue Apr 20 14:10:44.934 2010 (GMT-4)
System Uptime: 0 days 0:17:57.416
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {0, 2, 0, 8c6ebea1}

Unable to load image \SystemRoot\system32\DRIVERS\avgfwd6x.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for avgfwd6x.sys
*** ERROR: Module load completed but symbols could not be loaded for avgfwd6x.sys
Unable to load image \SystemRoot\system32\DRIVERS\Rt86win7.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for Rt86win7.sys
*** ERROR: Module load completed but symbols could not be loaded for Rt86win7.sys
Probably caused by : NETIO.SYS ( NETIO!NetioCompleteNetBufferAndNetBufferListChain+35 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 00000000, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: 8c6ebea1, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from 82db1718
Unable to read MiSystemVaType memory at 82d91160


8c6ebea1 8b08            mov     ecx,dword ptr [eax]





TRAP_FRAME:  a89e970c -- (.trap 0xffffffffa89e970c)
ErrCode = 00000000
eax=00000000 ebx=00000000 ecx=00000003 edx=00000002 esi=860b8c70 edi=00000060
eip=8c6ebea1 esp=a89e9780 ebp=a89e978c iopl=0         nv up ei pl nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010206
8c6ebea1 8b08            mov     ecx,dword ptr [eax]  ds:0023:00000000=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 8c6ebea1 to 82c8f7eb

a89e970c 8c6ebea1 badb0d00 00000002 8c8ead98 nt!KiTrap0E+0x2cf
a89e978c 8c6eab48 860b8bd0 00000001 00000000 NETIO!NetioCompleteNetBufferAndNetBufferListChain+0x35
a89e97ac 921ddcd4 860b8bd0 00000000 00000000 NETIO!NetioDereferenceNetBufferList+0xa2
a89e97ec 8c6968a6 0cabb1e4 00000000 860b8bd0 wanarp!WanNdisSendComplete+0xe8
a89e9838 8c6325e2 00000000 860b8bd0 00000000 ndis!ndisMSendCompleteNetBufferListsInternal+0x217
a89e984c 92199848 8738e928 860b8bd0 00000000 ndis!NdisFSendNetBufferListsComplete+0x3a
a89e9870 8c6325e2 87392de0 00000000 00000000 pacer!PcFilterSendNetBufferListsComplete+0xb4
a89e9884 9209c56a 87392558 860b8bd0 00000000 ndis!NdisFSendNetBufferListsComplete+0x3a
WARNING: Stack unwind information not available. Following frames may be wrong.
a89e98a8 8c697fe9 87392008 860b8bd0 00000000 avgfwd6x+0x156a
a89e98c8 8c698e86 86f780e0 8649ea04 00000000 ndis!ndisMSendCompletePacketToNetBufferLists+0x77
a89e98ec 92b607d7 02f780e0 8649ea04 00000000 ndis!ndisMSendCompleteX+0x248
a89e9908 92b5d045 873906c8 881aa548 8649ea04 ndiswan!CompleteNdisPacket+0xda
a89e9930 92b5d25b 881aa548 00000000 88347064 ndiswan!CompleteSendDesc+0x134
a89e994c 8c65e01c 00000000 00000001 86adb920 ndiswan!ProtoCoSendComplete+0xb1
a89e9970 8c6bd942 00000000 8856d128 88347064 ndis!ndisMCoSendCompleteToNdisPacket+0x210
a89e9984 92b3186c 00000000 8856d128 88347064 ndis!NdisMCoSendComplete+0x15
a89e99a8 92b3363d 87383cbc 87ed0ea8 88347064 rasl2tp!SendPayloadUnseqComplete+0xb3
a89e99cc 92b36b12 87383cbc 87ed0ea8 88347064 rasl2tp!L2tpSendComplete+0xa3
a89e99f4 82cb1b33 00000000 8622f270 86b96280 rasl2tp!WskSendCompletion+0x28
a89e9a38 9213f3e4 8622f270 860def00 a89e9a64 nt!IopfCompleteRequest+0x128
a89e9a48 92172290 8622f270 00000000 00000084 afd!WskProTLSendToComplete+0x65
a89e9a64 82cb1b33 00000000 860def00 8622f270 afd!WskTdiCOMPSendTo+0x41
a89e9aa8 920b0096 86244018 86244120 00000000 nt!IopfCompleteRequest+0x128
a89e9ac0 8c87530d 00000084 00000000 00000084 tdx!TdxMessageTlRequestComplete+0x94
a89e9ae4 8c875359 86244120 86244018 00000001 tcpip!UdpEndSendMessages+0xfa
a89e9afc 8c6e669a 86244018 00000001 00000001 tcpip!UdpSendMessagesDatagramsComplete+0x22
a89e9b2c 8c86a19f 00000000 00000001 00000000 NETIO!NetioDereferenceNetBufferListChain+0xea
a89e9b40 8c6968a6 872df008 86244018 00000001 tcpip!FlSendNetBufferListChainComplete+0x7b
a89e9b8c 8c6325e2 00000000 86244018 00000001 ndis!ndisMSendCompleteNetBufferListsInternal+0x217
a89e9ba0 92199848 872dde00 86244018 00000001 ndis!NdisFSendNetBufferListsComplete+0x3a
a89e9bc4 8c6325e2 872dda10 86244018 00000001 pacer!PcFilterSendNetBufferListsComplete+0xb4
a89e9bd8 9209c56a 872e0d68 86244018 00000001 ndis!NdisFSendNetBufferListsComplete+0x3a
a89e9bfc 8c696f0a 872e1008 86244018 00000001 avgfwd6x+0x156a
a89e9c20 92a9a339 86e5c0e0 86244018 00000001 ndis!NdisMSendNetBufferListsComplete+0xa4
a89e9c50 92a8bdcf 0003f000 00000001 86e5c0e0 Rt86win7+0x11339
a89e9c74 8c684309 8703f001 00000000 019e9ca0 Rt86win7+0x2dcf
a89e9cb0 8c6656b2 872dbc4c 002dbc38 00000000 ndis!ndisMiniportDpc+0xe2
a89e9d10 8c64c976 872dbd38 00000000 86deb3a8 ndis!ndisQueuedMiniportDpcWorkItem+0xd0
a89e9d50 82e5766d 00000001 9d5e46d8 00000000 ndis!ndisReceiveWorkerThread+0xeb
a89e9d90 82d090d9 8c64c88b 00000001 00000000 nt!PspSystemThreadStartup+0x9e
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


8c6ebea1 8b08            mov     ecx,dword ptr [eax]


SYMBOL_NAME:  NETIO!NetioCompleteNetBufferAndNetBufferListChain+35

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  0xD1_NETIO!NetioCompleteNetBufferAndNetBufferListChain+35

BUCKET_ID:  0xD1_NETIO!NetioCompleteNetBufferAndNetBufferListChain+35

Followup: MachineOwner
My System SpecsSystem Spec
21 Apr 2010   #5

win7 ultimate / virtual box

Quote   Quote: Originally Posted by MaoR View Post
Sure, Thanks for the quick comment.
And I have another question.
I have a folder named "windows.old" in "C" , I dont need it, because it was an older version of W7, so can I delet it?
yes go here for instructions :)
My System SpecsSystem Spec
21 Apr 2010   #6

Windows 7

wow, thanks for the quick comments.
Jonathan, I tried to update my network driver from the device manager, and it said I have the last version.
about AVG, are you sure? because I love this anti-virus.. and will Microsoft security essentials will give me a full protection as the AVG gave me?

Thanks :)
My System SpecsSystem Spec
21 Apr 2010   #7

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86


1) Try updating your network driver. Seems you have Realtek ones. Go to their website and download the latest.

2) Are you using AVG? Try switching to MSE or another AV of your choice.
My System SpecsSystem Spec
21 Apr 2010   #8

Windows 7 Professional x64

Yes, Microsoft Security Essentials will actually give you better protection than AVG.
My System SpecsSystem Spec
21 Apr 2010   #9

Windows 7

You gave me an AVG removal tool for X64 system, I have an X86, can you give me a link for downloading it?
Because I cant find it..

Thank you.
My System SpecsSystem Spec
21 Apr 2010   #10

Windows 7 Professional x64

My System SpecsSystem Spec

 BSOD in windows 7

Thread Tools

Similar help and support threads
Thread Forum
BSOD BlueScreen Windows 7x64 Error BSOD 0000000000041790
Necesito ayuda con este problema, muchas gracias.
BSOD Help and Support
BSOD on Windows Update; BSOD when playing games
NOTE: DM log collector seem to be getting stuck when collecting msinfo32.nfo, so the attached file can be incomplete. Please let me know if it can take longer than 10 minutes to collect this data so i will run the program again. BSOD #1: It started at around January 15th - basically when i shoot...
BSOD Help and Support
BSOD using FULL windows 7, no BSOD using safe mode
My computer has been stable for years, however recently I have been getting BSOD when doing any task. Windows will sometimes load to the desktop and I am able to watch video, run windows score, check email, etc before it will BSOD. Other times, it will BSOD before getting to the windows login...
BSOD Help and Support
lots of BSOD - Format, Clean windows install - Still same BSOD
Hi, I use a 1.5 year old aces aspire 5738z and I think it just died on me. Here is what happens. Whatever I do it cannot stay without a BSOD for more than 10 minutes. I tried reinstalling drivers and it did not change anything so I tried several things but finally just formated it and installed...
BSOD Help and Support
BSOD Starting Windows Virtual PC Machines (any machine, always bsod)
Hello All, I've been getting consistent BSODs while trying to start Windows Virtual PC (not Microsoft Virtual PC 2007) machines on my computer. I've tried various driver updates and a bios update and several system restores along the way, but to no avail. In the attached dump files, the last...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App