Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Blue Screen c000021a(Fatal System Error)

23 Apr 2010   #1
SD1645

Windows 7 64-Bit
 
 
Blue Screen c000021a(Fatal System Error)

Hello Everyone,

I have a Dell XPS Studio 1645 i7 Q 720 @ 1.60GHz, 1597 Mhz, 4 Core(s), 8 Logical Processor(s)
4 GB DDR3 RAM
BIOS: Dell Inc. A08, 3/12/2010
Windows 7 64-bit 6.1.7600 Build 7600
GPU: ATI HD 4670 1GB RAM

I am using a 90W adapter fyi and games seem to run fine once windows boots.

So my problem is,

I get a Blue screen a few times when I reboot my system. But then it just goes away on restart. Sometimes I have to restart multiple times for it to windows to start up.

The blue screen occurs at the Windows is loading page right after the windows come together. I have no idea why this error occurs, I got so frustrated with it that I called Dell and the technician came and replaced my motherboard and hardrive. But this error still occurs. ANY help would be greatly appreciated..I have absolutely no idea what drivers/software would cause this to occur. I am attaching the log files for the error and the dump file too (The dump file is zipped since i can't attach .dmp) .

As I said before any kind of help resolving this would be much appreciated. If someone could pinpoint which application/hardware/software in specific is causing this I will be SO GRATEFUL!

PS:- I don't have any Antivirus either (since I read about AVG making this happen)

Thanks,
SD


My System SpecsSystem Spec
.
23 Apr 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by SD1645 View Post
Hello Everyone,

I have a Dell XPS Studio 1645 i7 Q 720 @ 1.60GHz, 1597 Mhz, 4 Core(s), 8 Logical Processor(s)
4 GB DDR3 RAM
BIOS: Dell Inc. A08, 3/12/2010
Windows 7 64-bit 6.1.7600 Build 7600
GPU: ATI HD 4670 1GB RAM

I am using a 90W adapter fyi and games seem to run fine once windows boots.

So my problem is,

I get a Blue screen a few times when I reboot my system. But then it just goes away on restart. Sometimes I have to restart multiple times for it to windows to start up.

The blue screen occurs at the Windows is loading page right after the windows come together. I have no idea why this error occurs, I got so frustrated with it that I called Dell and the technician came and replaced my motherboard and hardrive. But this error still occurs. ANY help would be greatly appreciated..I have absolutely no idea what drivers/software would cause this to occur. I am attaching the log files for the error and the dump file too (The dump file is zipped since i can't attach .dmp) .

As I said before any kind of help resolving this would be much appreciated. If someone could pinpoint which application/hardware/software in specific is causing this I will be SO GRATEFUL!

PS:- I don't have any Antivirus either (since I read about AVG making this happen)

Thanks,
SD
This crash was probably caused by smss.exe. That file is normally a prt of the win 7 SO when located in c:\windows|system32, but if located anywhere else it has been known to be a virus.

I would run a systemf ile check to repair your OS files
type cmd in search>right click and run as admin>sfc /scannow

I would also download Microsoft security essentials and run a scan to be sure.

Let us know if you need help

Ken
Code:
Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\K\Desktop\042310-35240-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*F:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16539.amd64fre.win7_gdr.100226-1909
Machine Name:
Kernel base = 0xfffff800`02860000 PsLoadedModuleList = 0xfffff800`02a9de50
Debug session time: Fri Apr 23 15:04:22.918 2010 (GMT-4)
System Uptime: 0 days 0:00:23.074
Loading Kernel Symbols
...............................................................
................................................................
.
Loading User Symbols
Loading unloaded module list
...
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck C000021A, {fffff8a00012ac00, 0, ffffffffc0000001, 100580}

Probably caused by : ntkrnlmp.exe ( nt!ExpSystemErrorHandler2+5e1 )

Followup: MachineOwner
---------

7: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

WINLOGON_FATAL_ERROR (c000021a)
The Winlogon process terminated unexpectedly.
Arguments:
Arg1: fffff8a00012ac00, String that identifies the problem.
Arg2: 0000000000000000, Error Code.
Arg3: ffffffffc0000001
Arg4: 0000000000100580

Debugging Details:
------------------


BUGCHECK_STR:  0xc000021a_0

ERROR_CODE: (NTSTATUS) 0xc000021a - {Fatal System Error}  The %hs system process terminated unexpectedly with a status of 0x%08x (0x%08x 0x%08x).  The system has been shut down.

EXCEPTION_CODE: (NTSTATUS) 0xc000021a - {Fatal System Error}  The %hs system process terminated unexpectedly with a status of 0x%08x (0x%08x 0x%08x).  The system has been shut down.

EXCEPTION_PARAMETER1:  fffff8a00012ac00

EXCEPTION_PARAMETER2:  0000000000000000

EXCEPTION_PARAMETER3:  ffffffffc0000001

EXCEPTION_PARAMETER4: 100580

ADDITIONAL_DEBUG_TEXT:  initial session process or

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  smss.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff80002d2dd5e to fffff800028d0600

STACK_TEXT:  
fffff880`02e534e8 fffff800`02d2dd5e : 00000000`0000004c 00000000`c000021a fffff880`02e53608 fffffa80`06e82820 : nt!KeBugCheckEx
fffff880`02e534f0 fffff800`02b1e071 : fffffa80`06e23a76 fffff880`02e53ca0 00000000`00000100 fffffa80`05cd2230 : nt!PoShutdownBugCheck+0xae
fffff880`02e53570 fffff800`0291c8c4 : 00000000`00000000 00000000`00000004 00000000`00000000 00000000`0035f501 : nt!ExpSystemErrorHandler2+0x5e1
fffff880`02e537a0 fffff800`02d01021 : 00000000`c000021a 00000000`00000004 00000000`00000001 fffff880`02e53b58 : nt!ExpSystemErrorHandler+0xd4
fffff880`02e537e0 fffff800`02d02893 : 00000000`c000021a fffffa80`00000004 fffff8a0`00000001 fffff880`02e53b58 : nt!ExpRaiseHardError+0xe1
fffff880`02e53b10 fffff800`028cf853 : fffffa80`05c299a0 00000000`00000001 00000000`0035f588 fffff800`02be73b4 : nt!NtRaiseHardError+0x1a1
fffff880`02e53bb0 00000000`77b211ea : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0035f568 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77b211ea


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt!ExpSystemErrorHandler2+5e1
fffff800`02b1e071 cc              int     3

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  nt!ExpSystemErrorHandler2+5e1

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4b88cfeb

FAILURE_BUCKET_ID:  X64_0xc000021a_0_nt!ExpSystemErrorHandler2+5e1

BUCKET_ID:  X64_0xc000021a_0_nt!ExpSystemErrorHandler2+5e1

Followup: MachineOwner
---------
My System SpecsSystem Spec
23 Apr 2010   #3
SD1645

Windows 7 64-Bit
 
 

Hi Ken,

Thanks for the quick reply. I ran the tests as you said and they ran fine, no errors. I have attached a screenshot.

Just fyi, I started having this issue 2 days back and then I formatted windows, I am concerned if this is due to a windows update? Also, when I formatted, I couldn't reinstall the OS due to this error occurring each time. Then the Dell technician came and gave me a windows reinstalled hard disk which starting having this error as frequently as the previous version. Also, I noticed that the installed updates on my recently installed windows say they were installed on 05/23/2009 when actually it was installed only today (The system time was wrong so thats why that happened I guess).

I am giving you all this information hoping it might have some relation. Should I remove all updates and try to restart? ATM I am scared to even restart my laptop in case it never turns on again

Thanks again,
SD
Attachment 69099
My System SpecsSystem Spec
.

23 Apr 2010   #4
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by SD1645 View Post
Hi Ken,

Thanks for the quick reply. I ran the tests as you said and they ran fine, no errors. I have attached a screenshot.

Just fyi, I started having this issue 2 days back and then I formatted windows, I am concerned if this is due to a windows update? Also, when I formatted, I couldn't reinstall the OS due to this error occurring each time. Then the Dell technician came and gave me a windows reinstalled hard disk which starting having this error as frequently as the previous version. Also, I noticed that the installed updates on my recently installed windows say they were installed on 05/23/2009 when actually it was installed only today (The system time was wrong so thats why that happened I guess).

I am giving you all this information hoping it might have some relation. Should I remove all updates and try to restart? ATM I am scared to even restart my laptop in case it never turns on again

Thanks again,
SD
Attachment 69099
First things first. Do you have a backup made? and a restore point? Do you have a bootable win 7 dvd?

when all of those are out of the way we can start getting aggressive in diagnosing what the problem is.

Ken
My System SpecsSystem Spec
24 Apr 2010   #5
SD1645

Windows 7 64-Bit
 
 

Hey I have everything backed up and have a restore point and re installation win 7 disc. Lets go forward with root causing this issue. I also noticed that most of my device drivers are outdated (2006 when 2009 drivers are available) But that shouldn't cause it to NOT BOOT.

Thanks,
SD
My System SpecsSystem Spec
Reply

 Blue Screen c000021a(Fatal System Error)




Thread Tools




Similar help and support threads
Thread Forum
c000021a Fatal System Error
Hello, Recently I have been getting BSOD's.. got 3rd time in 5 bootups. It happens on Starting Windows screen. The latest one said something like this: And this is not it; I have been getting problems lately. 1. This Starting Windows screen stays for long time, so boot time has doubled...
BSOD Help and Support
BSOD | C000021a {Fatal System Error} after chkdsk
Error : STOP: C000021a {Fatal System Error} The initial session proces or system process terminated unexpectedly with a sta tus of 0x00000000 (0xc00000001 0x00010710). The system has been shut down. This happens when i choose the option to not restart upon error, else it just keeps loop...
BSOD Help and Support
BSOD: STOP: c000021a {Fatal System Error]
I have a Raid1 set-up, and I think one of the drives went bad. I disconnected the bad one and am now having trouble getting Windows to start. Here is the error code I'm getting: Problem Signature Problem Event Name: StartupRepairOffline Problem Signature 01: 6.1.7600.16385 Problem...
BSOD Help and Support
STOP:c000021a [fatal system error]
hello,while playing games online, my system gets shutdown and if i restart, i will be getting " STOP:c000021a " over blue screen. in order to start, i have to do restart several times.. any body can tell me how to fix this and what is actually ment by fatal system error? waiting for help..
BSOD Help and Support
BSOD on startup c000021a {fatal system error}
Hey fellas, i restarted my compure about an hour ago for it to complete a windows update, on the logout screen and showed: installing updates, it jumped from 10% to 20 and thirty and the skipped to shutting down. when starting back up again i got a BSOD saying: STOP: c000021a {fatal system...
BSOD Help and Support
BSOD - Stop: C000021A {Fatal System Error}
I have been having some issues with various BSOD's, I listed my most previous BSOD here on the forums and thought that I might have had this BSOD issue fixed (well, hopefully!) - it was related to AVG and possibliy conflicting with MSE, as no virus db was listed, you can see it here on the forum ...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App