Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MSVCP71.dll missing?

11 Jun 2010   #1

windows 7 Professional
MSVCP71.dll missing?

I'm using Windows 7 32bit as my secondary OS. Recently I had to place the files MSVCP71.dll MSVCR71.dll (which belong to the .net framework 1.1 if I'm not mistaken) in the System32 folder in order one of a program I use to work.
Since then the management console doesn't start. I deleted the dlls and moved them in a different folder (outside c:\windows...) in order to be available for the app and not to conflict with other windows core applications.

The problem is that now every time i start the management console it displays an error message that the file MSVCP71.dll (just this one) could not be found (obviously). after I press OK management console starts ok.

How can I fix this issue?
  1. I ran a registry cleaning program but didn't help
  2. Installed all updates from MS
  3. Installed .NET 4.0
I will gladly provide any extra info from the system if required

My System SpecsSystem Spec
11 Jun 2010   #2

Windows 7 Professional x64

I suggest a repair install.
My System SpecsSystem Spec
11 Jun 2010   #3

windows 7 Professional

thank you for the suggestion but it will take a lot to reinstall drivers, re-apply settings just to fix a small (possibly) issue, and since this is a .net problem with the frameworks redistributables and could appear again i think it should be better (for me anyway) to fix it properly without reinstalling the OS.
My System SpecsSystem Spec

11 Jun 2010   #4

Windows 7 Professional x64

A repair install shouldn't touch your drivers at all.

You can also try a system files check:
Open an elevated command prompt and enter sfc /scannow.
My System SpecsSystem Spec
11 Jun 2010   #5

windows 7 Professional

system files check didn't help, thanks again for the help. I'll keep on searching the entry for these two files (since they aren't even registered with regsvr32) and purge any memory of them for good from the system...

edit: Installing RealPlayer (which ships with these two files) also causes management console to crash.
edit 2: ok the issue will probably not affect anyone else, it was an issue with my antivirus. Uninstalled the antivirus and all is well with my new one...
you can lock the thread (or even delete it)
My System SpecsSystem Spec

 MSVCP71.dll missing?

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
MSVCP71.dll missing
Hey there, im missing the MSVCP71.dll file and without it i cant run this GPU gems 2 example program. I might be able to kill two birds with one stone if it turns out that that gets downloaded as part of an old version of MSVC++ because i've been wondering what version of visual studio they built...
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App