Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: strange windows has recovered from an unexpected...

24 Jun 2010   #1

windows 7
strange windows has recovered from an unexpected...


I always get this when starting the PC (I have no problems, no BSOD...)!!!

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7600.
Locale ID: 1036

Additional information about the problem:
BCCode: 1000007e
BCP1: C0000005
BCP2: 00040000
BCP3: 833FA4F8
BCP4: 833FA0D0
OS Version: 6_1_7600
Service Pack: 0_0
Product: 256_1

Files that help describe the problem:

Read our privacy statement online:
Windows 7 Privacy Statement - Microsoft Windows

If the online privacy statement is not available, please read our privacy statement offline:

Any help?

My System SpecsSystem Spec
24 Jun 2010   #2

Windows 7 Ultimate x64, Mint 9


Your BSoD points towards your video drivers. Make sure you update those, and Direct X as well.

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\David\AppData\Local\Temp\\062410-24796-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16539.x86fre.win7_gdr.100226-1909
Machine Name:
Kernel base = 0x83816000 PsLoadedModuleList = 0x83955570
Debug session time: Sat Apr 17 00:14:49.218 2010 (UTC - 7:00)
System Uptime: 0 days 0:00:20.953
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
Unable to load image \SystemRoot\System32\drivers\dxgkrnl.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for dxgkrnl.sys
*** ERROR: Module load completed but symbols could not be loaded for dxgkrnl.sys
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {c0000005, 40000, 833fa4f8, 833fa0d0}

Probably caused by : dxgkrnl.sys ( dxgkrnl+62192 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
Arg1: c0000005, The exception code that was not handled
Arg2: 00040000, The address that the exception occurred at
Arg3: 833fa4f8, Exception Record Address
Arg4: 833fa0d0, Context Record Address

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

00040000 ??              ???

EXCEPTION_RECORD:  833fa4f8 -- (.exr 0xffffffff833fa4f8)
ExceptionAddress: 00040000
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 00000000
   Parameter[1]: 00040000
Attempt to read from address 00040000

CONTEXT:  833fa0d0 -- (.cxr 0xffffffff833fa0d0)
eax=89446000 ebx=8cb901b0 ecx=893fd700 edx=00000000 esi=833fa634 edi=8cb9007e
eip=00040000 esp=833fa5c0 ebp=833fa5e8 iopl=0         nv up ei pl zr na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
00040000 ??              ???
Resetting default scope



PROCESS_NAME:  csrss.exe


ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.



READ_ADDRESS: GetPointerFromAddress: unable to read from 83975700
Unable to read MiSystemVaType memory at 839550c0

94d9a192 ??              ???

00040000 ??              ???


LAST_CONTROL_TRANSFER:  from 94d9a192 to 00040000

WARNING: Frame IP not in any known module. Following frames may be wrong.
833fa5bc 94d9a192 879ba000 833fa634 833fa644 0x40000
833fa5e8 94d991a6 833fa634 89446000 8cb9007e dxgkrnl+0x62192
833fa68c 94d99ea0 89446000 a36b0660 894bd008 dxgkrnl+0x611a6
833fa828 94d730de a36b0660 00000000 94d39201 dxgkrnl+0x61ea0
833fa87c 94d9c5bb 89446000 919d5500 a36b0660 dxgkrnl+0x3b0de
833faa78 9ab72611 00000004 00000000 833fad28 dxgkrnl+0x645bb
833faac0 9ab75151 ffb87010 833facd0 833fad28 cdd!CreateAndEnableDevice+0x171
833fad50 839fdd6e ffb87010 af0d3494 00000000 cdd!PresentWorkerThread+0x81d
833fad90 8389f159 9ab74934 ffb87010 00000000 nt!PspSystemThreadStartup+0x9e
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


SYMBOL_NAME:  dxgkrnl+62192

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgkrnl

IMAGE_NAME:  dxgkrnl.sys


STACK_COMMAND:  .cxr 0xffffffff833fa0d0 ; kb

FAILURE_BUCKET_ID:  0x7E_BAD_IP_dxgkrnl+62192

BUCKET_ID:  0x7E_BAD_IP_dxgkrnl+62192

Followup: MachineOwner
My System SpecsSystem Spec
24 Jun 2010   #3

Microsoft Window 7 Professional 32 bit

Hi and welcome to SF nacer99

The bugcheck indicated the cause to be dxgkrnl.sys, which is component of Directx. Please download and install fresh copy of directx.
Usually dxgkrnl.sys usually associated to video driver issue, therefore I'm looking at the drivers loaded...and yes, you have some old drivers that need to be updated:

94420000 944224e0   DtvAudio DtvAudio.sys Thu Feb 26 08:42:51 2004 (403D4F1B)
94ff9000 94fff400   DtvVideo DtvVideo.sys Mon Jan 03 10:47:22 2005 (41D8C04A)
92d39000 92d3c600   ElRawDsk ElRawDsk.sys Sun Jul 27 00:58:57 2008 (488B65E1)
92fcd000 92fe5000   NmPar    NmPar.sys    Tue Dec 19 13:22:34 2006 (4587852A)
92fe5000 92ffa000   nmserial nmserial.sys Tue Dec 19 13:20:41 2006 (458784B9)
92f28000 92f2bc00   vpscr    vpscr.sys    Tue Oct 24 02:38:33 2006 (453D1A39)
92f77000 92f7aba0   vsb      vsb.sys      Tue Sep 07 20:31:26 2004 (413DB82E)
Let us know if you need help


Edit: Opps...I'm a bit slow typing...Yes, I think LB agree with me at that point, please download and install fresh copy of video driver at manufacture's site of your machine
+ ElRawDsk.sys is RawDisk Driver by EldoS Corporation
+The other two, I guess they belong to Hamlet DTV controller drivers
Just finished the more old drivers..
My System SpecsSystem Spec

24 Jun 2010   #4

Windows 7 Ultimate x64, Mint 9

Additional old drivers:
DtvAudio DtvAudio.sys Wed Feb 25 18:42:51 2004
DtvVideo DtvVideo.sys Sun Jan 02 20:47:22 2005
ElRawDsk ElRawDsk.sys Sat Jul 26 10:58:57 2008
NmPar    NmPar.sys    Mon Dec 18 23:22:34 2006
nmserial nmserial.sys Mon Dec 18 23:20:41 2006
vpscr    vpscr.sys    Mon Oct 23 12:38:33 2006
vsb      vsb.sys      Tue Sep 07 06:31:26 2004
-The first 2 belong to the Hamlet DTV controller. These need to be updated.
-The third is a system file. Try fixing it by running sfc /scannow from an elevated command prompt.
-nmpar is also a system file, same as above.
-nmserial is also a system file, same as above.
-I can find no information on vpscr, so I recommend a scan with Malwarebytes to make sure you are not infected.
-vsb is a system file, see above.

My System SpecsSystem Spec

 strange windows has recovered from an unexpected...

Thread Tools

Similar help and support threads
Thread Forum
Windows has recovered from an unexpected...
Windows is freezing sometimes and sometime restarts..when restart I get this error: Problem Event Name: BlueScreen OS Version: 6.1.7601. Locale ID: 1033 Additional information about the problem: BCCode: 7a BCP1: C054ED50 BCP2: C0000185
BSOD Help and Support
Windows has recovered from an unexpected shutdown
Hi Everyone, I keep getting the error message Windows has recovered from an unexpected shutdown. This usually happens after the computer is put to sleep or shutdown. I have been looking through the forums, but I think I need some help with this. I have tried to attach the DMP file to this post...
BSOD Help and Support
Windows has recovered from an unexpected shutdown
I am having problems with windows shutting down instead of sleeping and I get the below error message on reboot. Ive tried downloading chipsets and drivers and nothing seems to be helping. Any suggestions? Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7600. ...
BSOD Help and Support
Windows has recovered from an unexpected shutdown
Hye everyone! I have a big big problem to my laptop. I just bought my laptop yesterday at my hometown and went to travel to my college. When I try to open my laptop, after 30 minutes,sometimes longer, it restart by itself. And after I open the windows, it gives me this error : Problem...
BSOD Help and Support
Windows has recovered from an unexpected shutdown
Hello I am having the same problem.... I have just reloaded Windows7 64bit to see if that will solve the problem. Its basically a slick boot. Just reinstalled Office 2007 Student Edition and uTorrent. I have a Toshiba P505-S8945. Thats it. Here is the basics of the problem Problem...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:54.
Twitter Facebook Google+