Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD - Dell XPS M1530

26 Aug 2010   #11
cluberti

Windows 10 Pro x64
 
 

Quote   Quote: Originally Posted by porkshire View Post
If this one caused the latest one, maybe it's because I bought a Creative external sound card on usb (Creative Sound Blaster 24-bit External USB)? It sometimes act strangly (hearing something like knocking?,I have to restart the program that uses the sound card - AIMP2,WMP11,BestPlayer - didn't have this problem in games though). Despite all, what can do about that?
Code:
0: kd> !thread
GetPointerFromAddress: unable to read from fffff80002ebf000
THREAD fffffa8009aa1b60  Cid 0ac4.0e48  Teb: 000007fffff9e000 Win32Thread: fffff900c0711820 RUNNING on processor 0
Not impersonating
GetUlongFromAddress: unable to read from fffff80002dfdb74
Owning Process            fffffa8007b0f060       Image:         explorer.exe
Attached Process          N/A            Image:         N/A
fffff78000000000: Unable to get shared data
Wait Start TickCount      3618592      
Context Switch Count      302318                 LargeStack
ReadMemory error: Cannot get nt!KeMaximumIncrement value.
UserTime                  00:00:00.000
KernelTime                00:00:00.000
Win32 Start Address 0x000007fefd98c7d4
Stack Init fffff8800a852db0 Current fffff8800a852900
Base fffff8800a853000 Limit fffff8800a845000 Call 0
Priority 12 BasePriority 8 UnusualBoost 0 ForegroundBoost 2 IoPriority 2 PagePriority 5
Child-SP          RetAddr           : Args to Child                                                           : Call Site
fffff800`00ba1c18 fffff800`02c7f46e : fffffa80`0a1dbd40 00000000`00000000 fffff800`00ba2390 fffff800`02cb4668 : nt!KeBugCheck
fffff800`00ba1c20 fffff800`02cad40d : fffff800`02e95b7c fffff800`02dcfe84 fffff800`02c17000 fffff800`00ba2b28 : nt!KiKernelCalloutExceptionHandler+0xe
fffff800`00ba1c50 fffff800`02cb4a90 : fffff800`02dd6a40 fffff800`00ba1cc8 fffff800`00ba2b28 fffff800`02c17000 : nt!RtlpExecuteHandlerForException+0xd
fffff800`00ba1c80 fffff800`02cc19ef : fffff800`00ba2b28 fffff800`00ba2390 fffff800`00000000 fffff880`05f8e700 : nt!RtlDispatchException+0x410
fffff800`00ba2360 fffff800`02c86d82 : fffff800`00ba2b28 fffffa80`06d9d6a0 fffff800`00ba2bd0 fffffa80`0b3fa4b0 : nt!KiDispatchException+0x16f
fffff800`00ba29f0 fffff800`02c8568a : 00000000`00000018 fffff800`00ba2bd8 00000000`00000000 fffffa80`0457a000 : nt!KiExceptionDispatch+0xc2
fffff800`00ba2bd0 fffff880`049d419b : fffffa80`06d9d6a0 fffffa80`0b3fa4b0 fffffa80`06d9c1a0 fffffa80`0b3fa270 : nt!KiGeneralProtectionFault+0x10a (TrapFrame @ fffff800`00ba2bd0)
fffff800`00ba2d60 fffff880`049d02dd : 00000000`00000002 fffffa80`0b3fa270 fffffa80`06d9c1a0 fffffa80`06d9c1a0 : usbuhci!UhciPollIsochEndpoint+0x6b
fffff800`00ba2db0 fffff880`04801e8b : fffffa80`06d9c1a0 fffffa80`0b3fa270 00000000`00000000 00000000`00000060 : usbuhci!UhciPollEndpoint+0x21
fffff800`00ba2de0 fffff880`048069b1 : 00000000`00000060 00000000`00000008 fffffa80`0b3fa270 fffff880`04814fed : USBPORT!MPf_PollEndpoint+0x9b
fffff800`00ba2e10 fffff880`04812043 : fffffa80`06d9c1a0 00000000`00000060 fffffa80`0000000e 00000000`00000000 : USBPORT!USBPORT_iSetGlobalEndpointStateTx+0x7c1
fffff800`00ba2e70 fffff880`04802f89 : fffffa80`06d9c050 00000000`00000000 fffffa80`06d9ca02 fffffa80`06d9ca10 : USBPORT!USBPORT_Core_UsbHcIntDpc_Worker+0x1af
fffff800`00ba2ed0 fffff800`02c92bfc : fffff800`02e01e80 fffffa80`06d9ca10 fffffa80`06d9ca28 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff800`00ba2f00 fffff800`02c8d865 : 00000000`00000000 fffffa80`09aa1b60 00000000`00000000 fffff880`04802db0 : nt!KiRetireDpcList+0x1bc
fffff800`00ba2fb0 fffff800`02c8d67c : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxRetireDpcList+0x5 (TrapFrame @ fffff800`00ba2e70)
fffff880`0a852be0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiDispatchInterruptContinue

0: kd> !sysinfo machineid
Machine ID Information [From Smbios 2.4, DMIVersion 36, Size=2001]
BiosMajorRelease = 1
BiosMinorRelease = 2
FirmwareMajorRelease = 1
FirmwareMinorRelease = 2
BiosVendor = Dell Inc.
BiosVersion = A12
BiosReleaseDate = 11/19/2008
SystemManufacturer = Dell Inc.
SystemProductName = XPS M1530                       
SystemFamily =  
BaseBoardManufacturer = Dell Inc.
BaseBoardProduct =       
BaseBoardVersion =
It appears, at least from this stack, that some device on the USB bus is having an issue with isochsynchronous I/O along the bus (the USB driver is polling for registered drivers, and someone didn't respond properly or responded with garbage data). There are some issues with this when machines resume from sleep with drivers that may not be 100% quality, for lack of a better way of phrasing it, so can you remove the Creative device from the system and uninstall it's drivers and still reproduce this problem?

Also, as a precaution, I would recommend installing the very latest public USB drivers for Windows 7:
http://support.microsoft.com/kb/981214


My System SpecsSystem Spec
.
26 Aug 2010   #12
porkshire

Windows 7 Proffesional x64
 
 

Done.

Quote:
There are some issues with this when machines resume from sleep with drivers that may not be 100% quality, for lack of a better way of phrasing it, so can you remove the Creative device from the system and uninstall it's drivers and still reproduce this problem?
I have only 2 usb devices connected - a Logitech mouse and the sound card. I have the mouse for a long time and it didn't cause me any problems,. So it has to be the sound card, as I have it for 2 days. I'll try to reinstall the drivers. Maybe Creative released some shitty drivers for Windows 7 that cause the problems. As for the sleep, I don't use that function. Unless when I don't use the laptop for some time and the screen blanks and all, but I just have to move the mouse to bring it on, so I don't think that the laptop went to sleep.

As the topic has 2 pages now, I'll write again about the next crashes (I edited my previous post, but not everybody may have read it).

Quote:
I have uninstalled the drivers for the video card and cleaned the rest with the Driver Sweeper. After the restart, when I double clicked the file with new drivers, system crashed. After another restart, while doing the same thing, another crash. I attach the file with minidumps from those 2 crashes. Hope you will help me find the cause of them.
My System SpecsSystem Spec
26 Aug 2010   #13
cluberti

Windows 10 Pro x64
 
 

If you want to be 100% certain, you can enable driver verifier and hope the next dump contains better data about the problem (it should). This latest attachment doesn't contain the USB update, so I wouldn't worry about that one too much.
My System SpecsSystem Spec
.

26 Aug 2010   #14
porkshire

Windows 7 Proffesional x64
 
 

The hotfix wasn't such a good idea. The svchost.exe processes started to take 100% of my CPU all the time. I had to uninstall it. During the restart after the uninstallation another bsod happened but it blanked only for a short while, I didn't even notice the error code and there is no new minidump. I enabled the driver verifier though. I don't know if it's because of the update or not but the system started to run really choppy and it wasn't so slow earlier I think I will have to do another fresh install of the system. I did the last only two months ago. All this bsods and problems are really starting to get on my nerves
My System SpecsSystem Spec
26 Aug 2010   #15
cluberti

Windows 10 Pro x64
 
 

Reinstall, but don't attach the creative device or install it's driver right away, and see if you stay clear for 24 - 48 hours. If so, add the Creative device and driver, and see if the behavior changed.

As to svchost, that's actually pretty normal after installing a hotfix (remember, this isn't a security update, it's an actual system binary code change), and should subside within 10 - 15 minutes.
My System SpecsSystem Spec
27 Aug 2010   #16
reventon

Windows 7 x64, Windows XP SP3, Fedora
 
 

Hi,

2 more things for you take care of

1. Intel Wifi Driver

Code:
netw5v64.sys Wed Sep 16 07:34:16 2009
This driver still has the same timestamp in the latest dump as it did at the start - when it was listed as a probable cause.

Try updating it again from here (run the update utility) - http://downloadcenter.intel.com/Default.aspx

2. Kaspersky
This is known to cause BSODs - and is most likely interfering with the out of date Intel Wifi Driver.

Remove ASAP -> KIS Removal -- jcgriff2.com

Considering the last few dumps - it is more than likely that the Creative Device is at fault however it will still pay to deal with the above.

Regards,
Reventon

BUGCHECK SUMMARY
Code:

Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Fri Aug 27 08:37:19.538 2010 (GMT+12)
System Uptime: 0 days 0:01:52.520
Probably caused by : usbuhci.sys ( usbuhci!UhciPollIsochEndpoint+6b )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x1E
PROCESS_NAME:  System
Bugcheck code 0000001E
Arguments 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Fri Aug 27 08:34:54.311 2010 (GMT+12)
System Uptime: 0 days 0:03:07.293
Probably caused by : usbuhci.sys ( usbuhci!UhciPollIsochEndpoint+6b )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x1E
PROCESS_NAME:  System
Bugcheck code 0000001E
Arguments 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Thu Aug 26 22:03:50.555 2010 (GMT+12)
System Uptime: 0 days 15:40:50.412
Probably caused by : usbuhci.sys ( usbuhci!UhciPollIsochEndpoint+6b )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x1E
PROCESS_NAME:  explorer.exe
Bugcheck code 0000001E
Arguments 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Tue Aug 24 05:39:30.011 2010 (GMT+12)
System Uptime: 0 days 9:57:39.130
Probably caused by : win32k.sys ( win32k+26fd7 )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x3B
PROCESS_NAME:  explorer.exe
Bugcheck code 0000003B
Arguments 00000000`c0000005 fffff960`00036fd7 fffff880`09810e10 00000000`00000000
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Fri Aug 13 20:57:54.561 2010 (GMT+12)
System Uptime: 0 days 3:25:57.419
*** WARNING: Unable to verify timestamp for nvlddmkm.sys
*** ERROR: Module load completed but symbols could not be loaded for nvlddmkm.sys
Probably caused by : nvlddmkm.sys ( nvlddmkm+f322e )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
PROCESS_NAME:  System
BUGCHECK_STR:  0x7E
Bugcheck code 1000007E
Arguments ffffffff`c0000005 fffff880`109ab22e fffff880`03806418 fffff880`03805c80
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16539.amd64fre.win7_gdr.100226-1909
Debug session time: Mon Jul 26 00:46:19.155 2010 (GMT+12)
System Uptime: 0 days 22:28:30.462
*** WARNING: Unable to verify timestamp for netw5v64.sys
*** ERROR: Module load completed but symbols could not be loaded for netw5v64.sys
Probably caused by : netw5v64.sys ( netw5v64+a609 )
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x1E
PROCESS_NAME:  System
Bugcheck code 0000001E
Arguments ffffffff`c0000005 fffff880`08be4700 00000000`00000000 00000000`00000000
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
My System SpecsSystem Spec
27 Aug 2010   #17
porkshire

Windows 7 Proffesional x64
 
 

Quote:
1. Intel Wifi Driver
After the advice from ttran, I reinstalled the wifi driver but there was no newer version. Now as I checked, there is. I have updated it.

Quote:
2. Kaspersky
Sorry to hear that Kaspersky might be the problem. I have a free subscription for it and I always liked that antivirus. Can you recommend some other , bsod free, antivirus software (best free or cheap) ? Before Kaspersky I used Avira Antivir.

As for the Creative device, I found some advices, which may help to get rid of the problem. I will check them out, if the problem still exists, I will just sell it and think about buying something else.

Thanks for all the advice!
My System SpecsSystem Spec
27 Aug 2010   #18
reventon

Windows 7 x64, Windows XP SP3, Fedora
 
 

Quote   Quote: Originally Posted by porkshire View Post
Can you recommend some other , bsod free, antivirus software (best free or cheap) ?
Microsoft Security Essentials -> http://www.microsoft.com/Security_Essentials/
My System SpecsSystem Spec
27 Aug 2010   #19
cluberti

Windows 10 Pro x64
 
 

Very cool - please don't forget to post back and let us know how things are going.
My System SpecsSystem Spec
12 Sep 2010   #20
porkshire

Windows 7 Proffesional x64
 
 

Hi.

Everything was fine since the last time you've helped me. I did all the things you told me to, except for removing Kaspersky. But today, while playing Starcraft 2 my laptop crashed. I attach the minidump. Any help appreciated. Thanks!
My System SpecsSystem Spec
Reply

 BSOD - Dell XPS M1530




Thread Tools




Similar help and support threads
Thread Forum
Dell XPS M1530 BSOD
Happy New Year! OK, I have a 2-3 year old Dell XPS M1530 laptop, which is crashing. It was running Vista Home Premium 32-bit OEM originally, but I upgraded it to Windows 7 Home Premium 32-bit Retail some time ago with no problems. Since then I had problems with the internal Intel WiFi...
BSOD Help and Support
Dell M1530 - BSOD
Hi all I have to admit defeat. Been having random BSOD for ages now since installing Windows 7 64Bit on laptop. Havent been that bothered but it is starting to get to me now so trying to do something about it. Dell M1530 laptop is about 2-2.5 years old. Originally came with vista 32bit. Now...
BSOD Help and Support
BSOD on Dell XPS M1530
Help my system is crashing with a blue screen the following message appears:- i am getting the following message after a blue screen Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7600.2.0.0.768.3 Locale ID: 2057 Additional information about the problem: BCCode: fe BCP1:...
BSOD Help and Support
BSOD on Dell XPS M1530
Help my system is crashing with a blue screen the following message appears:- i am getting the following message after a blue screen Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7600.2.0.0.768.3 Locale ID: 2057 Additional information about the problem: BCCode:...
BSOD Help and Support
Dell XPS M1530, DVD ROM driver, Win 7 Pre SP1
Hi guys, I was just wondering, if anyone knew about a newer firmware or driver software that I could find for the Optical Drive of my Dell XPS M1530. The problem is that I'm testing Windows 7 SP1 (V 1.53, btw). Yeah... Yeah... I know... Since is not an official release I can't hope for it to...
Drivers
BSOD DELL XPS-M1530, Win7x64Ultimate
Hello everyone, Yet another BSOD thread, for Win7 64bit I am trying to download the appropriate resources to debug this myself, but since it will be my first try ever to do that, perhaps some help from the 'pros' can be beneficial. I am attaching a zip of my recent crush minidumps ...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

й Designer Media Ltd

All times are GMT -5. The time now is 14:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App