Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: You know what really grinds my gears...

11 Aug 2009   #11
LFB

Windows7 Enterprise SP1 x64 (Technet)
 
 

Antivirus just sucks... that's why i never use...
My System SpecsSystem Spec
11 Aug 2009   #12
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by LFB View Post
Antivirus just sucks... that's why i never use...
same here...Windows Firewall on and no Anti-Virus...no viruses sense 98SE
My System SpecsSystem Spec
11 Aug 2009   #13
LFB

Windows7 Enterprise SP1 x64 (Technet)
 
 

Quote   Quote: Originally Posted by Zidane24 View Post
same here...Windows Firewall on and no Anti-Virus...no viruses sense 98SE
Exactly...
My System SpecsSystem Spec
.

12 Aug 2009   #14
holo88

Windows 7 Ultimate x32
 
 

whats the weather like, ollie?
israinin!
thanks ollie.

(Ollie pwns)

speaking of a/v's anyone do that survey MS sent out last night? re: MSE.
My System SpecsSystem Spec
12 Aug 2009   #15
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by holo88 View Post
whats the weather like, ollie?
israinin!
thanks ollie.

(Ollie pwns)

speaking of a/v's anyone do that survey MS sent out last night? re: MSE.
i tried it out for a bit...still enrolled to in on Connect...but like I said I find Anti-Virus silly for anyone who is remotely careful while they browse. Just use a little wit while browsing and trust your gut...no virus anytime
My System SpecsSystem Spec
12 Aug 2009   #16
StephenJay

Windows 7
 
 

Quote   Quote: Originally Posted by Zidane24 View Post
i tried it out for a bit...still enrolled to in on Connect...but like I said I find Anti-Virus silly for anyone who is remotely careful while they browse. Just use a little wit while browsing and trust your gut...no virus anytime
You have to think too, some people like to use torrents to get software.
Using torrents without an AntiVirus is just plan stupid, imo.

Also you have to realise that some people aren't exactly pros at computers. Particularity young teenagers I have noticed (13-15 year olds) download from Limewire willy-nilly and when I open their IE half of the page is filled with toolbars.

Then I have to spend a good amount of time fixing their PC D:
Why anyone would want to install SmileyCentral Toolbar is beyond me.
My System SpecsSystem Spec
12 Aug 2009   #17
Orbital Shark

 
 

Quote   Quote: Originally Posted by stephenjay View Post
You have to think too, some people like to use torrents to get software.
Using torrents without an AntiVirus is just plan stupid, imo.

Also you have to realise that some people aren't exactly pros at computers. Particularity young teenagers I have noticed (13-15 year olds) download from
Quote:
Limewire
willy-nilly and when I open their IE half of the page is filled with toolbars.

Then I have to spend a good amount of time fixing their PC D:
Why anyone would want to install SmileyCentral Toolbar is beyond me.
Do people still use Limewire???

Isn't the main installer a virus? I've had to clean up so many machines after just an install of limewire
My System SpecsSystem Spec
12 Aug 2009   #18
z3r010

 

Anybodys PC that comes through here always ends up with limewire's site blocked in the hosts file
My System SpecsSystem Spec
12 Aug 2009   #19
StephenJay

Windows 7
 
 

Quote   Quote: Originally Posted by Orbital Shark View Post
Do people still use Limewire???

Isn't the main installer a virus? I've had to clean up so many machines after just an install of limewire
Unfortunately they do :|
One person tried "Frostwire"
But that was basically the same, I still had to fix their PC from ruins afterwards.
My System SpecsSystem Spec
12 Aug 2009   #20
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by stephenjay View Post
Unfortunately they do :|
One person tried "Frostwire"
But that was basically the same, I still had to fix their PC from ruins afterwards.
For myself Anti-Virus is silly...for others I reccomend it completey...
My System SpecsSystem Spec
Reply

Thread Tools


Similar help and support threads
Thread Forum
Windows hits invisible resource limit, grinds to a halt and freaks out
I stuck with Windows XP until just a few months ago because I knew Vista was a disaster and that Windows 7 had a lot of BS design changes. But I'd had it up to here with being stuck with < 4 GB RAM (especially since I already had 16 GB in my machine) and my computer grinding to a halt as a result,...
Performance & Maintenance
Google Chrome grinds to a halt or can't access page
Hello and thanks in advance for any insight to this problem. Google Chrome suddenly slows and opening pages reminds me of old dial up connection then show errors ( I'm sorry I don't have codes) - I would close out and reopen the browser and it would work okay for a few pages ad go back to...
Browsers & Mail
Gears of War: WINDOWS 7 run fail
hi everyone got some problems with starting GoW on my machine... that is it doesnt run at all :( i think it's all about win7 64bit and GoW uncompability, seems that the game is 'too old' for windows 7 instalation gone corectly, but when i try to run the game, following message appears: ...
Gaming
Steam really grinds my gears...
Okay so I don't have any source of decent high speed internet (And if I get any of that "OMG NO CabLe Live in THe Nao" Crap I'll be angry, I can't help it, it's not available where I live, the closest thing is satellite ) Anyways I purchased Empire: Total War. On the back of the box it says it...
Gaming
how to install gears of war other then c/:
how to install gears of war other then c/: i have only 8gb left in c drive and gears of war going only in c drive can any 1 help i try my best but i wont work:cry::cry:
Gaming
Gears Of War 2 wont work
as said in the title this game wont work,i installed the game and when i try to start it it says :failed to initalize the physics system.please ensure you have an updated version of the physx system software installed...HELP!
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App