Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Remove Read-Only in XP

20 Feb 2012   #1

Windows XP, 32 bit
Can't Remove Read-Only in XP

hi, i recently purchased a new computer because my old one died and went to heaven, i removed the two hard drives from it because they contained alot of my pictures and music and i put one of them into my new one, it will let me access it but i can't view anything on them because its saying i don't have permission and i can't remove the read-only. Any suggestions.

P.S. both computers are windows xp 32bit
My System SpecsSystem Spec
20 Feb 2012   #2

Win7 Home Premium x64 W10Pro&Home

1. right click on the drive that you want to take ownership of (in my computer) and choose properties
2. click on the 'security' tab
3. click the 'advanced' button
4. click the 'Owner' tab
5. under 'change owner to:' select your username
6. check the 'replace owner on subcontainers and objects'
7. click Apply (may take some time)
8. click on the 'Permissions' tab
9. click the 'add' button
10. type 'everyone' for all users to be able to access the drive. Type your user name just for yourself. OK it.
11. click the 'full control' checkbox under 'allow.' OK it.
12. check the 'replace permission entries on all child objects...' checkbox
13. OK it (result may take some time)
14. OK the last window
My System SpecsSystem Spec
20 Feb 2012   #3

Windows XP, 32 bit

don't have a security tab when i click on properties, the tabs i have are general, tools, hardware, sharing, and quota
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
Remove read only attribute of folder.
I have an executable file, which is a windows service. Now I cannot start it from service control management panel. I am the administrator. I guess the readonly attribute effects it. I found that the folder is readonly. I unclick it and apply it and click OK button. However next time when I look...
General Discussion
Cannot remove read-only from shared folder - help!
- I have three PCs - two running Win 7 Home Premium ("clients") and one running Win 7 Ultimate ("server"). - I wish to use one of the server PC's HDD to store a backup of critical files of the two client PCs using folder sharing. - All three are on the same homegroup (took me ages to achieve...
Network & Sharing
Unable to remove Read only attribute
I am a photographer. I use Adobe Lightroom 4 to manage my photos. I had to reload my photos the other day. Today I was making changes in the data in my photos, when I finshed and saved the data I recevied a message that the photo was Read Only. I have tried several remidies posted here and other...
Music, Pictures & Video
How come I can't remove read only from folders?
I noticed that under properties of my user name that read only is checked, I am the admin and the only one on my pc. I've unchecked it twice and it applies changes but when I go back in it is checked again? I've tries restarting thr computer but still no luck?
General Discussion
Can't remove 'Read Only' for C:/Windows/installer
Yeap, as per the title Now I'm having problems installing java. I'm logged into my only account, which is an admin account, and yet I can't remove the read-only thing from the folder. Please help. This is related to the 'error 2203' problem when installing java Windows 7 ultimate 64
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App