Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: So who is using Chrome?

08 May 2009   #71
Thirteenthorder

Windows Se7en
 
 

Quote   Quote: Originally Posted by ikilledkenny View Post
Safari FTW
I loved the old Safari until the beta came out. Top Sites hogs up my resources like you would not believe. I'm stuck for about two minutes every time I open up a new tab.

Other than that, it's an excellent browser. But than again, that could be said for anything other than IE6 xD

Safari and Firefox FTW!
My System SpecsSystem Spec
11 May 2009   #72
ikilledkenny

Windows 7 Professional, Windows Longhorn 4074
 
 

Quote   Quote: Originally Posted by Thirteenthorder View Post
Safari and Firefox FTW!
Agreed :)
My System SpecsSystem Spec
11 May 2009   #73
jfar

Vista Ult64, Win7600
 
 

I use them all ,but using Chrome again at the moment.
My System SpecsSystem Spec
.

12 May 2009   #74
penguin17

Win7 7201 x64
 
 

Have just switched to the chrome 2 beta and so far i'm very impressed with it, have been with firefox for many years but never really bothered with the add ons, so the switch was easy.
My System SpecsSystem Spec
12 May 2009   #75
ikilledkenny

Windows 7 Professional, Windows Longhorn 4074
 
 

I have Minefield (FireFox 3.6pre1)

I don't like it as much as Safari, but it's pretty good. No bugs so far...
My System SpecsSystem Spec
12 May 2009   #76
Win7User512

Windows 7 x64 / Same
 
 

Safari and Chrome are OK, but I like Firefox best.
My System SpecsSystem Spec
12 May 2009   #77
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

Quote   Quote: Originally Posted by ikilledkenny View Post
I have Minefield (FireFox 3.6pre1)

I don't like it as much as Safari, but it's pretty good. No bugs so far...
you must be very lucky (or not using addons..)
the reasoning is that alphas have buggy code...:)
for me if i have bug (have many...:)) that i course send to mozilla to that they can have enough feedback..
My System SpecsSystem Spec
13 May 2009   #78
nate42nd

Windows 7 Professional x64
 
 

Does everybody else create a new "Bookmarks folder" on the LEFT side of the bookmarks bar?

I have found this to be the number one complaint with people I have switched.
It's very easy to do and make things more like how they were in other browsers.

Chrome rules.
My System SpecsSystem Spec
15 May 2009   #79
screwballl

Win7, XP, Vista x64, Ubuntu 9.04
 
 

Quote   Quote: Originally Posted by LePoilu View Post
I don't

Lack of addfilter
Lack of mouse gesture
Lack of customisation

I Stay with Maxthon
pretty much how I see it, except I use Firefox. The rest of the browsers are either too problematic or are just junk IMHO.
My System SpecsSystem Spec
16 May 2009   #80
Tsimezke

Windows 7 RC1
 
 

Chrome rocks... As swarfega says : 'set up an ad filtering proxy...'
My System SpecsSystem Spec
Reply

Thread Tools


Similar help and support threads
Thread Forum
Chrome Unable to Save Webpages How to uninstall & reinstall chrome?
I having a google chrome lately. Whenever I wanted to save a webpage written in HTML,Asp,Php, etc. I will not be able to save it. For example, a 82Kb HTML webpage will save to 4Kb then it stop forever.If I press retry, it will download and save without problem. It's not the ISP connection as the...
Browsers & Mail
BSOD when using Chrome the past 2 days, also Chrome Tab crashing
Hi there, I've been consistently getting BSODs on startup and when using Chrome over the past 2 days. Every other time I load a new chrome tab (be it Youtube, Facebook, etc), the tab crashes. It says 'Aw Snap!'. Then after a while of using Chrome on the computer , I get a BSOD. I've...
BSOD Help and Support
Getting chrome has stopped working popups but chrome still runs fine
I'm getting a pop up that tells me chrome has stopped working when I start up chrome. Then I get more of these pop ups as I browse the web. The pop up tells me chrome has stopped working when it actually hasn't. Anyone know how to fix this?
Browsers & Mail
Google Chrome v8 developer build hints at future of Chrome OS
more
News


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:07.
Twitter Facebook Google+