Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Configuring the "Debugging Tools"

24 Apr 2013   #51
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

After opening an elevated command prompt, have you changed the directory as by typing
CD C:\debuggers ?

When you are at the proper directory, then only you can execute the next command as per the tutorial.


My System SpecsSystem Spec
.
24 Apr 2013   #52
rovopio

windows 7 home premium 64bit
 
 

yea i did that and i got windows cannot find the file path specified.

so i wrote C:\>chdir /d C:\debuggers instead.

I am here now, C:\debuggers>
windbg.exe -IA

and i got that internal external command etc etc

do i need to download the proper 8.0 debugging tools btw? or the stand-alone 7.1 i've downloaded and put on the wrong path worked just as well?
I'm downloading the debugging tools part of WDK as we speak, i hope its the correct one

===
btw, i posted on my BSOD thread regarding uninstallation of driver and getting rid of asus utility, kindly check it out at your leisure

cheers,

KP

wish you a great week!!
My System SpecsSystem Spec
24 Apr 2013   #53
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Try it: Debuggers (x64)

A bit older version, but works exactly the same. Contains the debugger tool only and nothing more.
My System SpecsSystem Spec
.

24 Apr 2013   #54
rovopio

windows 7 home premium 64bit
 
 

Quote:
Even if the dumps are not associated with windbg, you can open windbg, then File > Open Crash Dump and browse to the dump and open it. The result will be the same.
i tried this as well since its on post#1,, there are 2 dump file on my dump folder, when i opened 1 of them,, i got a pop up saying "executable search is:" and it doesnt open just stay that way.

when i opened the other one, i got "you dont have to correct symbols" or smthn... i cant rmmbr what.


on that note, i will try downloading your link and go from there,


cheers again,


KP~!
My System SpecsSystem Spec
24 Apr 2013   #55
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Open windbg.
Go to File > Symbol Path File.
In the box, paste it : SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
If it is prompted to save the workspace, uncheck the box and save.

All done.
My System SpecsSystem Spec
25 Apr 2013   #56
rovopio

windows 7 home premium 64bit
 
 

okay i've tried opening the crash dump file, and its already associated with dmp files, the windbg.exe -IA command works properly this time, however when i tried opening dump files, i got

Symbol search path is: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
Executable search path is:

and that's it. also on the bottom it was written, debuggee not connected.

may i ask wht should i do now?
My System SpecsSystem Spec
25 Apr 2013   #57
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Quote   Quote: Originally Posted by kungfupanda7 View Post


and that's it. also on the bottom it was written, debuggee not connected.


may i ask wht should i do now?
Wait a bit .... till a line comes saying "Followup : machineowner" or something similar. It's a break point, and then you will get KD against the place to type further commands.
Configuring the "Debugging Tools"-2013-04-26_004754.jpg


My System SpecsSystem Spec
25 Apr 2013   #58
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

If you set things up correctly (which from the looks of it you did), what's happening is it's downloading all the symbol files and storing it in the folder you assigned (C:\SymCache). It will take a while, especially for the first run, so let it sit. May even take several minutes, depending on your network connection. Once it's done, the "debuggee not connected" will disappear and it'll provide the prompt and will not give any big symbol errors.

Some symbol errors are expected for drivers that are 3rd-party drivers, since they very commonly do not include symbols (nor will MS have it in their symbol server). What you'll want to worry about is when it pops up that it couldn't find symbols for Windows modules. When that happens usually it'll prompt you with a big massive message about no or incorrect symbols.
My System SpecsSystem Spec
25 Apr 2013   #59
rovopio

windows 7 home premium 64bit
 
 

awesome, i think it takes a quite long while due to slow internet connection then.

i will post my result on the appropriate thread,

cheers for the help!!

KP
My System SpecsSystem Spec
25 Apr 2013   #60
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Then the SymCache will be developed, it will not take very long to complete a breakpoint.
My System SpecsSystem Spec
Reply

 Configuring the "Debugging Tools"




Thread Tools




Similar help and support threads
Thread Forum
Fresh Win7 Install "Failure Configuring Windows Updates"
Doing a fresh oem win7 sp1 pro x64 install. After initial setup allowed Windows update to do It's thing (146 updates). Upon reboot I get the message "failure configuring windows updates" Have read extensively re. this issue but, unfortunately, have not found a definitive resolution. ...
Windows Updates & Activation
Error Message "Failure configuring Windows update"
I have Win 7 ultimate. For the past few months my computer tries to download the updates and install them automatically, but it does not complete them. I get the error message as above and informs "Reverting the changes". What does this mean and how to fix this problem ? Thanks for the help.:)
Windows Updates & Activation
Google "More" and "Search Tools" buttons no longer working...
Sometime over the last few weeks Google's "More" drop-down and its "Search Tools" menu items have quit working in IE10. The other buttons that let you select web, images, shopping, etc. still work properly. The "More" and "Search Tools" buttons get focus when the mouse is over them and they...
Browsers & Mail
"Failure configuring updates" message - advice please!
Hi everyone, I'm running Windows 7 Home Premium on an HP laptop and I have automatic Windows updates activated. Earlier today when I finished a session, 6 updates were installed. I've just switched the computer on again and got the message "Configuring Windows updates" as often happens...
Windows Updates & Activation
Which Setting for "Write Debugging Information"
I have been having a recurring BSOD problem. I have ran memtest86 overnight and came back to find 0 errors which was surprising since I had assumed that was my problem. Now I am trying to open my dump file and having some trouble. I just switched my setting so the system doesn't automatically...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App