Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: removing "press any key to continue"?

14 Jun 2012   #151

Windows 7 Ultimate x64

I am also glad to see you have both drives working again.

The questions I asked Anak were out of curiosity more than anything else.

I really should have posted earlier. As I said in #Post 43,
Well to me at least, your out of luck.
The Jmicron detection screen is part of the BIOS POST and the RAID setup screen.

I took it one step further and can say for certain the JMicron's firmware is included in your BIOS file as an Option Rom. Using a BIOS mod tool I was able to extract a file called "jmb361_1.06.63_raid.bin" from the BIOS file. Now I'm no reverse engineerer but opening the file with notepad reaveals the following text,
PCIE-to-SATAII/IDE RAID Controller BIOSv1.06.62 Copyright (C) 2005 JMicron Technology. Detecting drives, please wait ... Detect drives done, no any drive found. Press any key to continue ... Press <Ctrl-J> to enter RAID Setup Utility ... Save to Disk & Exit (Y/N)? Y DEGRADED/REBUILD DRIVE DETECTED. IT IS SUGGESTED TO REBUILD IN THE OPERATION SYSTEM TO PRESREVE THE COMPLETENESS OF YOUR DATA. Be careful, it is not raid mode now,but there is still raid structure in the hard disk [TAB]-Switch Window []-Select ITEM [ENTER]-Action [ESC]-Exit [TAB]-Switch Window []-Select DISK [ENTER]-Detail [ESC]-Exit [TAB]-Switch Window []-Select RAID [ENTER]-Detail [ESC]-Exit
As you can see these are the strings that are displayed on the JMicron detection screen.

Now how can a driver effect the JMicron's detection screen? The screen is processed before any OS, driver or registry keys are loaded and there is no rom file or rom flashing tools included with the driver.
1) RaidAPShowStateAtSysBoot = 2
2) ShowDiskInfoForNonRaidMode=1
3) SplashTime=0
All these things must be to do with the Windows RAID application. The following is a good guess,

1 - Not entirly sure but may have somthing to do with the RAID app showing on boot or just loading to the taskbar.

2 - Determines if disk info is shown in the RAID app when set to IDE in BIOS.

3 - How long to display the splash screen when opening the RAID app.

BTW if you want the latest JMB36x driver it can be downloaded from

Not really any changes that will effect you but the ReleaseNotes are at the bottom of the page if you wish to review the changes.

My System SpecsSystem Spec
14 Jun 2012   #152

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

@Duzzy: Thanks for the "reverse engineering". At least ptbg's machine has been "improved" by a number of changes chasing down this issue.

@ptbg: Thanks for posting the Speccy screenshots.

Now for a little clean up after this seemingly futile attempt to resolve the "press any key" issue.

I was looking through the System Information you posted earlier and I see a number of extraneous programs you might have downloaded trying to fix the issue. There are some others I'm not familiar with, but you only need one AV program (plus MalwareBytes) - you have two.

This recommendation has nothing to to with the "press any key" issue - it's simply housekeeping. Removing some of the programs should improve your system performance (Acronis has scheduled updates & backups - I don't know if you have storage for backups, so why run it). There are a number of Startup programs that could be disabled.
Removing others might prevent future problems (third party bots, blasters, tune-ups). I personally tend to only trust a few vendors for GREAT software and I use only what I absolutely need on my system.
Pgms I don't think you need
-- your decision though.
Puran Defrag (Windows 7 defrag is fine)
Spybot (unnecessary)
SpywareBlaster (unnecessary)
TuneUp Utilities 2012 (unnecessary)
Acronis (unnecessary - Yeah, I know... I pointed you to Acronis on WD)

Pgms I think are redundant or unnecessary
-- You might have these by choice or they came with you machine. You will have to decide if you need them.

????? Aomei Partition Assistant Home Edition 4.0: Free Partition Magic alternative - AOMEI Partition Assistant is magic partition manager software for Windows 8/7/Vista/XP and Server 2000/2003/2008

????? gBurner: is a powerful and easy-to-use CD/DVD/BD burning software, which allows you to create data, audio and video CDs, DVDs and Blu-ray Discs, make bootable data discs, create multisession discs. gBurner is also a disc image file processing software, which allows you to open, create, edit, extract, convert and burn disc image files.

????? HFSExplorer: View Mac OS X files from a Windows partition

????? Oracle VM VirtualBox: enables desktop or laptop computers to simultaneously run multiple operating systems, allowing users to get the most flexibility and utilization out of their PCs.
Note: See the tutorials on virtualization in Windows 7

????? RocketDock: is a smoothly animated, alpha blended application launcher. It provides a nice clean interface to drop shortcuts on for easy access and organization.

????? Sophos: Award Winning Antivirus, Email Spam Protection and Endpoint Management Software for Windows, Mac and Linux

????? ESET\ESET Smart Security: complete Internet security suite, built on the award-winning ThreatSense antivirus and antispyware engine.

????? Unlocker: If you've ever been unable to delete a file in Windows, and can't figure out what program's using it, Unlocker is the solution. Simply right-click the folder or file and select Unlocker. If the folder or file is locked, a window listing of lockers will appear.

Startup items
everest.exe - shortcut (might just be in the wrong folder)
taskmgr.exe - shortcut (might just be in the wrong folder)
RocketDock - gone if you uninstall
SpybotSD TeaTimer - gone if you uninstall
egui - ESET security (depending on which security pkg you choose, this one should stay, or gone if you decide on Sophos)

If you could change the IDE detection time to 0 seconds and stop displaying the JMicron screen, that would "solve" the issue, but there doesn't seem to be a way to access those settings. Per Duzzy, it is controlled solely by the BIOS and I agree, no driver or registry entry is going to change that. I was thinking the install settings affected the BIOS - which Duzzy points out... "There is no flash in the update"

The best and least expensive solution is probably to purchase a PCI IDE card (around 12-14 euros) as I mentioned in post #147 and completely ignore the JMicron controller (disable/uninstall).

A more expensive solution would be to purchase a larger SATA drive, connect it to an available Intel SATA connector, move your data from the WD to the new drive, exchange the IDE cable you bought for an IDE-SATA adapter cable and hook up your NEC OD to an available Intel SATA connector and completely ignore the JMicron controller (disable/uninstall).

A third solution would be to purchase external cases and drive the WD and NEC off USB ports and completely ignore the JMicron controller (disable/uninstall).

I sure am good at spending your money, aren't I. The key to all of the above solutions is to completely ignore the JMicron controller (disable/uninstall).

Duzzy's evaluation is sound. I presumed there was a flash in the JMicron update...ooops, notice I didn't ASSume - thank you very much Duz, for looking deeper!

Μπορείτε επίσης φίλος μου, κι εσείς. Είμαστε όλοι μάθησης - Γεια σου ... Είμαι ακόμα εκμάθηση της ελληνικής γλώσσας! You too my friend, you too. We're all learning - hey... I'm even learning Greek!
My System SpecsSystem Spec
14 Jun 2012   #153

Microsoft Windows 7 Ultimate 64-bit Service Pack 1

A single post,would be too poor to express,how i feel about all of you people who really tried to help me solve a four,maybe five second issue.I ll probably stick with the cheapest solution,buy a PCI card for now and later get rid off all that old IDE junk.It might seem like an oscar nomination speach,but i wanna thank every single one,i even went all 16 pages through,just not to miss anyone.REALLY BIG THANKS to
3D Jed
Hopalong X
A guy
Petey 7
and that greek speakin old man called Slartybart
Gonna be around,maybe help is needed,resizing my taskbar...

αυτο ειναι ενα ανεκδοτο
My System SpecsSystem Spec

14 Jun 2012   #154

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

One point I should make - you will get the "any key" prompt until you disable the JMicron controller

I hope you're not joking about resizing your taskbar - ROTFLMAO

Αλλά σας είπα, δεν μιλάω ελληνικά,

Thanks for your help - couldn't have done it without you.
My System SpecsSystem Spec
14 Jun 2012   #155

Windows 7 Ultimate x64

That all makes sense as far as BIOS still having control before passing it to the HD for booting. That said, I think it's worth a shot to think about changing the value of this regkey (back up the registry first):


The BIOS on some boards can be written to while the OS is running (SMBIOS), and maybe that key is "key" to the issue.

I think I'd have a hard time deciding to buy another card I'd likely have no future use for and considering I already had the functionality to begin with (albeit with a 5 sec delay). But if I was going to do it I think I'd get a PCI-E card rather than a PCI.
My System SpecsSystem Spec
14 Jun 2012   #156
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Was a pleasure watching everyone help in this thread. Rep all around

A Guy
My System SpecsSystem Spec
14 Jun 2012   #157

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by A Guy View Post
Was a pleasure watching everyone help in this thread. Rep all around

A Guy
Yep, it was pretty cool the way it all went down!
My System SpecsSystem Spec
15 Jun 2012   #158

Microsoft Windows 7 Ultimate 64-bit Service Pack 1

I really couldnt find key ShowDiskInfoForNonRaidMode,i dont mind messing with the editor
My System SpecsSystem Spec
15 Jun 2012   #159

Windows 7 Ultimate x64

While in Regedit use F3 to search for jraid. Then navigate through it's keys/subkeys to see if you can find a key that may correspond.
My System SpecsSystem Spec
15 Jun 2012   #160

Windows 7 Ultimate x64

Thank you for the big thanks, I think we are all happy to have helped.

I personally wouldn't buy a PCI card I would just live with it for now untill you can afford to upgrade to a SATA Hard Drive and SATA Optical Drive, it just depends on how much it really bothers you.

Good luck in the future and I look forward to helping you again with anything else if I can.
My System SpecsSystem Spec

 removing "press any key to continue"?

Thread Tools

Similar help and support threads
Thread Forum
"Setup can't continue." Windows 7 Repair Install
I've been trying to repair install Windows 7 (SP1) and every time I get to the second step (Gathering files, settings, and programs) it cancels itself and displays this message: When I click OK, it brings me back to the desktop....
Installation & Setup
"Unable to Continue" Error When Attempting to Synchronize Time
(I'll tell you some background before I get to the issue in case there is something related) I recently cleaned my computer case (took it all apart and vacuumed it out). When I plugged everything back in and tried to boot up, all of my BIOS settings had cleared and I had to re-enter/set them...
General Discussion
"Microsoft .NET Framework Version 2.0 is required to continue." Error
Hi, I hope I'm not asking this for the millionth time here, as I tried a search but am afraid it all just confused me more. I believe my problem is related to the Dell all-in-one printer I want to work with my Dell laptop. Recently, Windows updated and I now get this message again upon start up:...
General Discussion
Password required instead of clicking " yes ' ot " continue "
On an admin account, if I want to, say, download/install a program, UAC will ask for confirmation, and clicking " yes " will get it to start downloading. I wonder if I can make the system asking for password instead of giving the option of " yes " or " continue ". Like it does to a standard...
System Security
"Registry area appears locked. Cannot continue" error
Hi, I've just about completed the migration of my XP programs to my new Windows 7 x64 installation. All my programs work (astronomy related) except for one - MaxPoint by Diffraction Limited. The program installs correctly (no errors), but when I run it for the first time, I get a "Registry area...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:22.
Twitter Facebook Google+