Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to change default program access settings

03 Sep 2009   #1

Windows 7 RC x86 (US 7100 build)
Unable to change default program access settings


I'm desperately trying to change the sidebar gadget to open websites by default with Mozilla Firefox (in particular, the "Ask LEO" gadget).

Firefox is my default browser. If I double-click on a .url file saved on my system, it correctly opens Firefox, and so does clicking a link in MS Outlook. Again, Firefox is default, but that's not my problem.

Somewhere I found the advice to change the "Set program access and computer defaults" settings. So I tried, but every time I change something there, it doesn't keep the setting. I click on Custom => Default Web Browser => Mozilla Firefox, click OK, get some flashing on desktop, but next time I get there it's set back to "Use current browser" again.

Anyone got the same problem? I'm using the 7100 (x86) build, but a friend of mine tried the same on the final build (x64) and he got the same problem. It's reverting all the time. Re-installed Firefox, restarted, changed/tried/reset everything I can imagine.
Please help!


Edit: It seems the problem is a Javascript-call "" in the "Ask LEO" gadget. Someone knows why this call opens IE and every other call doesn't? And is there a workaround?
Edit2: With a dirty hack I solved the problem. Edited the gadget and replaced "" by "System.Shell.execute". Still - I'd like to know why a) I can't change the default programs setting and b) why ignores my default browser configuration.

My System SpecsSystem Spec
27 Oct 2009   #2

Windows 7

Bagstone, you need to turn of UAC in the user accounts section...then you will be able to change the access settings...
My System SpecsSystem Spec
02 Apr 2010   #3

Windows 7

Issue with Windows 7 32/64 bit and Windows 2008 R2 environments
Hi Friends,
I am facing issue when I am trying of open OSK.EXE (On-Screen Keyboard) through ShellExecute() in both Windows 7 32/64 bit and Windows 2008 R2 environments. OSK is not getting popped up after executing the command.
My source code’s statement follows:
Statement1: ShellExecute ( pWnd, "open", "C:\\WINDOWS\\system32\\osk.exe", NULL, NULL, SW_SHOWNORMAL);
Note (FYI):
(1) If I execute following statement2 by putting OSK.EXE in C:\, then On – Screen Keyboard is getting popped up.

Statement2: ShellExecute ( pWnd, "open", "C:\\osk.exe", NULL, NULL, SW_SHOWNORMAL);
(2) Statement1 is successfully executed on XP, W2K Server and Vista with expected behavior.
(3) If I try to get the last error through GetLastError() after executing the Statement 1, “Operation has been performed successfully” is translated from the return value of the GetLastError().
(4) On my Windows 7 machine, UAC is disable.
(5) I am running ShellExecute() function by logging through the login ID having added to administrator group.
Please guide me for executing the Statement1.
Thanks in advance.
My System SpecsSystem Spec


 Unable to change default program access settings

Thread Tools

Similar help and support threads
Thread Forum
Can't change cmd.exe settings to default
Hello, I'm new on SevenForums and I need to help. I was testing my Small Basic app, but when I launched it, the TextWindow font size was only 46 pixels. So I launched the Command Prompt via Run, and the size was also 46. In Properties, there were only 4 tabs and 9 sizes of Terminal font....
General Discussion
How do I change cmd to default settings?
Hi, Recently my computer's internet gliched and I can no longer connect to any webpage. I think it might have somthing to do with me deleting route on cmd. this is what I wrote: route delete -p Is there any way i can restore the deleted route?
Network & Sharing
Unable to change BIOS settings
I would like to change the boot order in my BIOS, but nothing on the keyboard will work. I reboot, and the splash screen for Gigabyte comes up. I hit the delete or F12 button and the BIOS screen comes up. Then nothing I do on the keyboard works. I have to hit the reset button. Since I can...
General Discussion
Unable to change Default Program for Video Files
Hello, I've recently installed Windows 7 Professional on my older laptop and I would like to change the program that opens video files. The default is Media Player, and I'd like to change it to KMPlayer. When I get to the "Default Programs" windows, and choose defaults for Media Player, what I...
Music, Pictures & Video
Unable to save Default Gateways in Network Settings!
Hi, I want to save the Default Gateways in Advance TCP/IP Settings for my network adapter. I used the following sequence to set the values: 1. Open Adapter Settings (LAN Properties). 2. Select IPv4 and click on Properties. 3. Click Advance. 4. In the Popup select to add Default Gateways for...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:34.
Twitter Facebook Google+