wordpad is missing from "new" right-click context menu

  1. Posts : 332
    Windows 7 32bit Home Premium

    wordpad is missing from "new" right-click context menu

    About a week ago I suddenly noticed that wordpad went missing from my "new" right-click context menu. I believe that happened when I installed the latest version of libreoffice, because now instead of wordpad I have all the libreoffice options under "new". Does anybody know how I can restore wordpad to my "new" context menu without upsetting anything else? Will it require a registry edit? I checked in libreoffice over and over and can't find an option to disable in context menu.
      My Computer

  2. Posts : 54,354
    Windows 10 Home x64

    See if this tute helps

    New Context Menu - Remove & Restore Default Menu Items

    A) Click on the download button below to download the below.
    NOTE: This is for a WordPad .rtf document file. If you have Office Word installed, then it may be set to be the default program instead of WordPad to open RTF files with and would remove Rich Text Document if so, and you may have Microsoft Word Document instead.
    A manual method if that isn't what you seek:

    How to Add / Remove Items from “New” in Windows Context Menu? - Tweaking with Vishal

    A Guy
      My Computer

  3. Posts : 332
    Windows 7 32bit Home Premium
    Thread Starter

    Hey, thanks for the reply!

    I just actually found that first link a few minutes ago and gave it a try - I downloaded the fix from the first link and ran it, but there is no change. I'll reboot and see if it shows up after a reboot. Very strange because I've made sure that .rtf documents are associated with wordpad. If I double-click on a .rtf, it opens in wordpad. But it's just gone in the context menu under new.

      My Computer

  4. Posts : 71,066
    64-bit Windows 10 Pro

    Hello tgfyhre,

    You might also see if downloading and merging the .reg for the listed RTF option in the tutorial below may help. It will restore all default associations for it.

    Default File Type Associations - Restore

    Hope this helps, :)
      My Computer

  5. Posts : 332
    Windows 7 32bit Home Premium
    Thread Starter

    I also just tried method 2, and that also didn't work, and it said it should be immediate. Here's what I've got listed under ShellNew for .rtf in HKEY_CLASSES_ROOTDefault) REG_SZ (value not set)
    DATA REG_SZ {\rtf1}
    ItemName REG_EXPAND_SZ @%ProgramFiles%\Windows NT\Accessories\WORDPAD.EXE,-213
    NullFile REG_SZAny idea what's going on here?
      My Computer

  6. Posts : 332
    Windows 7 32bit Home Premium
    Thread Starter

    Just rebooted and still no luck. Then I tried "Default File Type Associations - Restore" posted by Brink above, and that did the trick! Now I have my new>rich text document link back in my context menu.

    Thanks a ton to all that tried to help. I just hate it when software tries to hijack my context menu like this. I actually missed having that new rtf link so I'm glad I've got it back.

    Thanks again!
      My Computer

  7. Posts : 54,354
    Windows 10 Home x64

    Great! Yeah, I saw Shawn's post and just knew it would work. he has a habit of doing that

    A Guy
      My Computer

  8. Posts : 71,066
    64-bit Windows 10 Pro

    I'm glad that we could help. :)
      My Computer

  9. Posts : 1
    Windows 10 home premium

    Hey guys,

    I have just lost rich text from the context menu, I uninstalled microsoft office 97 and now rich text is gone.

    I have done this CMD as admin then pasted this reg add "HKEY_CLASSES_ROOT\.rtf\Word.RTF.8\ShellNew" /v Filename /t reg_sz /d Document.rtf

    hit enter and it asked if i wanted to do this i put y and hit enter, and it returned to the command line.

    I also made a registry file,

    Windows Registry Editor Version 5.00reg add "HKEY_CLASSES_ROOT\.rtf\Word.RTF.8\ShellNew" /v Filename /t reg_sz /d Document.rtf

    I ran it and again it said it added the new registry key, I have rebooted like 10 times, and still no rich text on the right click context menu.

    I went to the registry location and rtf\word,rtf,8\shellnew value (default) REG_SZ (value not set)
    second value Filename REG_SZ Document.rtf


    text document is there but not rich text.

    At this point I am stumped

    this is a really old thread I hope someone will answer.
      My Computer

  10. Posts : 54,354
    Windows 10 Home x64

    Welcome to Seven Forums Do you see a .rtf file in %SystemRoot%\ShellNew ? If not, you can create one by opening Wordpad and creating a empty rtf file by saving the file to desktop as Document.rtf, then saving the Document.rtf to %SystemRoot%\ShellNew . If still no shortcut, run the reg file again after

    Windows Registry Editor Version 5.00[HKEY_CLASSES_ROOT\.rtf\Word.RTF.8\ShellNew]"filename"="Document.rtf"

    Or, if no joy, this small tool should also work

    ShellNewHandler download | SourceForge.net

    Good luck

    A Guy
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:16.
Find Us