Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: all cpu meter

10 Feb 2016   #11

Windows® 7 (64-bit)

(3 years and 3 months later)

Despite the length of time that passed since the last post in this thread, I just had this problem myself, which means it's still possible to have it, and I did solve it, so since this thread was never resolved, I'll post the solution for the benefit of those coming here as a result of their Google search results, as I did. One thing though: your situation may not be the same as mine, so my solution may not work for you, but it's certainly worth a shot. And for those who recognize their own situation here, it's a pretty safe bet this'll fix it.

In my case the situation was simply this : I had switched motherboards. If you're inclined to think "what does that have to do with anything" keep reading, it had everything to do with it. Upgraded the CPU as well, but that doesn't figure into this—the motherboard thing absolutely does. Specifics are :

Before :   H81 chipset mobo (from lenovo®-branded system) w/Core™ i3-4130 @3.40  GHz CPU
   After :
    H97 chipset mobo (Gigabyte™) w/Core™ i5-4690 @3.50  GHz CPU

With the "Before" setup, I had been using All CPU Meter and GPU Meter, latest version of each one, both from And I had been using them with PC Meter so that I could see the temperature of each of the 4 cores on the CPU gadget as well as the GPU core temp on the GPU gadget. This setup had worked flawlessly for just over a year.

When I upgraded to the "After" setup, I was hoping I wouldn't have to reinstall Windows (or all my programs) because of the fact the Before & After mobo chipsets were compatible, so I knew there was a good chance I could just drop my HDD into the new setup "as is" and boot successfully from it, and this is indeed what happened. So new motherboard & CPU but same hard drive, which means same OS (Windows®7 Professional 64-bit) and all my programs intact—including the gadgets and PC Meter of course.

However, I found that with the new setup, all of a sudden the two gadgets didn't want to play nice with PC Meter anymore, insisting it was not running, even though it absolutely was. Keep in mind no options were changed, the gadgets still set to show temperatures by handshaking with PC Meter, as always.
(fast forward past most of the tinkering, all of the Googling, and half a nervous breakdown, and jumping directly to the pre-fix and fix, as I can already see this post is going to be more than double what I had anticipated)
At one point in my tinkering I changed the Options   >    Select Method setting in GPU Meter from PC Meter to Standalone, not even sure why anymore, but after hitting [ OK ], holy sh*t !… GPU Meter showing core clock temperature of 32°C ! Then I considered what that really meant :  I had told GPU Meter to disengage from PC Meter, to ignore it completely, and instead of continuing to not show temperature, it had had the opposite effect and was now showing it… but where was the gadget getting the info from?

There was really only one possibility :  I knew the new motherboard had settings relating to temperature, and while I hadn't yet set them any one specific way, it seemed reasonable to assume the mobo was feeding temperature info to the gadget (or possibly the graphics card—this is still GPU Meter I'm talking about—although the very same graphics card wasn't able to do that when plugged into the old motherboard) and it looked like asking the gadget to get that info from anywhere else was, um, confusing it.  

That took care of the GPU Meter problem … on to All CPU Meter. I opened its settings and looked at Options   >    Show CPU temperatures, which was set to ON (PC Meter). Here there was no "standalone" option though … the other two options were OFF and ON (Core Temp). I knew what Core Temp was but didn't have it installed, and in any case I figured "off" was roughly the equivalent of "standalone" in the other gadget, which had worked, so I set it to OFF, clicked [ OK ], and …
(fast forward past a lengthy series of very bad words and jumping directly to about 5 seconds after I regained my composure)
So that didn't work, despite the rough equivalent working in GPU Meter. The only other option for All CPU Meter was ON (Core Temp), so I figured I had nothing to lose and went ahead and downloaded/installed it, without much hope but what the hell, ran it, and …
(fast forward past another lengthy series of very bad words, but this time the mood was a weird combination of a "Yes ! Victory at last! Hahahahahahaaa!" feeling mixed in with an equal dose of "F*ck you m*therf*ckerrrrrrrrrr !" (it is unclear who I was addressing, or why I was still p*ssed off for that matter) and jumping directly to about 5 seconds after I regained my composure again)
So in a nutshell :

Because the new mobo had temperature features which the old one definitely did not have, I had to switch to "standalone" mode in the case of GPU Meter and switch All CPU Meter from PC Meter over to Core Temp, and these measures solved it. Finally. Why All CPU Meter works with Core Temp and not with PC Meter with this motherboard I can't say, since neither has been updated since 2013.

During the research phase, I noticed that most of the thread-starters complaining about this problem were doing so because, for example, they had switched to Windows 10 or something like that … assuming, in other words, that it was a software issue, and understandably so. But I think at least some of those were maybe really having a hardware issue, like those who switched their OS as a result of a hardware upgrade (new motherboard) or the purchase of a new computer altogether.

If on the other hand the problem started without having changed the motherboard, it might have something to do with a change in BIOS relating to temperature settings. Try to think if you were tinkering with your BIOS around the same time the problem started, like maybe you flashed a new BIOS and neglected to carry the same temperature settings over to the new BIOS.

All in all, if you've tried everything at the software level to no avail, start thinking hardware, especially BIOS.

The end finally.  

My System SpecsSystem Spec

 all cpu meter

Thread Tools

Similar help and support threads
Thread Forum
Battery meter (only) not updating
I have recently installed a new battery on my 5+ year old hp compaq laptop. I'm not entirely sure, but assume the behaviour with the battery meter started then, though there have been some windows updates since then as well. The battery meter does not update (anything - charging status /...
Performance & Maintenance
1 meter or 2 meter led strip ?
I`m guessing for the money, a 2 meter strip would be best ? NZXT Premium Sleeved LED Kit (2 meter) - White at Xoxide!
PC Custom Builds and Overclocking
Battery Meter
Have a 1 year old Dell notebook. Just noticed that the battery meter is showing that it's only 49% charged. It shows that it's charging, but from time to time I would check how much and it only shows 49%. How can I correct this problem. Thanks
General Discussion
Gadgets problems: All cpu meter, network meter and ilMeteo not work!
Hello! I also have problems with this gadget. I install it, but do not charge anything. It remains a white box that shows the following thing: <! . It is not the only gadget I have problems with: Network meter also does not load and shows the same thing: <! . Another gadget that I have problems...
DU Meter log file
Does anyone know where to find the DU Meter log file? I've checked C:\ProgramData\Hagel Technologies\DU Meter and in C:\Users\Username\Appdata but I can't find anything.
Network & Sharing
CPU Meter show 100%
I am using the CPU Meter gadget on my desktop. My system seems to "freeze" a lot and I notice that when that happens my CPU Meter is show 100% usage. I quickly start task manager but it does not show any tasks usisng that much CPU. I am using 32bit Windows 7 Ultimate Evaluation copy Build...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App