Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: [HELP] Internet Explorer 10 doesn't work with some custom shell32.dll

25 Dec 2014   #1

Windows 7 Ultimate x64
[HELP] Internet Explorer 10 doesn't work with some custom shell32.dll

I've modified the icons in my shell32.dll using Resource Hacker and when I've applied it Internet Explorer fails to start. It gives an error which reads,

"iexplore.exe - Entry Point Not Found"
The procedure entry point
shell32.SetCurrentProcessExplicitAppUserModeID could not be located in the dynamic link library api-ms-win-downlevel-shell32-l1-1-0.dll."

When I revert back to my previous shell32.dll which is also custom one, IE10 is working fine, so I think it is Resource Hacker that is causing this problem. I've tried modifying shell32.dll using Restorator 2007 but it gives me an error with "corrupt icon resource." I don't know what else to use to modify shell32.dll that won't make any problem with IE10. Any solution or suggestion would be greatly appreciated.

My System SpecsSystem Spec
25 Dec 2014   #2

Windows 7 Home Premium x64

I assume you're running ResHack as admin, but do you have ownership of shell32.dll? That might be problem, I assume.
My System SpecsSystem Spec
25 Dec 2014   #3

Windows 7 Ultimate x64

I'm running it as administrator and I have already taken ownership of shell32.dll hence I was able to replace it. It's just that IE10 wouldn't work with my modified shell32.dll but it works with other custom shell32.dll that I've downloaded.
My System SpecsSystem Spec

28 Dec 2014   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

It does appear to be an issue with how Resource Hacker changes the resources (some have the same issue with 7tsp installs).

IE10 A Bit Of A No Go For Me

However, most have no issue with Restorator, and your error changes, so I think you have a different issue with that. Sorry, no fix as you are the 1st that I have seen having issues with Restorator.

A Guy
My System SpecsSystem Spec

 [HELP] Internet Explorer 10 doesn't work with some custom shell32.dll

Thread Tools

Similar help and support threads
Thread Forum
Netflix doesn't work on Windows 7 Internet Explorer
Symptom: Netflix movie thumbnails (including their links) don't show up. There's one "dash" per row in their place that turns into finger on mouseover but doesn't do anything. However you still see the arrow navigation controls with "page indicator". Works on Chrome. Failed attempts to...
Installed an SSD on custom pc, explorer.exe error & start menu no work
Just tried installing an Kingston SSD on my computer. Everything worked fine but I tried to switch data from my original HDD over to SDD and successfully did so. Noticed after that my HDD became labeled (E:/) and was mentioned twice on the list. Then I started to have problems a while after. None...
General Discussion
Can shell32.dll remove explorer toolbar using custom classic theme?
I've tried this tutorial, and I still can't remove the explorer toolbar. I use a customized windows classic theme, and I think this might be the reason its not working for me. So, I found another thread with this post and I'm thinking of trying to edit the shell32.dll and see if this method...
View downloads doesn't work-Internet Explorer 9
neither ctrl +j does. Even if i download a file and press "view more" (or sth like that sorry i dont have english windows ) nothing happens. -Ive tried reseting ie 9 -deleting all personal data(cookies ,etc) -deleting all files in "appdata/internet explorer -unistalling and installing again...
Browsers & Mail
shell32.dll Problem : Windows 7 x64 custom theme
Hello, Im having a problem modifying shell32.dll on windows 7 x64. On 32 bit windows it was simple, just replace the shell32.dll in windows \system32 and restart. Im trying to modify the control panel side bar (with res hacker). I replace the resources in both windows/system32/shell32.dll and ...
Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:00.
Twitter Facebook Google+