Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fn+f5/Fn+f6 not functioning proper in Win-7 Ultimate 64bit.

21 Sep 2010   #1
worldsdream

Windows 7 Ultimate x64
 
 
Fn+f5/Fn+f6 not functioning proper in Win-7 Ultimate 64bit.

Hi guys/girls. I am facing a problem for like 5 months. I searched so much about it. But i couldnt reproduce the problem. So i am very gladfull to the person that can fix and help me out of this problem. I will never forget you!!!!!

Sony Vaio VGN-NW21MF
Windows 7 Ultimate 64 bit
Windows updated to the latest 22-09-2010


The Brightness Control isn't working. When i hit FN+F5 or F6.
When i hit it FN+F6 i see this:
http://img40.imageshack.us/img40/252/vaioi.png

It doesnt go more up. And the screen brightness stays the same. I think the brightness is on 100 procent.

When i hit Windows+X i see this:
http://img10.imageshack.us/img10/6788/17001413.png

There is no Brightness section?

Where is my problem? I did all driver reinstall. In my hardware manage i dont have any yellow question marks. in msconfig and services.msc all the process are activated. sony event service and all. Am i missing something?

Somebody please help me.


My System SpecsSystem Spec
.
24 Sep 2010   #2
worldsdream

Windows 7 Ultimate x64
 
 

ok nobody knows.
My System SpecsSystem Spec
25 Sep 2010   #3
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by worldsdream View Post
ok nobody knows.
Hi worldsdream , sorry But I have only just seen your post , Have a look at this thread post #2 'Fn+f6'/'Fn+f5'not functioning proper in Win-7 HomePremium 32bit. ,It contains links to drivers and more info to help you solve your problem
My System SpecsSystem Spec
.

25 Sep 2010   #4
worldsdream

Windows 7 Ultimate x64
 
 

pebbly, thanks for your comment. i have looked there and installed first 2.2 and then 4.0 version. rebooted after each install. didnt had any effects. the keys still doesnt work and the brightness still dont show up in mobility center. i even downloaded sony update manager. so it downloads all the latest software. rebooted after. still the same with the keys for brightness (f5 + f6)

i have an ATI mobility radeon HD 4570.

edit: Brightness Issue with Sony Vaio VGN-CS36GJ

got the same problem as me. he did a nvida driver update and it worked for him. but i dont have nvidia. i got an ATI card. i reinstalled my ATI graphic card software and still the same problem.
My System SpecsSystem Spec
26 Sep 2010   #5
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by worldsdream View Post
pebbly, thanks for your comment. i have looked there and installed first 2.2 and then 4.0 version. rebooted after each install. didnt had any effects. the keys still doesnt work and the brightness still dont show up in mobility center. i even downloaded sony update manager. so it downloads all the latest software. rebooted after. still the same with the keys for brightness (f5 + f6)

i have an ATI mobility radeon HD 4570.

edit: Brightness Issue with Sony Vaio VGN-CS36GJ

got the same problem as me. he did a nvida driver update and it worked for him. but i dont have nvidia. i got an ATI card. i reinstalled my ATI graphic card software and still the same problem.
worldsdream, Done a little research on this for you In order for the keys to function correctly you have to install the Sony software in the correct order-
1- Sony shared library
2- Setting utility series
3- Vaio event service
4- Vaio control centre
hope that helps you
My System SpecsSystem Spec
26 Sep 2010   #6
worldsdream

Windows 7 Ultimate x64
 
 

pebbly, did that several times.

i searched much after this issue before. but i never could find the steps to fix this problem. so i left it.
the last months i had it busy with my windows/linux servers and cisco routers. i didnt had time for windows 7 problems. windows servers and routers have more problems then windows xp/vista/7 clients. thats why.
today i sat behind my laptop and i was looking into this issue. you know why? because you PEBBLY are very kind to help me for this problem.

so i fixed it. how i fixed it:

- go to software and delete everything from ATI
- delete everything from ATI in regedit
- uninstall ATI driver from hardware in device and settings.(your monitor resolution will be 800x600. its normal)
- reboot.

then go to: Graphics Drivers & Software
select: notebook graphics / mobility radeon series / HD 4xxx series and select your OS. (ofcourse you need to select what relevant is for your graphic card, i am just telling what i selected)
install it. reboot. thats all. enjoy your brightness working keys FN+F5/FN+F6 and if you press Windows + X, you see brightness to adjust. even if you go to configuration and select the battery. you will see brightness in the bottom to adjust.

i hope i helped you all if you are having the same problem.
My System SpecsSystem Spec
27 Sep 2010   #7
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by worldsdream View Post
pebbly, did that several times.

i searched much after this issue before. but i never could find the steps to fix this problem. so i left it.
the last months i had it busy with my windows/linux servers and cisco routers. i didnt had time for windows 7 problems. windows servers and routers have more problems then windows xp/vista/7 clients. thats why.
today i sat behind my laptop and i was looking into this issue. you know why? because you PEBBLY are very kind to help me for this problem.

so i fixed it. how i fixed it:

- go to software and delete everything from ATI
- delete everything from ATI in regedit
- uninstall ATI driver from hardware in device and settings.(your monitor resolution will be 800x600. its normal)
- reboot.

then go to: Graphics Drivers & Software
select: notebook graphics / mobility radeon series / HD 4xxx series and select your OS. (ofcourse you need to select what relevant is for your graphic card, i am just telling what i selected)
install it. reboot. thats all. enjoy your brightness working keys FN+F5/FN+F6 and if you press Windows + X, you see brightness to adjust. even if you go to configuration and select the battery. you will see brightness in the bottom to adjust.

i hope i helped you all if you are having the same problem.
worldsdream, thank you for posting how you fixed the problem , I will ask for this to be marked solved
My System SpecsSystem Spec
03 Apr 2011   #8
ankit2

window 7 professional , 32 bit
 
 

Dear Pebby and worldsdream,
I have exactly the same problem (as described by worldsdream) with my sony vaio laptop (Window 7 professional, 32 bit). I got this problem after my computer was crashed and i reinstalled everything. I downloaded all the drivers but it did not help. I am struggling for several days on this problem, but still no solution. Could you please help me in this regard?

Regards,
Ankit
My System SpecsSystem Spec
Reply

 Fn+f5/Fn+f6 not functioning proper in Win-7 Ultimate 64bit.




Thread Tools




Similar help and support threads
Thread Forum
Help Pls! Upgrade from 32 bit Win 7 Ultimate to 64bit Win 7 Ultimate
Hi, My laptop config is as follows: Win7 32 Ultimate on Acer Aspire 4730z 2GB Ram, 2.2 Ghz Dual Core...and 320 GB Space I want to install windows 7 64 bit ultimate version on my laptop which currently has 32 bit win 7 ultimate version. Is it possible to install 64 bit ultimate version as...
Installation & Setup
Trouble installing W7 64bit HP, message "reboot and select proper boot
Hello, I am currently building my first computer and the message appears when I try to install Windows 7 64bit Home Premium. "reboot and select proper boot device or insert boot media in selected boot device and press a key" I have set my DVD drive as 1st in the boot order. I have checked...
Installation & Setup
Intel 82865G Not Functioning Properly in Windows 7 Ultimate (32-bit)
Hi, I am Abdul Basit from Pakistan, I recently bought a new Pentium 4 PC (about 6 months ago) from now, and it had Windows XP SP2 installed, A cousin of mine suggested me to install Windows 7, because it's faster than Vista and XP, Therefore I did a clean install of Windows 7 Ultimate 32-bit by...
Graphic Cards
'Fn+f6'/'Fn+f5'not functioning proper in Win-7 HomePremium 32bit.
Hi Guys!I will be very thankful to you if u can solve my recently faced problem.I am using a SONY VAIO VGN-CS36GJ,which was initially provided with Windows Vista Home Premium(64bit).Recently i have installed Windows 7 Home Premium (32-bit) OS.I have download and installed all the required drivers...
Drivers
Upgrading from Windows ultimate 32bit to Ultimate 64bit
Can I upgrade from Windows ultimate 32bit ver 6.1 ( build 7600) to windows 7 ultimate 64bit edition and keep all of my installed programs and files ? :huh:
Installation & Setup
Win 7 ultimate 32 bit & 64bit
Want to know if I can install both win 7 32 bit and 64 bit on the same drive, or do i need to use partition magic to create a second partition and install the 64bit afterwards. Want to have the 2 system, because some games don't run good in 64bit mode Thanks
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App