Belkin Usb wireless driver  

Page 4 of 6 FirstFirst ... 23456 LastLast

  1. Posts : 3
    Win7
       #31

    Wouldn't that require a working internet connection on that computer? I'm accessing the forums on a differnet laptop.
      My Computer


  2. Posts : 5
    Windows 7/XP/Linux
       #32

    I am currently using version 3 with no problems. This is the version: f5d7050v3_ww_03.00.02_w2

    I have used builds 7000 and 7100 and with no problems since I found the right version. I did originally have install issues but I just kept trying different versions.

    I recently did a clean install of the 7100 and no hitch with this driver.

    I hope you get this figured out, I wish I could help further.

    Here is a link to the driver download and to verify the correct driver is used for the FCC code.

    Belkin
      My Computer


  3. Posts : 995
    XP/win7 x86 build 7127
       #33

    dbennettt said:
    Wouldn't that require a working internet connection on that computer? I'm accessing the forums on a differnet laptop.
    well, its the usb belkin G right? Then plug it up to the laptop with a connection, and then do those following steps
      My Computer


  4. Posts : 7
    Windows 7 RC
       #34

    I have this wireless adapter and I was able to get it working, but I don't remember all the steps, but it included a lot of trial and error. Now, with Build 7100, I can see wireless networks, but I cannot connect to mine. It starts chugging along and then the initial dialogue box closes, and soon after another appears, saying the ever informative "Could not connect to <ESSID> ". Ive been messing with it all day but havent been able to get it up and working. It is both hidden and WPA2 secured if that matters, but the data for both has been entered correctly.
    Thanks in advance.
      My Computer


  5. Posts : 5
    Windows 7/XP/Linux
       #35

    carickw,

    Just a thought, have you tried connecting without security, just to see if it would connect then?
      My Computer


  6. Posts : 995
    XP/win7 x86 build 7127
       #36

    currently I am using the XP (SP2) comp mode /driver.... named BLKWGU.sys. This is hit and miss, still have a few d/c problems. Best mode i have found is Vista SP2 comp mode. This installs a driver named athrusb.sys. Tho when win7 attempts to download and install the driver itself, it installs the exact same athrusb.sys, but that version is horrible and has a different Driver Date than the Vista SP2 driver does.


    *edit: *correction
      My Computer


  7. Posts : 7
    Windows 7 x64, Vista x32, Ubuntu 8.10, XP
       #37

    I installed today a belkin usb F5D7050 with the drivers on the cd and Im working it with no problems at all.. even managed to enable ICS with it.
    The only problem is that the utility doesnt even exist on my system and I cant get it to install, and w7 only seems to be able to use WEP encryption.. theres no option at all for WPA. To further check this, I created an adhoc on my Vista machine with WPA, and sure enough w7 could see it but would give an error when trying to connect "cannot connect due to hardware limitations" or something in the lines of that, which leads me to believe that belkins drivers (at least for x64) are a bit incomplete.

    for those interested, I dont know the setups name as its simply "setup.exe" on the cd so I dont know the exact version, although the drivers date is 2/4/2008, relatively new.
      My Computer


  8. Posts : 5
    Windows 7/XP/Linux
       #38

    Manic, sorry about the issues you are describing but I will let you know that I have only used the 64bit version of Window 7 and have succesfully been using the Belkin G USB adaptor. I would suggest uninstalling the driver that you installed from the CD, unhook the adaptor, download the appropriate driver from the Belkin website, and following the instructions if they give them to you. Usually you will not connect the USB adaptor until the installation prompts you to or it may cause an error.

    Hopefully this helps, if not then keep asking and you will certainly be succuesful!
      My Computer


  9. Posts : 7
    Windows 7 x64, Vista x32, Ubuntu 8.10, XP
       #39

    im pretty sure i first tried with one from their website but it wouldnt work.. ah well :dives into another rabbit hole:

    ;p
    thnx for the quick reply though
      My Computer


  10. Posts : 7
    Windows 7 x64, Vista x32, Ubuntu 8.10, XP
       #40

    Ok I downloaded the one on their website (f5d7050v4010setup) and its actually older than the one on the cd! (29/01/2007). before installing it I completely removed the previous driver and software and then proceded with the new ones, but I still cant get the belkin utility to work (not that I particularly care) and theres still nothing more than WEP available when setting up adhoc networks :/

    which driver are you running Timbu?
      My Computer


 
Page 4 of 6 FirstFirst ... 23456 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:06.
Find Us