Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows doesn't install new USB devices

13 Oct 2010   #21
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

no system re-installation wont invalidate when i had blue screen probs i done mine about 6 times till i decided enough was enough and sent it back and it turned out to be a update in bios was required


My System SpecsSystem Spec
.
13 Oct 2010   #22
Difusal

Windows 7 Ultimate x64
 
 

alright, found this:
http://www.windowsreference.com/wind...vice-in-vista/

they mention infcache.1, that might be my prolem
My System SpecsSystem Spec
14 Oct 2010   #23
Difusal

Windows 7 Ultimate x64
 
 

please anyone help me? tried to delete the infcache.1 but no result...
also, I did this:

Open Regedit

Change HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
\DevicePath to '%SystemRoot%\System32'



also.. no results
My System SpecsSystem Spec
.

14 Oct 2010   #24
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

hi i think you should try system restore
My System SpecsSystem Spec
14 Oct 2010   #25
Difusal

Windows 7 Ultimate x64
 
 

lol I tried that, I restored my system to the oldest point I had! nothing changed...
My System SpecsSystem Spec
14 Oct 2010   #26
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

have you put the windows disk in ?
My System SpecsSystem Spec
14 Oct 2010   #27
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

System Recovery Options[2]=Performance%20Maintenance
My System SpecsSystem Spec
14 Oct 2010   #28
Difusal

Windows 7 Ultimate x64
 
 

HAHAAHAHAHAH FINALLY GUYS!!! I finally solved my problem! And no, I didn't need to re-install my Windows. As I thought, there had to be a way to solve this in a very easy way!

Finally I don't see this message again:

Windows found driver software for your device but encountered an error while attempting to install it.



Here's the solution for the ones who might have this problem:
This worked for me in Windows 7 Ultimate 64bit!
You must have all administrator privileges!


1- Open Windows Explorer

2- Go to C:/Windows/System32/DriverStore

You will have a couple of folders and files.
You will have *.dat files and other file named: infcache.1

3- Right click every file (dont touch the folders!) and choose properties.

4- go to security tab

5- click Edit

6- choose your account and check the box: full control (see ss)

7- Click ok.

8- Repeat to every file

9- Select all the files (*.dat and infcache.1)

10- Press shift+del

11- Press OK.

12- Now, go to C:Windows/System32/Driver Store/File Repository/

13- Search for folder named usbstor.inf

14- Open it (if you have more than one, choose the most recent)

15- Copy "usbstor.inf" and "usbstor.PNF"

16- Paste those two files to C:/Windows/inf

17- Reboot your pc and voilla! :b

If Windows doesnt install them automatically go to device manager, uninstall all unknown devices and the ones with the yellow exclamation mark, then click in "check to see if there is any hardware changes"

Now, Windows will install all your hardware successfully :b


Thank you all who tried to help me I'm really really happy now xD

P.S.- There should be a fix for this problem as it is a big fail in Windows system


Attached Thumbnails
Windows doesn't install new USB devices-sem-titulo.png  
My System SpecsSystem Spec
14 Oct 2010   #29
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

well done why did it happen in the first place?
My System SpecsSystem Spec
14 Oct 2010   #30
Difusal

Windows 7 Ultimate x64
 
 

I have no idea xD doesn't matter now... How do I close the thread?
My System SpecsSystem Spec
Reply

 Windows doesn't install new USB devices




Thread Tools




Similar help and support threads
Thread Forum
Bluetooth doesn't find devices
Hey guys, I have an Acer Aspire V3, running Windows 7 SP1 x64, with internal bluetooth. I tried with the standard Generic Bluetooth Adapter and also with the Atheros_7.4.0.126 Bluetooth Adapter which comes with the driver-package of my laptop. I checked that the Bluetooth Service is...
Hardware & Devices
Windows 7 doesn't want to install
Hi, i bought W7 some time ago but I havent got it working and one of my friends said that this is the best place for help. Thats what usually happens: I put in W7 dvd and make a restart to boot it. When my computer sais press any key to boot i press enter and everything goes like it should. It...
Installation & Setup
Bluetooth doesn't search for devices
Hey guys.My Dell Inspiron Mini 1018 doesn't search for devices after i click send to ->bluetooth device.When the Bluetooth File Transfer opened,it doesn't search for device and just leave it a blank.Just like this picture.I had reinstall the driver but it doesn't work.Please help me if you know...
Hardware & Devices
Error USB Remove Safely Icon doesn't show the devices, just 3 dots
When I click in the Notification area icon to remove USB, the devices don't appear. And, if I can't use the rundll32 shell32.dll,Control_RunDLL hotplug.dll Many Thanks
Hardware & Devices
Windows doesn't detect any audio devices: no sound
Hello, my name is Conan. I have installed Windows 7(Ultimate, 64-bits) in 2009, my previous os was Windows XP(32-bit). Although I am really happy with W7 there's something which is a big turn-off. The sound, that is, it hasn't worked on W7 ever since I installed it. It's not the devices that...
Sound & Audio
My PC doesn't like new USB devices...
I upgraded to Win7 the day after it's release, from WinXP. Did a new install. Things have worked just fine for me after that, except for a driver that I needed to update in the first couple of days (HP scanner didn't get recognized, but update was released a day or two later and all was good...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App