Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ethernet controller exclamation mark

18 Jan 2011   #1
boien

windows 7 64 bit
 
 
ethernet controller exclamation mark

Im having problems wiht my "ethernet conntroller" under "other devices" in my device manager, I see a yellow exclamation next to it. Last time i formatted my machine (this one) I was able to find the driver, although it was a hassle and chase for it. My mb is a "Gigabyte EP45-DS3L". I have downloaded all kinds of drivers for it which seemed to fix another issue, but i just cant seem to get the right driver for the "ethernet controller" to get recognized. Ive installed a few "hardware detection" software programs and I was able to get the mb model at least, and if i remember correctly this boards drivers used the intel chipset but since im not online with it it wont tell me what chipset it is. For some reason I just cant find the correct drivers for this damn controller. Is this is a motherboard/hardware issue? Is this still a software fixable thing? Can someone help me out please?

Thanks
-boien


My System SpecsSystem Spec
.
18 Jan 2011   #2
LiquidSnak

W7 Professional x64
 
 

What "hardware detection" programs have you installed?

GA-EP45-DS3L (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - Driver

Here is the driver, select the download site for LAN, the "Realtek Realtek LAN Driver," that is closest to you.
My System SpecsSystem Spec
18 Jan 2011   #3
boien

windows 7 64 bit
 
 

What If I just installed those drivers and I still see the yellow exclamation? I'm goin to try and just reformat it after but I wanted to try one last thing before I took that step.
My System SpecsSystem Spec
.

19 Jan 2011   #4
sreedhav

MS Windows 7 Home Premium 64-bit SP1
 
 

DEAR boien,
Welcome and you have put two probs. before us! 1) Ethernet Controller (E-C) per se is a chip in the MB and thus strictly speaking is HARDWARE,but the SOFTWARE needed to make it operable is the E-C Driver,as suggested by @[B]liquidsnack! Thusly to solve the riddle, you may (in fact ,must) install the driver on offer and 2) IF the yellow exclamation mark still persists,two possibilities persist.A) The driver was not compatible and/or the hardware "might" have been affected by issues like power probs. and/or your E-C driver has married some malware, b'cause your E-C seems to be affected quite frequently!

So check for Virus,Rootkits and Trojans with the appropriate software!Ideally the MB website (i do not know much about "Gigabyte") will be having the updated and/or the appropriate drivers.I have had many probs. while trying to download drivers from third party sites and you please keep that as your last option! HAVE YOU VISITED THE MB'S SITE AND LOOKED FOR THE DRIVER? Very sorry for the bold type, it was purely for emphasis! If it were i, since i downloaded drivers from so many third party sites,my first focus will be to identify and root out malware as mentioned above!BECAUSE,your drivers will be hit again and again! All said and done, kindly install the driver first, identify any infection next and if it's a Rootkt then i am on your side about formatting!

Please let us know how it all went off! Cheer up Dragon-slayer, we are with you!

regards,
DR.Sreedhav
My System SpecsSystem Spec
19 Jan 2011   #5
boien

windows 7 64 bit
 
 

The hardware detection software I tried was CPUz, driver agent, and driver update, they all told me the same thing about my motherboard. It looks like the LAN driver link is the one that usually worked when I reformatted earlier times, but I'm still seeing the exclamation. Thus is really strange, now I'm strting to think that I could have some malware or Trojans eating up those drivers or something. What spyware/malware/ Trojan antivirus or malware apps would you guys suggest for me even though I can't get online? I tried out avg but that needs an Internet connection to even begin the installation process so that was a dead end.
My System SpecsSystem Spec
19 Jan 2011   #6
sreedhav

MS Windows 7 Home Premium 64-bit SP1
 
 

I should have mentioned those apps.,in the previous post! Anyway,here we go: SUPER ANTI SPYWARE. site to download : SUPERAntiSpyware.com | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware! MBAM--------------------------------->malwarebytes.org IOBIT MALWARE FIGHTER(BETA)-----> |MG| IObit Malware Fighter 1.0 BETA Download Rootkits are a double menace because at times a simple formatting may not completely remove all of them! IMO, the procedure should be A) Identify their presence using at least TWO ANTI ROOTKITS 1)GMER : GMER - Rootkit Detector and Remover As you can see in the downloaded page, any RED entries indicate Rootkits. 2)SOPHOS (you have the advantage here of identifying and "removing"(?) them Sophos Anti-Rootkit - Free Rootkit Detection and Removal Tool .A lot of personal details are asked from unwary entrants, unless you pick and tick that it's for "home use". I do not think Sysinternal's anti rootkit works on Win.7 platform. 2) "erase the HD" with Active Kill disk (free ,single pass,very effective and quite fast). Website to download : Active@ Kill Disk - Hard Drive Eraser - Free software downloads and software reviews - CNET Download.com B) Then partition and format. I prefer to do the partitioning personally, according to my taste and thus do not use any partition Manager. EASEUS website has a free and excellent P-M! Thus my "SOLILOQUY" ( A dramatic or literary form of discourse in which a character talks to himself or reveals his thoughts without addressing a listener.&quot ends, Regards, sreedhav
My System SpecsSystem Spec
20 Jan 2011   #7
boien

windows 7 64 bit
 
 

So I ran the superantispyware and both of the root kits that you linked. Fortunately no results on the spyware software or the root kit app any root kit or spyware detected. This is the second time I have formatted and I'm starting to think that its having something to do with the motherboard now. Is there any way I can test out if the mother board hardwaree is messed up now or did these few tests and elimination processes just determine that?

Thanks,
Stumped
My System SpecsSystem Spec
20 Jan 2011   #8
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Here's an idea. Along with the Ethernet driver there is a Realtek Ethernet controller diagnostic tool. You can run it and hopefully it will give you an idea of what's going on.

Here it is already scanned with MSE no problems found. mb_driver_lan_realtek_rtltool.zip

Secondly you can try going to device manager>clicking in the device>properties>drop down menu>select hardware ID>Copy and Paste the hardware Id string and we can look for a driver for you that way.

If the Realtek driver provided above installs yet you still have the exclamation point it's probably because the controller is bad, but running the file I provided should test it and you'll find out.

Also please go to your User cp top of the page, scroll down on the right to edit system specs and fill in all your system specs.

If you need a program to help you with that you can use one of these Speccy - Download

Or this one |MG| HWiNFO32 3.67 Download
Thanks. Fabe


My System SpecsSystem Spec
20 Jan 2011   #9
sreedhav

MS Windows 7 Home Premium 64-bit SP1
 
 

Quote   Quote: Originally Posted by thefabe View Post
Here's an idea. Along with the Ethernet driver there is a Realtek Ethernet controller diagnostic tool. You can run it and hopefully it will give you an idea of what's going on.

Here it is already scanned with MSE no problems found. Attachment 133188

Secondly you can try going to device manager>clicking in the device>properties>drop down menu>select hardware ID>Copy and Paste the hardware Id string and we can look for a driver for you that way.

If the Realtek driver provided above installs yet you still have the exclamation point it's probably because the controller is bad, but running the file I provided should test it and you'll find out.

Also please go to your User cp top of the page, scroll down on the right to edit system specs and fill in all your system specs.

If you need a program to help you with that you can use one of these Speccy - Download

Or this one |MG| HWiNFO32 3.67 Download
Thanks. Fabe
Nice ideas! The prob.for the@OP is, he cannot connect to the net using his PC! I would rather suggest, that he use a pen drive ,go a cyber cafe ,download the driver you suggested along with UBCD : website : UBCD for Windows
My System SpecsSystem Spec
20 Jan 2011   #10
boien

windows 7 64 bit
 
 
screenshots

Hi guys. So i have filled out my cpu specs on the cp menu page. I did all of the steps with the diagnostic tools and I have taken several screenshots to do the rest of the talking for me. I figure it will explain more than just words. I have attached them to show you the results of each recommended rootkit/malware/diagnostic tool from you all. Btw I am online via wifi which is how ive been able to use the apps on my pc, its just my pc thats offline so im dl'ing apps from my lap and transfering/installing via flash drive.


Attached Thumbnails
ethernet controller exclamation mark-ethernet-diagnostic-tool-ss1.jpg   ethernet controller exclamation mark-hardware-ids-ss.jpg   ethernet controller exclamation mark-rootkit1-ss.jpg   ethernet controller exclamation mark-speccy-ss1.jpg   ethernet controller exclamation mark-speccy-ss2.jpg  

ethernet controller exclamation mark-superanti-ss.jpg  
My System SpecsSystem Spec
Reply

 ethernet controller exclamation mark




Thread Tools




Similar help and support threads
Thread Forum
An exclamation mark is shown on LAN/Wireless Network connection
Hi veryone! No internet access while using local Area connection, or wireless network connection, although someone else connects to the same modem router via his mobile phone. I have TP-link(300MBps) wireless N USB ADSL2 +Modem Router. ...
Network & Sharing
Yellow triangle with exclamation mark over network
Hello, First time posting here, but long time visitor. I have a bit of a problem with what i assume is a windows network issue. After I restart the pc, 9 times out of 10 i get a yellow triangle with an exclamation mark over my network icon. When i go over it, it says I'm connected to the...
Network & Sharing
Exclamation mark in yellow triangle
http://speccy.piriform.com/results/5OUPcYzXZDOcWOZsHOejYhH Gooday folks. I ran G Parted to check some thing about one of my hard drives and I noticed that the NTFS partition that has this windows7 installation on it has the above mentioned yellow triangle with exclamation mark in it. Could some...
General Discussion
Yellow triangle and exclamation mark.
The internet on my laptop has stopped working from time to time and a yellow triangle with an exclamation point goes on top of the internet icon on the bottom right. Now it has stopped working completely for about a week and hasnt come back like before. I use the same internet cord on my pc and...
Network & Sharing
Bluetooth Peripheral Device (yellow exclamation mark)
In device manager under "Other devices" there are 5 "Bluetooth Peripheral Device" with a yellow exclamation mark next to them. I have a Dell Inspiron 1420. How can I fix it? And why are there 5 of the same "Bluetooth Peripheral Device"? The only bluetooth device I use with my laptop is my Nokia N85.
Drivers
no audio and the device has an exclamation mark
Hi, I am new to the forum. I installed win xp on top of win 7 following instructions on the forum, on my Dell Inspiron 1520. I have restored all the drivers that I have backed up (I used to have win xp before win 7, I uninstalled it but backed up the drivers before formatting the win xp drive)....
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App