Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 - Belkin F5D8055 N Wireless USB Problem

05 Feb 2011   #1

Windows 7 Professional x64
Windows 7 - Belkin F5D8055 N Wireless USB Problem

hi guys.

So the thing is... i have a wireless USB N1 from Belkin (F5D8055 v.1).
He works well on Windows 7 Pro x64, except for one thing that always happened to me.
when i shut down the computer and i turn it back on after a while, the system doesnt show the USB adapter. I have to take it out of the USB door, and then put it back on so that windows can recognize it.

The weird thing is that if shut down the pc and 5 minutos later (random minute) i turn it back on it still recognizes it. However if i let much time pass... BAM problem.

i´m using the belkin x64 drivers and i have downloaded the newer drivers from belkin site... still no good.

Can anyone help me?

My board is a Asus ROG Rampage II Extreme.


My System SpecsSystem Spec
05 Feb 2011   #2
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16

I have the same type of adapter and have no issues on 64-bit.

Are you sure its not faulty?
My System SpecsSystem Spec
05 Feb 2011   #3

Windows 7 Professional x64

Quote   Quote: Originally Posted by Prof Kerfuffle View Post
I have the same type of adapter and have no issues on 64-bit.

Are you sure its not faulty?
No because i have another board (also Asus but not ROG) and it works fine :S
My System SpecsSystem Spec

19 Jun 2011   #4

Windows 7 Ultimate x86

I've been upgrading my Mother's PC to a Windows 7 machine and she is having the exact same issue with her Belkin F5D8055 V1. The adapter worked fine on her old XP machine.

I tried downloading and installing the latest drivers and it made no difference.

Did you ever get a resolution to this?
My System SpecsSystem Spec
19 Jun 2011   #5

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

I'm using that adapter (not sure about the version), but I've never had a problem with it being recognized. The machine that it is on is never shutdown long, but I do power it off overnight each day, and nothing like that has occurred. I don't know the solution, but I'm wondering if you installed the Belkin software for it, or are using Windows WiFi function?
My System SpecsSystem Spec
19 Jun 2011   #6

Windows 7 Home Premium 32bit, Vista Home 32bit, XP Home 32bit

Are you using custom USB chipset drivers?
Also, check if your computer turns off USB devices to save power (device manager -> Universal serial bus controllers -> USB root hub -> Power Management)
Your problem sounds like windows turns the device off, like safely remove hardware does.
My System SpecsSystem Spec

 Windows 7 - Belkin F5D8055 N Wireless USB Problem

Thread Tools

Similar help and support threads
Thread Forum
belkin n150 wireless router problem
hi guys i realy need help regarding this matter iam from asia philippines yeterday i bought a belkin n150 wireless router , i have installed and connect to wifi instanly then all of a sudden around 30mins of my connection i was disconnected when i click the lan icon on my laptop there are no...
Network & Sharing
BELKIN Wireless G Adapter Problem
Recently, i bought a new BELKIN wireless g adapter. The adapter keeps on dropping connection and i can't even download a 200mb file without it dropping. My friend has that adapter and somehow he made it work but he says it was like 2 years ago, he can't remember how he did it. Can anyone PLEASE say...
Network & Sharing
Belkin wireless adapter problem
Hi, I have recently purchased a belkin F6D4050 N150 Enhanced Wireless USB Network Adapter and installed the driver from belkins site. The adapter stays disabled regardless of me trying to enable it. I have been trying to solve this for days!! I have followed your instructions and the ones on the...
Network & Sharing
Belkin wireless problem
I'm using windows 7 64 bit and its working fine except one problem. I have a belkin fd8055 usb wireless adapter. It acts just like it did in vista 64 bit sp2 when it boots from a cold boot. While booting, the little internet strenth bars on the bottom right side start menu has a little blue hour...
Hardware & Devices
BELKIN Wireless G USB adapter Problem- again
Hi all members. I read alot topics on this forum to try solve my problem. I found in here 2 topics about Belkin Wireless G USB adapter , but still i have a problem I describe whats the problem . I try to instal on my Windows 7 x64 b.7000 drivers for belkin w g usb adapter f5d7050 I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:41.
Twitter Facebook Google+