Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Chipset Drivers

13 Feb 2011   #11
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Hi
Thanks for your reply.

I have downloaded the Chipset drivers from Gigabytes website and there are only 2 drivers which are showing as not currently installed. Should I install them?




Attached Thumbnails
Chipset Drivers-untitled.png  
My System SpecsSystem Spec
.
13 Feb 2011   #12
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

I'd say yes. I install all of the drivers for my motherboard from the manufacturer.

The AHCI driver is custom for your MB. Windows ships with it's own generic AHCI driver but it does not equal the one from the MB maker. One common problem with the Windows AHCI driver is that internal SATA drives show up as removable (external) devices.

As for USB Filter Driver - same deal - Gigabyte is probably offering it as an "enhancement" of the regular functions of the MB.
More Here: windows - What is an USB Filter Driver? - Super User
And since you are having an USB issue......
My System SpecsSystem Spec
13 Feb 2011   #13
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Hi,

Thanks for your reply.

I have installed the SATA / AHCI drivers and now the hard drives are showing as SATA in device manager where as before they were showing as ATA devices. So at least thats sorted out.


I also installed the USB Filter Drivers but this has not made any difference. I have also done a clean install of windows on another hard drive to check to see if its something to do with windows and also the memory stick does not work in the front usbs of the case but if I plug it into any other USB port it shows up pretty much instantly.
My System SpecsSystem Spec
.

13 Feb 2011   #14
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Then I think you are down to bad case ports or perhaps the USB header on the motherboard.

Check the connection of the case's USB ports to the USB header(s). Be sure they are orientated correctly and that the connector is pushed all the way in.

Is this a new PC case?
My System SpecsSystem Spec
13 Feb 2011   #15
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Hi

Thanks for your reply

I have changed the USB connections to another USB header on the board and the issue is still there.


Its an Antec 300 gaming case and the warranty is up next month on it.
My System SpecsSystem Spec
13 Feb 2011   #16
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

I had an Antec Sonata One case that had front case USB ports that were defective - running at USB 1.0 speed when it was supposed to be USB 2.0. Antec replaced the module without question or cost upon request, and the case was 3 years old. YMMV.

If you can get your hands on a spare known working USB module from another case you could do a test to determine if it is indeed the Front panel connector module or the motherboard. You could also Gerry-Rig a test with a USB device if you are handy with wires.
My System SpecsSystem Spec
13 Feb 2011   #17
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Hi,

I'll contact Antec and see what they say. Assume you contacted them through their site?
My System SpecsSystem Spec
13 Feb 2011   #18
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by wizkid View Post
I have installed the SATA / AHCI drivers
Now go to the AMD link I posted previously and get the latest versions of both, which will be much newer than the one from Gigabyte (from what I can see the one from Gigabyte looks to be from around the time of the Catalyst 9.12).

Quote:
I'll contact Antec and see what they say.
If they do like they did for me when I had a front panel go bad on one of their cases, they will issue the RMA for it and send you a new front panel assembly (took about a week and a half from start to finish for me, would have been quicker if I was in the States due to shipping to Canada). Start here,

Antec - Support Online

select your region and fill in the online forum. Just need your receipt.
My System SpecsSystem Spec
13 Feb 2011   #19
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Hi Stormy

Thanks for your reply.
I have installed the SATA / AHCI Drivers form AMD's website.

I will contact Antec and tell them what the issue is.
My System SpecsSystem Spec
13 Feb 2011   #20
wizkid

WINDOWS 7 HOME PREMIUM 64BIT
 
 

Sent a support request to Antec says they should reply within 48hours.

Its a odd issue because the memory stick in question will work in the front USBS of the case but just takes about 1-2 minutes to actually show up on the computer.
My System SpecsSystem Spec
Reply

 Chipset Drivers




Thread Tools




Similar help and support threads
Thread Forum
Need Intel Chipset drivers
so after installing my new system, i used the mbo CD instead of downloading the newest. now im trying to update. however i can not find intel z77 chipset drivers. i go to their website and plug everything in and it says 0 results found...? anyone know where i can get them? i also need their...
Drivers
AMD Drivers On An Intel Chipset (South Bridge & Chipset Drivers ?)
Hi, I think my chipset is Intel Pentium 4 CPU 2.93GHz and my motherboard is Gigabyte GA-8TRC410M-NF but when using Driver Genius to scan for driver updates it reports back AMD South Bridge Driver (PCI bus) & AMD Chipset Drivers (ATII/O Communications Processor SMBus Controller) need...
Drivers
Drivers for Intel 915 GAV chipset
Recently i had installed Windows 7 ultimate 32 bit but i m not able to install any of the drivers.Help me to resolve this issue.
Drivers
Chipset Drivers
Two questions 1. Does Windows 7 automatically install chipset drivers? 2. Which part of the device manager is the chipset?
Drivers
Why do I have chipset drivers when I don't use an nvidia chipset?
http://img806.imageshack.us/img806/4683/captureor.png I have GTX 460 with 258.96 drivers. I do not have an nVidia chipset. When I went to check the Driver Sweeper files, I found all these chipset files. Why do I have them?
Graphic Cards
Chipset Drivers for Motherboard Help!
ok so i was getting helped trying to get my driver for my video card. When i tried it said no driver found compatable for my hardware. i was told i need to install the chipset drivers for my motherboard first, Anyone able to help with this?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App