Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Scanner lost after OS change from XP to 7

14 Feb 2011   #1
Caplin

Windows 7 Ultimate x32
 
 
Scanner lost after OS change from XP to 7

My printer is a Canon PIXMA MX700 All-in-one connected through a router. My OS is Win7 Ultimate x32. The cd's included with the printer are pre-win7 (and they don't address a TWAIN driver anyway!?). A win7 driver were downloaded from Canon Support.
Printing and smart monitor are working fine, but scanning fails with a pop-up window "No TWAIN driver is installed"!
Looking at Canon Support/Drivers Download I cannot seem to find any referece to TWAIN drivers. Where is this and where can I get it. Any help much appreciated.





My System SpecsSystem Spec
.
14 Feb 2011   #2
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Try uninstalling printer and then downloading the current version of the software suite for windows 7 32 bit and installing that version.

Canon U.S.A. : Support & Drivers : PIXMA MX700
My System SpecsSystem Spec
15 Feb 2011   #3
Caplin

Windows 7 Ultimate x32
 
 

Quote   Quote: Originally Posted by bassfisher6522 View Post
Try uninstalling printer and then downloading the current version of the software suite for windows 7 32 bit and installing that version.

Canon U.S.A. : Support & Drivers : PIXMA MX700
Hi, couldn't find the "software suite for windows 7 32 bit" as a package on the Canon Support Site, but I installed the "Driver Addon Module 2.0" and the "MP Drivers for NW 1.01 from the site.
Now the Scanner was recognized but a popup window complained about the MP Navigator not being installed correctly.
After installing "MP Navigator EX for Windows 1.06" from the site everything works perfect.

Thanks for leading me in the right direction.
My System SpecsSystem Spec
.

16 Feb 2011   #4
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Glad you got it sorted out.
My System SpecsSystem Spec
Reply

 Scanner lost after OS change from XP to 7




Thread Tools




Similar help and support threads
Thread Forum
Lost WiFi icon connection after some unkown children change
OS= Win 7 64bits Home Premium (French) Hi, Until yesterday, everything worked fine, but I let my laptop to my children and ... I lost Wifi Icon for another type of icon, I mean the small icon between volume and hour (see "Win7 network.jpg"). Usually, I could view all possible Wifi...
Network & Sharing
Lost my HP Touchsmart LOGO since I lost resetted my BIOS (I guess)
Hi All I have a HP Touchsmart 300-1060a (Home Premium Windows 7 64 BIT) which I bought few years back. Now for the last 6 months or so I started getting issues with my machine was not displaying anything at all after turning it on. So I had to hard reset my power from the machine and then...
Hardware & Devices
Linux to Windows 7 change and lost my cd
I have a Sony Vaio VPCEB 15-FA. Everything works fine on Linux but, I need to run Windows 7 for some new required work. When I load the 7 the system does not recognize the cd drive. It works fine under Linux. I have reformatted, loaded Windows 7 only etc but, it still does not work. I assumt...
General Discussion
XP Mode Autologon credentials are lost after Windows 7 password change
When the old Windows 7 password expires, the user has to change it during the normal logon. The problem is that after this type of the password change the saved XP Mode autologon credentials are removed from Windows 7 Windows Vault Generic Credentials group. As a consequence the user gets a...
Virtualization
Lost being able to change default music player
I seem to have lost the ability to have a default (say winamp player to play MP3).. I have gone thro all the link instructions here in the forum. makes no difference when I reset the defaut I click use etc on and off and then on again to make sure its on.. I save changes to program setting etc...
Music, Pictures & Video
Lost Dual Boot Screen?...Lost Windows 7
I have Vista Home Premium 64 bit and I downloaded 64 Bit RC Windows 7 and did a clean install on another partition of my hard drive. Dual boot was working for about 4 days then all of a sudden it doesnt come up any more. The partition is still there with Windows 7 installed on it but its not...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App