Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX 6950 driver hell! Which version works?

21 Feb 2011   #1
psychotron

Home 7 64 on Alienware and Asus. W8 on Lenovo.
 
 
XFX 6950 driver hell! Which version works?

I just completed my new build and everything went great. W7 started up and I began the mobo driver updates and extras that come on the Crosshair 4F disk. I put in the AMD Radeon graphics driver disk and it told me the version on the disk was old and to download the new one, I chose the version for W7 64, I believe it was 11.1 or .2, downloaded and installed, reboot and the black screen of death. I could tell windows was there, I even typed in my password and hit enter but then the windows logo just sat there and stayed, nothing else. I had to go into safe mode and "roll back" the drivers, after I tried to update them in device manager which failed, then it loaded up and displayed fine after the roll back but told me the proper drivers are not found and I should install the latest ones which I had just done. I then just decided to install the ones straight from the dvd, installed, reboot and same black screen. Did the safe mode thing again just so I could get online to search for the cure, I cannot find one. I tried the last three versions of drivers going back by date, no go. I said F-it and with no security logged into here to post this. My specs are in my profile, but I know all my parts are compatible with each other. What version of drivers should I try? All installs on the crosshair disk went fine, many reboots with the display and W7 starting up fine. It was not until I installed the AMD drivers for my video card that the black screen started. Hardware build went great, software build no going so well. Any advice appreciated.

Current version video card drivers are 8.801.0.0 I can longer "roll back" so I'm stuck in safe mode.


My System SpecsSystem Spec
.
21 Feb 2011   #2
Sardonicus

Windows 7 Home Premium 64 bit
 
 

This is the link, maybe try it again
ATI Radeon

Try just the driver
http://sites.amd.com/us/game/downloa...win7-64.aspx#2
My System SpecsSystem Spec
21 Feb 2011   #3
psychotron

Home 7 64 on Alienware and Asus. W8 on Lenovo.
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
This is the link, maybe try it again
ATI Radeon

Try just the driver
ATI Radeon
Yep, did both newer versions already, I beleive one is missing APP which is opencl I think, the other is the full version, neither worked. I'd love to try just the driver but in safe mode it refuses to install. I'm in network safe mode, if I downloaded it and switched to command prompt safe mode may it work? No idea, I've been at this for many hours and don't have much left in me. I may just RMA the card and try a new one, replacing and installing new drivers has never been this difficult for me before.
My System SpecsSystem Spec
.

21 Feb 2011   #4
Sardonicus

Windows 7 Home Premium 64 bit
 
 

I know you probably already checked, but are you power connections to the card, OK?
My System SpecsSystem Spec
21 Feb 2011   #5
psychotron

Home 7 64 on Alienware and Asus. W8 on Lenovo.
 
 

I believe so. My card has two 6-pin pci-e power adapters and both are snug. My PSU is 850watt with good amps so I know that's not the issue. My next idea though is to just disconnect the card entirely and reattach it and see what happens. I really can't think of anything else to do.

I'm going to reinstall W7 first, then do all the updates and try the new 11.1 driver package. I'll let you know.
My System SpecsSystem Spec
21 Feb 2011   #6
Sardonicus

Windows 7 Home Premium 64 bit
 
 

That sound's like a good idea.
My System SpecsSystem Spec
21 Feb 2011   #7
Shark007

Windows 7 Ultimate 64bit
 
 

Disconnect any secondary display device such as a TV/projector etc (if you have one connected).
My System SpecsSystem Spec
21 Feb 2011   #8
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

recommend you read this guide:
TweakGuides.com - ATI Catalyst Tweak Guide

- make sure that you have .NET Framework installed..
- do a complete removal of all existing ATI drivers,
- scrub the system with CCleaner and start again from scratch
- it's a bit fussy but the guide gives full instructions..
My System SpecsSystem Spec
21 Feb 2011   #9
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

If the problems persist, the reason I still use XFX is because of their good rma policy.
They will put you through some steps, but if the card continues to give you issue they will accept a rma and are rather quick about it too. When I got this 5850, the first one had a strange performance issue and would sometimes not detect on the system at boot.
I had a replacement 7 days later. With a much more recent revision that has worked beyond expectation ever since.

You also may need a bios update, ASUS released a lot of bios updates for support of the 5xxx and 6xxx cards.

I've been in the same situation as you very recently, bios update first.
I don't normally recommend them, but in this situation I believe you may NEED it.
My System SpecsSystem Spec
21 Feb 2011   #10
psychotron

Home 7 64 on Alienware and Asus. W8 on Lenovo.
 
 

Quote   Quote: Originally Posted by Shark007 View Post
Disconnect any secondary display device such as a TV/projector etc (if you have one connected).
I tried the easiest solution first and what do you know, it worked. Thanks a million.

I did have my second monitor connected via HDMI and I just disconnected it and reinstalled new driver package and boom, worked. On restart my screen did freeze and I had to hard start it but I had to download and install a few more updates where I had to restart a few times and it works great. Funny thing is, now when pc is on I reattached my second monitor via HDMI and the screen froze, I disconnected it and it went back to normal. What's with that? Now I'm going to have to troubleshoot and maybe start another topic on how the heck I can get my second monitor to work, not to mention my third which I bought a DVI-mini Display Port adapter for because I was told to run three monitors independently on W7 I needed the third to run off one of the two mini Port Displays instead of my second DVI.

Thanks again. Will be sure to give you a bump or whatever they call it on here.
My System SpecsSystem Spec
Reply

 XFX 6950 driver hell! Which version works?




Thread Tools




Similar help and support threads
Thread Forum
How a Firewall works (simplified version).
How a Firewall works (simplified version) Welcome to my second guide in Seven Forums. Before we begin... In computer networking, we all know the term "Firewall". Before we get into "what is firewall" question, I'd like to explain about frames and packets. If you read my previous guide...
Security Basics
Spider Solitaire - XP Version Works
Hi all Fairly trivial post but I know people still like playing these Windows games. This isn't really "Gaming" as it's just a post about those little card games included with Windows. I quite like Spider Solitaire but I HATED the card designs in the VISTA and W7 versions. Howver the...
Gaming
amd radeon 6950 catalyst/driver errors
hi, im trying to run three hanns hz281s off a radeon 6950 and trying to run just the one atm straight from the gpu. Catalyst 11.6 and 11.5 wont show up in the programs after attempting installation. http://i1182.photobucket.com/albums/x450/johnwhtt/3.png...
Drivers
HP printer driver hell
I have an HP Laserjet 4250 printer. Windows Update attempted to install the latest PCL6 driver over the original shipping PCL5 driver. That install failed. As per MS's instructions, I attempted to install HP's printer driver. This resulted in a new printer driver, Universal Printing PCL6,...
Hardware & Devices
ATI Driver Hell
I downloaded latest vista drivers for my 7 installation(Catalyst 9.2). And when it tries to install the driver.It doesn't install.The Installation fails.Please Help!!!! Current Driver:ATI Windows 7 Beta Driver
Graphic Cards
Trying to avoid driver hell... Which network card should I purchase?
I am wondering which network to purchase so that I don't have driver issues with win 7. Anyone know a good card?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App